# Cluster keeps doing something after node failure

**URL:** <https://discuss.elastic.co/t/cluster-keeps-doing-something-after-node-failure/23340>\
**Category:** Elasticsearch\
**Created:** [April 21, 2015, 10:19am UTC](https://discuss.elastic.co/t/cluster-keeps-doing-something-after-node-failure/23340 "2015-04-21T10:19:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Anton\_Martynenko](https://avatars.discourse-cdn.com/v4/letter/a/2acd7d/32.png) [@Anton\_Martynenko](https://discuss.elastic.co/u/Anton_Martynenko)\
**Post date:** [April 21, 2015, 10:19am UTC](https://discuss.elastic.co/t/cluster-keeps-doing-something-after-node-failure/23340/1 "2015-04-21T10:19:31Z")

</div>

Hi guys,  
We are running a cluster with 3 nodes in prod. After a node failure cluster  
started index reallocation. This process took several days with small  
pauses (for hours each). When the process finished the cluster looked fine

- everything worked fast, workload was pretty low. After several days the  
"rebalancing" or something else started again. The node 01 (which failed  
earlier) has almost 100% CPU load and network traffic ~100 mbit from node  
02 to node 01. The problem is that we have issues with ElasticSearch for  
more that a week!

I have two questions

1. What and why elasticsearch is doing?
2. Why ES started "doing something" again after \>24h pause?
3. How to stop this process or understand when it gets finished? Our cliens  
are not happy with this terrible lags while ES is doing something

I've attached a screenshot from Zabbix and our ES config which is equal for  
all nodes.

Thanks in advance for any help

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/e238363d-a947-4a8b-8a84-203452edf073%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/e238363d-a947-4a8b-8a84-203452edf073%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:18am UTC](https://discuss.elastic.co/t/cluster-keeps-doing-something-after-node-failure/23340/2 "2017-07-06T00:18:35Z")

</div>


