# Cluster.name:: command not found

**URL:** <https://discuss.elastic.co/t/cluster-name-command-not-found/213196>\
**Category:** Elasticsearch\
**Created:** [December 27, 2019, 2:01pm UTC](https://discuss.elastic.co/t/cluster-name-command-not-found/213196 "2019-12-27T14:01:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Juan\_Andres\_Ramirez](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_andres_ramirez/32/9467_2.png) [@Juan\_Andres\_Ramirez](https://discuss.elastic.co/u/Juan_Andres_Ramirez)\
**Post date:** [December 27, 2019, 2:01pm UTC](https://discuss.elastic.co/t/cluster-name-command-not-found/213196/1 "2019-12-27T14:01:45Z")

</div>

Hello guys,  
I tried start elasticsearch version 7.5 in a RedHat 7, but I have the following error:

> Dec 27 13:48:39 ip-10-142-122-229.cl.latam elasticsearch[12964]: /etc/sysconfig/elasticsearch: line 17: cluster.name:: command not found  
> Dec 27 13:48:39 ip-10-142-122-229.cl.latam systemd[1]: elasticsearch.service: main process exited, code=exited, status=127/n/a  
> Dec 27 13:48:39 ip-10-142-122-229.cl.latam systemd[1]: Failed to start Elasticsearch.  
> Dec 27 13:48:39 ip-10-142-122-229.cl.latam systemd[1]: Unit elasticsearch.service entered failed state.  
> Dec 27 13:48:39 ip-10-142-122-229.cl.latam systemd[1]: elasticsearch.service failed.

In my elasticsearch.yml, I have the line:

> cluster.name: cluster-elk

So, IDK why this error.

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 24, 2020, 2:01pm UTC](https://discuss.elastic.co/t/cluster-name-command-not-found/213196/2 "2020-01-24T14:01:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
