# Cluster service failed to start if node missing license plugin

**URL:** <https://discuss.elastic.co/t/cluster-service-failed-to-start-if-node-missing-license-plugin/26200>\
**Category:** Elasticsearch\
**Created:** [July 24, 2015, 3:16am UTC](https://discuss.elastic.co/t/cluster-service-failed-to-start-if-node-missing-license-plugin/26200 "2015-07-24T03:16:43Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sumithub](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sumithub/32/461_2.png) [@sumithub](https://discuss.elastic.co/u/sumithub)\
**Post date:** [July 24, 2015, 3:16am UTC](https://discuss.elastic.co/t/cluster-service-failed-to-start-if-node-missing-license-plugin/26200/1 "2015-07-24T03:16:43Z")

</div>

Hi,

Today I faced with an issue where one of the newly added node was missing elastic latest license. The other nodes in the cluster has watcher evaluation plugin installed along with latest elastic license plugin. When I started the new node without having installed the license plugin which I thought was not necessary, the node started fine but failed to discover other nodes in the cluster. The other nodes successfully detected new node. After debugging the issue for few hours I installed elastic-license plugin to new node without watcher and everything worked fine.

My question is

1. Why it's necessary to add elastic-license even if you don't need watcher installed on new node?

2. The most frustrating part is no error or warning message in either new or old nodes about the license which makes it very hard what's the cause of the issue.

It would be great if someone could answer my queries.

Cheers,  
Sumit

---

<div class="post-metadata">

**Author:** ![ave19](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ave19/32/11631_2.png) [@ave19](https://discuss.elastic.co/u/ave19)\
**Post date:** [January 29, 2016, 10:22pm UTC](https://discuss.elastic.co/t/cluster-service-failed-to-start-if-node-missing-license-plugin/26200/2 "2016-01-29T22:22:11Z")

</div>

We just hit this, too. We installed 'license' for 'marvel-agent'. We added a search node without the plugins and it could not find the master. We added the 'license' plugin and it started working.

Not documented!

Very frustrating!

---

<div class="post-metadata">

**Author:** ![DmitriyR](https://avatars.discourse-cdn.com/v4/letter/d/b5e925/32.png) [@DmitriyR](https://discuss.elastic.co/u/DmitriyR)\
**Post date:** [December 13, 2016, 3:53pm UTC](https://discuss.elastic.co/t/cluster-service-failed-to-start-if-node-missing-license-plugin/26200/3 "2016-12-13T15:53:44Z")

</div>

Hi. So, I can't remove license plugin on my cluster. I should stop all nodes, remove plugin and start all nodes at the same time?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:05pm UTC](https://discuss.elastic.co/t/cluster-service-failed-to-start-if-node-missing-license-plugin/26200/4 "2017-07-05T22:05:01Z")

</div>


