# Cold data node is not starting after restart the ES service 7.7.0

**URL:** https://discuss.elastic.co/t/cold-data-node-is-not-starting-after-restart-the-es-service-7-7-0/281474
**Category:** Elasticsearch
**Created:** [August 15, 2021, 7:32am UTC](https://discuss.elastic.co/t/cold-data-node-is-not-starting-after-restart-the-es-service-7-7-0/281474 "2021-08-15T07:32:09Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![alicango](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alicango/32/84498_2.png) [@alicango](https://discuss.elastic.co/u/alicango)
#### Post date: [August 15, 2021, 7:32am UTC](https://discuss.elastic.co/t/cold-data-node-is-not-starting-after-restart-the-es-service-7-7-0/281474/1 "2021-08-15T07:32:09Z")

</div>

Hi,

I am getting below exception after restart the ES service;

```auto
journalctl -xe

```

```auto
systemd-entrypoint[4842]: Exception in thread "main" org.apache.lucene.index.CorruptIndexException: codec header mismatch: actual header=1071082590 vs expected header=10710>
systemd-entrypoint[4842]: at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:196)
systemd-entrypoint[4842]: at org.elasticsearch.common.settings.KeyStoreWrapper.load(KeyStoreWrapper.java:224)
systemd-entrypoint[4842]: at org.elasticsearch.common.settings.HasPasswordKeyStoreCommand.execute(HasPasswordKeyStoreCommand.java:42)
Aug 15 08:15:01 lon-elk-cold-1 systemd-entrypoint[4842]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
systemd-entrypoint[4842]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
systemd-entrypoint[4842]: at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:91)
systemd-entrypoint[4842]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
systemd-entrypoint[4842]: at org.elasticsearch.cli.Command.main(Command.java:90)
systemd-entrypoint[4842]: at org.elasticsearch.common.settings.KeyStoreCli.main(KeyStoreCli.java:43)
systemd-entrypoint[4842]: Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: org.apache.lucene.index.CorruptIndexException: codec header mismatch: a>
Aug 15 08:15:02 lon-elk-cold-1 systemd-entrypoint[4842]: Likely root cause: org.apache.lucene.index.CorruptIndexException: codec header mismatch: actual header=1071082590 vs expected header=1071082519 (r>
systemd-entrypoint[4842]: at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:196)
systemd-entrypoint[4842]: at org.elasticsearch.common.settings.KeyStoreWrapper.load(KeyStoreWrapper.java:224)
systemd-entrypoint[4842]: at org.elasticsearch.bootstrap.Bootstrap.loadSecureSettings(Bootstrap.java:240)
systemd-entrypoint[4842]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349)
systemd-entrypoint[4842]: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170)
systemd-entrypoint[4842]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161)
systemd-entrypoint[4842]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
systemd-entrypoint[4842]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
systemd-entrypoint[4842]: at org.elasticsearch.cli.Command.main(Command.java:90)
systemd-entrypoint[4842]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)
systemd-entrypoint[4842]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)
systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
systemd[1]: Failed to start Elasticsearch.
-- Subject: Unit elasticsearch.service has failed

```

Do you prefer to reinstall the ES?

---

<div class="post-metadata">

### Author: ![alicango](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alicango/32/84498_2.png) [@alicango](https://discuss.elastic.co/u/alicango)
#### Post date: [August 15, 2021, 8:17am UTC](https://discuss.elastic.co/t/cold-data-node-is-not-starting-after-restart-the-es-service-7-7-0/281474/3 "2021-08-15T08:17:59Z")

</div>

Thanks for the experience but no need to reduce them for my case. I have plenty of RAM and Disk size.

---

<div class="post-metadata">

### Author: ![alicango](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alicango/32/84498_2.png) [@alicango](https://discuss.elastic.co/u/alicango)
#### Post date: [August 15, 2021, 10:29am UTC](https://discuss.elastic.co/t/cold-data-node-is-not-starting-after-restart-the-es-service-7-7-0/281474/4 "2021-08-15T10:29:51Z")

</div>

Hi we solved by apply these steps;

```auto
/usr/share/elasticsearch/bin/elasticsearch-keystore create -p
/usr/share/elasticsearch/bin/elasticsearch-keystore passwd
systemctl restart elasticsearch

```

Thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 12, 2021, 10:30am UTC](https://discuss.elastic.co/t/cold-data-node-is-not-starting-after-restart-the-es-service-7-7-0/281474/5 "2021-09-12T10:30:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
