# Config Files contains non-ascii charaters

**URL:** <https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847>\
**Category:** Logstash\
**Created:** [October 25, 2016, 8:44am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847 "2016-10-25T08:44:09Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![saunderstd](https://avatars.discourse-cdn.com/v4/letter/s/7ab992/32.png) [@saunderstd](https://discuss.elastic.co/u/saunderstd)\
**Post date:** [October 25, 2016, 8:44am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847/1 "2016-10-25T08:44:09Z")

</div>

Morning  
I have two issues. One that the logs are not being populated in kibana and the second is that I am throwing errors shown below. Any help is appreciated.

An unexpected error occurred! {:error=\>#\<RuntimeError: The following config files contains non-ascii characters but are not UTF-8 encoded ["/etc/logstash/conf.d/beats-dashboards-1.1.0.zip"]\>, :class=\>"RuntimeError", :backtrace=\>["/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/config/loader.rb:81:in `local_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/config/loader.rb:37:in`load\_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/config/loader.rb:17:in `format_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/agent.rb:185:in`execute'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/runner.rb:94:in `run'", "org/jruby/RubyProc.java:281:in`call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/runner.rb:99:in `run'", "org/jruby/RubyProc.java:281:in`call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/stud-0.0.22/lib/stud/task.rb:24:in `initialize'"], :level=\>:warn}

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [October 25, 2016, 9:34am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847/2 "2016-10-25T09:34:48Z")

</div>

Did your stacktrace really say just `:error=>#`? Not `:error=>#<some error message>`? Format the stacktrace as preformatted text to avoid munging.

---

<div class="post-metadata">

**Author:** ![saunderstd](https://avatars.discourse-cdn.com/v4/letter/s/7ab992/32.png) [@saunderstd](https://discuss.elastic.co/u/saunderstd)\
**Post date:** [October 25, 2016, 11:08am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847/3 "2016-10-25T11:08:32Z")

</div>

An unexpected error occurred! {:error=\>#\<RuntimeError: The following config files contains non-ascii characters but are not UTF-8 encoded ["/etc/logstash/conf.d/beats-dashboards-1.1.0.zip"]\>, :class=\>"RuntimeError", :backtrace=\>["/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/config/loader.rb:81:in `local_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/config/loader.rb:37:in`load\_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/config/loader.rb:17:in `format_config'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/agent.rb:185:in`execute'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/runner.rb:94:in `run'", "org/jruby/RubyProc.java:281:in`call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.4.0-java/lib/logstash/runner.rb:99:in `run'", "org/jruby/RubyProc.java:281:in`call'", "/opt/logstash/vendor/bundle/jruby/1.9/gems/stud-0.0.22/lib/stud/task.rb:24:in `initialize'"], :level=\>:warn}

---

<div class="post-metadata">

**Author:** ![saunderstd](https://avatars.discourse-cdn.com/v4/letter/s/7ab992/32.png) [@saunderstd](https://discuss.elastic.co/u/saunderstd)\
**Post date:** [October 25, 2016, 11:11am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847/4 "2016-10-25T11:11:25Z")

</div>

service logstash configtest  
is the command I ran that received the error from. When looking at Kibana the logs are not being populated. The intent is to setup the local server first then add the others systems to it.

---

<div class="post-metadata">

**Author:** ![saunderstd](https://avatars.discourse-cdn.com/v4/letter/s/7ab992/32.png) [@saunderstd](https://discuss.elastic.co/u/saunderstd)\
**Post date:** [October 25, 2016, 11:50am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847/5 "2016-10-25T11:50:14Z")

</div>

Morning sir,  
The problem was that beats-dashboards-1.1.0.zip was in the  
the /etc/logstash/conf.d folder. I removed that and re-ran the config test which came back "Okay".  
v/r  
T

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:32am UTC](https://discuss.elastic.co/t/config-files-contains-non-ascii-charaters/63847/6 "2017-07-06T04:32:52Z")

</div>


