# Configuration error in filebeat in logstash

**URL:** <https://discuss.elastic.co/t/configuration-error-in-filebeat-in-logstash/123373>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [March 10, 2018, 6:45am UTC](https://discuss.elastic.co/t/configuration-error-in-filebeat-in-logstash/123373 "2018-03-10T06:45:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Abdur\_Raqeeb1](https://avatars.discourse-cdn.com/v4/letter/a/fbc32d/32.png) [@Abdur\_Raqeeb1](https://discuss.elastic.co/u/Abdur_Raqeeb1)\
**Post date:** [March 10, 2018, 6:45am UTC](https://discuss.elastic.co/t/configuration-error-in-filebeat-in-logstash/123373/1 "2018-03-10T06:45:06Z")

</div>

Hi,

I am getting the below error after starting the filebeat

2018-03-10T06:29:01Z INFO Error publishing events (retrying): write tcp Agent-IP:46906-\>ELK-IP:5044: write: broken pipe  
2018-03-10T06:29:24Z INFO Non-zero metrics in the last 30s: libbeat.logstash.call\_count.PublishEvents=1 libbeat.logstash.publish.write\_bytes=40140 libbeat.logstash.publish.write\_errors=1 libbeat.logstash.published\_but\_not\_acked\_events=1998  
2018-03-10T06:29:54Z INFO No non-zero metrics in the last 30s  
2018-03-10T06:30:01Z ERR Failed to publish events (host: ELK-IP:5044:10200), caused by: write tcp Agent-IP:46998-\>ELK-IP:5044: write: connection reset by peer  
2018-03-10T06:30:01Z INFO Error publishing events (retrying): write tcp Agent-IP:46998-\>ELK-IP:5044: write: connection reset by peer  
2018-03-10T06:30:24Z INFO Non-zero metrics in the last 30s: libbeat.logstash.call\_count.PublishEvents=1 libbeat.logstash.publish.write\_bytes=40140 libbeat.logstash.publish.write\_errors=1 libbeat.logstash.published\_but\_not\_acked\_events=1998  
2018-03-10T06:30:54Z INFO No non-zero metrics in the last 30s  
2018-03-10T06:31:02Z ERR Failed to publish events (host: ELK-IP:5044:10200), caused by: write tcp Agent-IP:47090-\>ELK-IP:5044: write: broken pipe

Request you to please check and suggest the same.

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [March 12, 2018, 10:41am UTC](https://discuss.elastic.co/t/configuration-error-in-filebeat-in-logstash/123373/2 "2018-03-12T10:41:13Z")

</div>

It seems there is a problem with sending the data to Logstash. Please share your Filebeat version, config file and the Logstash config.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 9, 2018, 10:41am UTC](https://discuss.elastic.co/t/configuration-error-in-filebeat-in-logstash/123373/3 "2018-04-09T10:41:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
