# Configuration error in Logstash under Kubernetes

**URL:** <https://discuss.elastic.co/t/configuration-error-in-logstash-under-kubernetes/154348>\
**Category:** Logstash\
**Created:** [October 28, 2018, 3:46pm UTC](https://discuss.elastic.co/t/configuration-error-in-logstash-under-kubernetes/154348 "2018-10-28T15:46:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![tomerl](https://avatars.discourse-cdn.com/v4/letter/t/7ab992/32.png) [@tomerl](https://discuss.elastic.co/u/tomerl)\
**Post date:** [October 28, 2018, 3:46pm UTC](https://discuss.elastic.co/t/configuration-error-in-logstash-under-kubernetes/154348/1 "2018-10-28T15:46:23Z")

</div>

Hi,  
I'm trying to deploy logstash in my Kubernetes environment using the stable helm chart: [https://github.com/helm/charts/blob/master/stable/logstash](https://github.com/helm/charts/blob/master/stable/logstash)

Using the default values, everything works fine, but when I've tried to use _date_ filter, I've started to receive the following error:

`[2018-10-28T15:41:04,793][ERROR][logstash.agent] Failed to execute action {:action=&amp;gt;LogStash::PipelineAction::Create/pipeline_id:main, :exception=&amp;gt;"LogStash::ConfigurationError", :message=&amp;gt;"translation missing: en.logstash.agent.configuration.invalid_plugin_register", :backtrace=&amp;gt;["/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-filter-date-3.1.9/lib/logstash/filters/date.rb:160:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/plugins/plugin\_factory.rb:36:in `filter_delegator'", "/usr/share/logstash/logstash-core/lib/logstash/plugins/plugin_factory.rb:95:in`plugin'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:110:in `plugin'", "(eval):8:in`&lt;eval&gt;'", "org/jruby/RubyKernel.java:994:in `eval'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:82:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:167:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:40:in`execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:305:in `block in converge_state'"]}`

This is the section that creates the filter:  
filters:  
main: |-  
filter {  
date {  
match =\> ["MMM dd yyyy HH:mm:ss"]  
}  
}

Any idea why it's not working?

---

<div class="post-metadata">

**Author:** ![tomerl](https://avatars.discourse-cdn.com/v4/letter/t/7ab992/32.png) [@tomerl](https://discuss.elastic.co/u/tomerl)\
**Post date:** [October 29, 2018, 1:45pm UTC](https://discuss.elastic.co/t/configuration-error-in-logstash-under-kubernetes/154348/2 "2018-10-29T13:45:25Z")

</div>

Issue solved

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 26, 2018, 1:45pm UTC](https://discuss.elastic.co/t/configuration-error-in-logstash-under-kubernetes/154348/3 "2018-11-26T13:45:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
