# Configuration is invalid

**URL:** https://discuss.elastic.co/t/configuration-is-invalid/159518
**Category:** Logstash
**Created:** [December 5, 2018, 11:35am UTC](https://discuss.elastic.co/t/configuration-is-invalid/159518 "2018-12-05T11:35:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ruthvik\_Sai](https://avatars.discourse-cdn.com/v4/letter/r/a587f6/32.png) [@Ruthvik\_Sai](https://discuss.elastic.co/u/Ruthvik_Sai)
#### Post date: [December 5, 2018, 11:35am UTC](https://discuss.elastic.co/t/configuration-is-invalid/159518/1 "2018-12-05T11:35:16Z")

</div>

Hi friends,

I am getting the following error:

C:\logstash\bin\>logstash -f appname\_modifier.conf --config.test\_and\_exit  
Sending Logstash logs to C:/logstash/logs which is now configured via log4j2.properties  
[2018-12-05T16:59:11,767][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2018-12-05T16:59:13,206][FATAL][logstash.runner] The given configuration is invalid. Reason: Expected one of #, {, ,, ] at line 10, column 13 (byte 173) after filter {  
mutate {  
gsub =\> [  
"event\_data.NewProcessName", ".OUTLOOK.\*", "outlook.exe"

[2018-12-05T16:59:13,257][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

My logstash configuration is as follows:

input {  
beats {  
port =\> "5044"  
}  
}  
filter {  
mutate {  
gsub =\> ["event\_data.NewProcessName", ".OUTLOOK._", "outlook.exe"]  
#"event\_data.NewProcessName", ".WINWORD._", "word.exe"  
}  
}  
output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
}  
}

Can you pls help me in resolving the error?

thanks in advance

---

<div class="post-metadata">

### Author: ![Ruthvik\_Sai](https://avatars.discourse-cdn.com/v4/letter/r/a587f6/32.png) [@Ruthvik\_Sai](https://discuss.elastic.co/u/Ruthvik_Sai)
#### Post date: [December 11, 2018, 10:31am UTC](https://discuss.elastic.co/t/configuration-is-invalid/159518/2 "2018-12-11T10:31:11Z")

</div>

Can someone please help me in understanding what could be the cause of the error so that I know how to progress??

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 8, 2019, 10:43am UTC](https://discuss.elastic.co/t/configuration-is-invalid/159518/3 "2019-01-08T10:43:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
