# Configure a custom s3 repository

**URL:** <https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342>\
**Category:** Elasticsearch\
**Tags:** snapshot-and-restore\
**Created:** [November 11, 2024, 5:49pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342 "2024-11-11T17:49:17Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![mahdi\_darvishiyan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mahdi_darvishiyan/32/139114_2.png) [@mahdi\_darvishiyan](https://discuss.elastic.co/u/mahdi_darvishiyan)\
**Post date:** [November 11, 2024, 5:49pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342/1 "2024-11-11T17:49:17Z")

</div>

i have a custom s3 server that is not aws and although I write configs in elasticsearch.yml and store keys in elasticsearch keystore still not be able to connect to my s3 bucket

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [November 11, 2024, 6:54pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342/2 "2024-11-11T18:54:04Z")

</div>

Have you gone through [this section in the documentation](https://www.elastic.co/guide/en/elasticsearch/reference/current/repository-s3.html#repository-s3-compatible-services)?

Which version of Elasticsearch are you using? What is the backing technology for your S3 server? What is the error you are getting? What does the configuration look like?

If you answer these questions and provide more detail maybe there is someone around with experience from the same technology that can help you.

---

<div class="post-metadata">

**Author:** ![mahdi\_darvishiyan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mahdi_darvishiyan/32/139114_2.png) [@mahdi\_darvishiyan](https://discuss.elastic.co/u/mahdi_darvishiyan)\
**Post date:** [November 11, 2024, 7:13pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342/3 "2024-11-11T19:13:28Z")

</div>

yes check it and make all configuration according to s3 configs and my elasticsearch is 8.15  
and get error like this

```auto
{
  "error": {
    "root_cause": [
      {
        "type": "repository_verification_exception",
        "reason": "[my_backup] path is not accessible on master node"
      }
    ],
    "type": "repository_verification_exception",
    "reason": "[my_backup] path is not accessible on master node",
    "caused_by": {
      "type": "i_o_exception",
      "reason": "Unable to upload object [tests-f0L3sYVYTZGmNblB5sa-gQ/master.dat] using a single upload",
      "caused_by": {
        "type": "sdk_client_exception",
        "reason": "Failed to connect to service endpoint: ",
        "caused_by": {
          "type": "socket_timeout_exception",
          "reason": "Connect timed out"
        }
      }
    }
  },
  "status": 500
}

```

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 11, 2024, 7:34pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342/4 "2024-11-11T19:34:16Z")

</div>

> [@mahdi\_darvishiyan](#):
>
> ```auto
> "caused_by": {
> "type": "sdk_client_exception",
> "reason": "Failed to connect to service endpoint: ",
> "caused_by": {
> "type": "socket_timeout_exception",
> "reason": "Connect timed out"
> }
> }
> 
> ```

This seems to be a connection issue.

Please share the configuration you are using.

Also, you need to provide more context about the backing technology of your s3 server.

---

<div class="post-metadata">

**Author:** ![mahdi\_darvishiyan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mahdi_darvishiyan/32/139114_2.png) [@mahdi\_darvishiyan](https://discuss.elastic.co/u/mahdi_darvishiyan)\
**Post date:** [November 11, 2024, 7:50pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342/5 "2024-11-11T19:50:27Z")

</div>

i could solve it by panel  
in this address  
..../app/management/data/snapshot\_restore/edit\_repository/s3  
with my client config name is minio but still not in dev tool  
........./app/dev\_tools

---

<div class="post-metadata">

**Author:** ![mahdi\_darvishiyan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mahdi_darvishiyan/32/139114_2.png) [@mahdi\_darvishiyan](https://discuss.elastic.co/u/mahdi_darvishiyan)\
**Post date:** [November 11, 2024, 7:58pm UTC](https://discuss.elastic.co/t/configure-a-custom-s3-repository/370342/6 "2024-11-11T19:58:53Z")

</div>

i figure it out in dev-tool i should add

```auto
PUT /_snapshot/my_s3_backup
{
  "type": "s3",
  "settings": {
     "client": "minio",
    "bucket": "test"
  }
}

```

```
 "client": "minio",

```

to code part
