# Configure filebeat nginx module with ansible role

**URL:** https://discuss.elastic.co/t/configure-filebeat-nginx-module-with-ansible-role/264661
**Category:** Beats
**Tags:** beats-module, filebeat
**Created:** [February 18, 2021, 8:26am UTC](https://discuss.elastic.co/t/configure-filebeat-nginx-module-with-ansible-role/264661 "2021-02-18T08:26:50Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![elster](https://avatars.discourse-cdn.com/v4/letter/e/dbc845/32.png) [@elster](https://discuss.elastic.co/u/elster)
#### Post date: [February 18, 2021, 8:42pm UTC](https://discuss.elastic.co/t/configure-filebeat-nginx-module-with-ansible-role/264661/2 "2021-02-18T20:42:35Z")

</div>

I got it installed properly meanwhile, however I am now getting error:

```auto
Failed to connect to backoff(elasticsearch(https://*.eu-central-1.es.amazonaws.com:443/)): Connection marked as failed because the onConnect callback failed: cannot retrieve the elasticsearch license from the /_license endpoint, Filebeat requires the default distribution of Elasticsearch. Please make the endpoint accessible to Filebeat so it can verify the license.: unauthorized access, could not connect to the xpack endpoint, verify your credentials

```

It seems to be the problem described in this post [Filebeat doesn't work with AWS ES domain](https://discuss.elastic.co/t/filebeat-doesnt-work-with-aws-es-domain/255683) (oss version of filebeat has to be used) so now my question is is it possible to customize [GitHub - elastic/ansible-beats: Ansible Beats Role](https://github.com/elastic/ansible-beats) so that the oss version is installed?

Thanks and br,  
Elmar

---

_[View the full topic](https://discuss.elastic.co/t/configure-filebeat-nginx-module-with-ansible-role/264661)._
