# Configuring pipeline in filebeat module - nginx

**URL:** <https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 1, 2019, 10:52am UTC](https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561 "2019-01-01T10:52:00Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![crazywizard](https://avatars.discourse-cdn.com/v4/letter/c/85f322/32.png) [@crazywizard](https://discuss.elastic.co/u/crazywizard)\
**Post date:** [January 1, 2019, 10:52am UTC](https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561/1 "2019-01-01T10:52:01Z")

</div>

I'm trying to figure out how to configure a pipeline in my nginx filebeat module.

This link [https://www.elastic.co/guide/en/beats/filebeat/master/configuring-ingest-node.html](https://www.elastic.co/guide/en/beats/filebeat/master/configuring-ingest-node.html) shows a general top-level configuration for all filebeats. This however is not ideal for me since it shows pre-processing errors for all other logs that fail the grok.

I have scoured the docs finding this [https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-input-log.html](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-input-log.html) which I used to add an entry to my nginx.yml module configuration as so

```
- module: nginx
  # Access logs
  access:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    #var.paths:
    pipeline: filebeat-6.4.3-nginx-access-custom

  # Error logs
  error:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    #var.paths:

```

I restarted filebeat but this still doesn't take effect. I know my pipeline is correct because I have tested with the `_simulate` endpoint and have even overridden the default nginx pipeline and it worked as expected.

---

<div class="post-metadata">

**Author:** ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)\
**Post date:** [January 2, 2019, 11:15am UTC](https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561/2 "2019-01-02T11:15:19Z")

</div>

Hi @crazywizard

I'm not sure about what error you may have. Please, ensure that the ingest node is [not disabled](https://www.elastic.co/guide/en/elasticsearch/reference/master/ingest.html). Also take a look in the same link that talks about the pipeline endpoint.

Just to double check, your pipeline must be `PUT` on ES [https://www.elastic.co/guide/en/elasticsearch/reference/master/put-pipeline-api.html](https://www.elastic.co/guide/en/elasticsearch/reference/master/put-pipeline-api.html)

I hope this helps.

---

<div class="post-metadata">

**Author:** ![crazywizard](https://avatars.discourse-cdn.com/v4/letter/c/85f322/32.png) [@crazywizard](https://discuss.elastic.co/u/crazywizard)\
**Post date:** [January 2, 2019, 12:41pm UTC](https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561/3 "2019-01-02T12:41:36Z")

</div>

Thanks for your response @Mario_Castro . I'm using the cloud offering, so not sure of the default ingest node setting for that.

As I mentioned previously, the pipeline was executed and created correctly and I even tested this with `_simulate` endpoint. For completeness, here is the request used

> <https://gist.github.com/davyngugi/d0f763e667c82b91309af3795fc01ff4>

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [January 2, 2019, 2:12pm UTC](https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561/4 "2019-01-02T14:12:35Z")

</div>

I think your configuration is incorrect. You need to add `input` to pass options properly.

```auto
- module: nginx
  # Access logs
  access:
    enabled: true
    input:
      pipeline: filebeat-6.4.3-nginx-access-custom

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 30, 2019, 2:12pm UTC](https://discuss.elastic.co/t/configuring-pipeline-in-filebeat-module-nginx/162561/5 "2019-01-30T14:12:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
