# Connect APM Server OSS with AWS Elasticsearch 7.10

**URL:** <https://discuss.elastic.co/t/connect-apm-server-oss-with-aws-elasticsearch-7-10/335686>\
**Category:** APM\
**Tags:** docker, server\
**Created:** [June 10, 2023, 1:20pm UTC](https://discuss.elastic.co/t/connect-apm-server-oss-with-aws-elasticsearch-7-10/335686 "2023-06-10T13:20:25Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Idris\_Jafer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/idris_jafer/32/122089_2.png) [@Idris\_Jafer](https://discuss.elastic.co/u/Idris_Jafer)\
**Post date:** [June 10, 2023, 1:20pm UTC](https://discuss.elastic.co/t/connect-apm-server-oss-with-aws-elasticsearch-7-10/335686/1 "2023-06-10T13:20:25Z")

</div>

**Kibana version** : 7.10

**Elasticsearch version** : 7.10

**APM Server version** : 7.10.2

**APM Agent language and version** : NodeJS

**Original install method (e.g. download page, yum, deb, from source, etc.) and version**: Docker

**Fresh install or upgraded from other version?** : Fresh

**Is there anything special in your setup?** : No

**Description of the problem including expected versus actual behavior. Please include screenshots (if relevant)**: Trying to use **[docker.elastic.co/apm/apm-server-oss:7.10.2](http://docker.elastic.co/apm/apm-server-oss:7.10.2)** docker APM to connect to AWS Elasticsearch offering v7.10 but getting this error:

```auto
Failed to connect to backoff(elasticsearch(https://search-wattb-test-us43oozuewptr4k6zd6oqvqb7u.us-east-1.es.amazonaws.com:443)): Connection marked as failed because the onConnect callback failed: Elasticsearch response: {"error":{"root_cause":[{"type":"parse_exception","reason":"No processor type exists with name [geoip]","processor_type":"geoip"}],"type":"parse_exception","reason":"No processor type exists with name [geoip]","processor_type":"geoip"},"status":400}: 400 Bad Request: {"error":{"root_cause":[{"type":"parse_exception","reason":"No processor type exists with name [geoip]","processor_type":"geoip"}],"type":"parse_exception","reason":"No processor type exists with name [geoip]","processor_type":"geoip"},"status":400}
Pipeline registration failed for apm_user_geo

```

**Steps to reproduce** :

1. Spin up AWS Elasticsearch v7.10 cluster
2. Try to run APM docker with below command:

```auto
docker run -d \
  -p 8200:8200 \
  --name=apm-server9 \
  --user=apm-server \
  --volume="$(pwd)/apm-server.docker.yml:/usr/share/apm-server/apm-server.yml:ro" \
  docker.elastic.co/apm/apm-server-oss:7.10.2 \
  --strict.perms=false -e

```

Is APM OSS version not compatible with AWS Elasticsearch v7.10 cluster?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 13, 2023, 12:51am UTC](https://discuss.elastic.co/t/connect-apm-server-oss-with-aws-elasticsearch-7-10/335686/2 "2023-06-13T00:51:59Z")

</div>

Welcome to our community! 😃

We do not support APM with the aws version of Elasticsearch sorry to say. It's not the Elasticsearch that we release as it contains unknown changes to the code.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 11, 2023, 12:52am UTC](https://discuss.elastic.co/t/connect-apm-server-oss-with-aws-elasticsearch-7-10/335686/3 "2023-07-11T00:52:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
