# Connectex: No connection could be made because the target machine actively refused it

**URL:** <https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [November 5, 2018, 10:27am UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380 "2018-11-05T10:27:05Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![laureate\_dube](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/laureate_dube/32/56803_2.png) [@laureate\_dube](https://discuss.elastic.co/u/laureate_dube)\
**Post date:** [November 5, 2018, 10:27am UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/1 "2018-11-05T10:27:06Z")

</div>

I am failing to ship windows logs to an elastic search server using winlogbeat. The winlogbeat log error reads: "No connection could be made because the target machine actively refused it." Firewall on both server and client machines is off.

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [November 5, 2018, 11:29am UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/2 "2018-11-05T11:29:45Z")

</div>

Do you see any errors in the logs of Elasticsearch?

---

<div class="post-metadata">

**Author:** ![laureate\_dube](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/laureate_dube/32/56803_2.png) [@laureate\_dube](https://discuss.elastic.co/u/laureate_dube)\
**Post date:** [November 5, 2018, 1:22pm UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/3 "2018-11-05T13:22:19Z")

</div>

Hi, No i am not seeing any errors on the elastic search server logs : C:\ProgramData\Elastic\Elasticsearch\logs

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [November 7, 2018, 7:15pm UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/4 "2018-11-07T19:15:50Z")

</div>

Could you please share you configuration formatted using `</>` and the debug logs (`winlogbeat.exe -e -d "*"`)?

---

<div class="post-metadata">

**Author:** ![laureate\_dube](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/laureate_dube/32/56803_2.png) [@laureate\_dube](https://discuss.elastic.co/u/laureate_dube)\
**Post date:** [November 8, 2018, 10:26am UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/5 "2018-11-08T10:26:41Z")

</div>

Hi now resolved. The problem was that i had not configured my elasticsearch to accept remote connections.  
Now i am facing a similar challenge with logstash. It is not being seen by remote machines. How do i configure logstash to be seen by remote machines.

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [November 8, 2018, 2:46pm UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/6 "2018-11-08T14:46:31Z")

</div>

What is the network layout? Are you running Logstash and Beats in separate containers?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 6, 2018, 2:46pm UTC](https://discuss.elastic.co/t/connectex-no-connection-could-be-made-because-the-target-machine-actively-refused-it/155380/7 "2018-12-06T14:46:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
