# Connection between APM-Server and Elasticsearch seems not to be established

**URL:** <https://discuss.elastic.co/t/connection-between-apm-server-and-elasticsearch-seems-not-to-be-established/374919>\
**Category:** APM\
**Tags:** server\
**Created:** [February 24, 2025, 6:33am UTC](https://discuss.elastic.co/t/connection-between-apm-server-and-elasticsearch-seems-not-to-be-established/374919 "2025-02-24T06:33:17Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![dhwo0787](https://avatars.discourse-cdn.com/v4/letter/d/ec9cab/32.png) [@dhwo0787](https://discuss.elastic.co/u/dhwo0787)\
**Post date:** [February 24, 2025, 6:33am UTC](https://discuss.elastic.co/t/connection-between-apm-server-and-elasticsearch-seems-not-to-be-established/374919/1 "2025-02-24T06:33:17Z")

</div>

elasticsearch and kibana setting is done.

But, APM-Server is getting an error when it starts.

error :

1. unable to authenticate user [kinana\_system] for REST request
2. API key: unable to find apikey with id elastic
3. precondition failed: error querying cluster\_uuid: status\_code=401

I tried with elastic / kibana\_system / API\_keys. But it cannot access with es.  
Of course, the password that i use can log into kibana website.

is it wrong about Self-signed Certification? Please help me......

> apm-server.yml :  
> apm-server:  
> host: "0.0.0.0:8200"  
> output.elasticsearch:  
> hosts: ["0.0.0.0"]  
> protocol: "https"  
> username: "kinana\_system"  
> password: "classified"  
> ssl.verification\_mode: none

> elasticsearch.yml :  
> network.host: 0.0.0.0  
> http.port: 9200  
> xpack.security.enabled: true  
> xpack.security.enrollment.enabled: true  
> xpack.security.http.ssl:  
> enabled: true  
> keystore.path: certs/http.p12  
> xpack.security.transport.ssl:  
> enabled: true  
> verification\_mode: certificate  
> keystore.path: certs/transport.p12  
> truststore.path: certs/transport.p12  
> cluster.initial\_master\_nodes: ["SSVELA1V"]  
> http.host: 0.0.0.0  
> xpack.security.authc.api\_key.enabled: true
