# Connection Failed Issue

**URL:** <https://discuss.elastic.co/t/connection-failed-issue/947>\
**Category:** Kibana\
**Created:** [May 20, 2015, 7:59am UTC](https://discuss.elastic.co/t/connection-failed-issue/947 "2015-05-20T07:59:56Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Phani\_Nadiminti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phani_nadiminti/32/45381_2.png) [@Phani\_Nadiminti](https://discuss.elastic.co/u/Phani_Nadiminti)\
**Post date:** [May 20, 2015, 7:59am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/1 "2015-05-20T07:59:56Z")

</div>

Hi All,

I upgraded elasticsearch servers from 1.4.2 to 1.5.2 recently and got noticed that kibana 3.1.2 working fine with es 1.5.2 added following property.

http.cors.enabled: true  
http.cors.allow-origin: "/.\*/"

```
         so no issues after upgrading server but recently my es nodes got shutdown automatically because of OOM issues.from that point onwards kibana 3.1.2 is not working.showing connection failed exception even though we have cors added to es.yml file

          I restarted server but exception not solving please address my issue how can we solve this?

```

Thanks,  
phani

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 20, 2015, 8:19am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/2 "2015-05-20T08:19:55Z")

</div>

What do your ES logs show, what about your nginx/apache logs (whatever is serving up KB)?

---

<div class="post-metadata">

**Author:** ![Phani\_Nadiminti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phani_nadiminti/32/45381_2.png) [@Phani\_Nadiminti](https://discuss.elastic.co/u/Phani_Nadiminti)\
**Post date:** [May 20, 2015, 9:36am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/3 "2015-05-20T09:36:47Z")

</div>

Hi Mark

No errors logs showing in elastic search related to kibana but in httpd logs i am getting following error logs

[Wed May 20 04:37:39 2015] [error] [client 10.0.0.23] Directory index forbidden by Options directive: /var/www/html/  
[Wed May 20 04:38:39 2015] [error] [client 10.0.0.23] Directory index forbidden by Options directive: /var/www/html/  
[Wed May 20 04:39:39 2015] [error] [client 10.0.0.23] Directory index forbidden by Options directive: /var/www/html/  
phani

---

<div class="post-metadata">

**Author:** ![Phani\_Nadiminti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phani_nadiminti/32/45381_2.png) [@Phani\_Nadiminti](https://discuss.elastic.co/u/Phani_Nadiminti)\
**Post date:** [May 21, 2015, 11:55am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/4 "2015-05-21T11:55:34Z")

</div>

Hi,

some one please help me!!

Thanks  
phani

---

<div class="post-metadata">

**Author:** ![Phani\_Nadiminti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phani_nadiminti/32/45381_2.png) [@Phani\_Nadiminti](https://discuss.elastic.co/u/Phani_Nadiminti)\
**Post date:** [May 25, 2015, 10:31am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/5 "2015-05-25T10:31:32Z")

</div>

Hi All,

My Kibana is working fine before unexpected shut down of es nodes.no logs showing in kibana and elasticsearch when we access kibana

I added security rules as follows

http.cors.allow-origin: "/.\*/"  
http.cors.enabled: true

But issues still exists please help me in this!!!.

Thanks,  
phani

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 26, 2015, 12:55am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/6 "2015-05-26T00:55:04Z")

</div>

Can you post your Elasticsearch, Kibana and apache configs?

---

<div class="post-metadata">

**Author:** ![Phani\_Nadiminti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phani_nadiminti/32/45381_2.png) [@Phani\_Nadiminti](https://discuss.elastic.co/u/Phani_Nadiminti)\
**Post date:** [May 26, 2015, 5:20am UTC](https://discuss.elastic.co/t/connection-failed-issue/947/8 "2015-05-26T05:20:18Z")

</div>

Hi Mark,

The following is elasticsearh.yml file.

httpd.conf

![](https://sea2.discourse-cdn.com/elastic/uploads/default/original/0/0/00d373ea5d7bd856c37b244354925309352e7b4d.png)

elasticsearch.yml

![](https://sea2.discourse-cdn.com/elastic/uploads/default/original/0/9/094c9e92819535ef9c8a6f5ee04e7c7127dff03d.png)

config.js  
 ![](https://sea2.discourse-cdn.com/elastic/uploads/default/original/5/7/5795202c0a3ac1e0f865e1648708dbce3fd995d2.png)

---

<div class="post-metadata">

**Author:** ![Phani\_Nadiminti](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/phani_nadiminti/32/45381_2.png) [@Phani\_Nadiminti](https://discuss.elastic.co/u/Phani_Nadiminti)\
**Post date:** [June 1, 2015, 2:17pm UTC](https://discuss.elastic.co/t/connection-failed-issue/947/9 "2015-06-01T14:17:21Z")

</div>

Hi All,

some one please help me to fix it.

Thanks,  
phani

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:18pm UTC](https://discuss.elastic.co/t/connection-failed-issue/947/10 "2017-07-06T14:18:48Z")

</div>


