# Connection Failed : Your elasticsearch server is down or unreachable

**URL:** <https://discuss.elastic.co/t/connection-failed-your-elasticsearch-server-is-down-or-unreachable/43636>\
**Category:** Elasticsearch\
**Created:** [March 7, 2016, 10:10am UTC](https://discuss.elastic.co/t/connection-failed-your-elasticsearch-server-is-down-or-unreachable/43636 "2016-03-07T10:10:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lawinn](https://avatars.discourse-cdn.com/v4/letter/l/d07c76/32.png) [@Lawinn](https://discuss.elastic.co/u/Lawinn)\
**Post date:** [March 7, 2016, 10:10am UTC](https://discuss.elastic.co/t/connection-failed-your-elasticsearch-server-is-down-or-unreachable/43636/1 "2016-03-07T10:10:04Z")

</div>

Hello there,

I am currently doing an internship in which I need to have my VM installed with specific versions of ELK products. I got Kibana 3.1.2, Nginx, Elasticsearch 1.7.3, and Logstash 2.1.0 installed by myself, and the Linux version is Redhat.

**Problem:**  
Chrome: When I try http:// **x.x.x.x** / on Chrome, I got an error "Connection Failed  
Possibility #1: Your elasticsearch server is down or unreachable"[...], and the browser is showing "GET http:// **x.x.x.x** /app/dashboards/default.json?1457344328763 net::ERR\_CONNECTION\_REFUSED" in the console  
Firefox: When I try http:// **x.x.x.x** / on Firefox, I got the Nginx welcome page "Welcome to nginx!  
If you see this page, the nginx web server is successfully installed and working. Further configuration is required."[...]

http:// **x.x.x.x** :9200 shows this:

> {  
> "status" : 200,  
> "name" : "bam\_guillaume",  
> "cluster\_name" : "bam\_guillaume",  
> "version" : {  
> "number" : "1.7.3",  
> "build\_hash" : "05d4530971ef0ea46d0f4fa6ee64dbc8df659682",  
> "build\_timestamp" : "2015-10-15T09:14:17Z",  
> "build\_snapshot" : false,  
> "lucene\_version" : "4.10.4"  
> },  
> "tagline" : "You Know, for Search"  
> }

Which means that elasticsearch is running properly.

**/etc/elasticsearch/elasticsearch.yml:**

> cluster.name: bam\_guillaume  
> node.name: "bam\_guillaume"  
> path.data: /tech/cloud/MONITORING/elasticsearch/data  
> path.work: /tech/cloud/MONITORING/elasticsearch/tmp  
> http.cors.enabled: true  
> indices.fielddata.cache.size: 40%  
> indices.breaker.fielddata.limit: 50%  
> indices.breaker.total.limit: 70%  
> network.bind\_host: 0.0.0.0  
> network.publish\_host: **x.x.x.x**  
> http.port: 9200  
> http.enabled: true  
> http.cors.allow-origin: /http://(.\*)(:[0-9]+)?/  
> discovery.zen.ping.multicast.enabled: true  
> cluster.routing.allocation.allow\_rebalance: always

**/var/www/html/config.js**

> ```
> * ==== default_route
> *
> * This is the default landing page when you don't specify a dashboard to load. You can specify
> * files, scripts or saved dashboards here. For example, if you had saved a dashboard called
> * `WebLogs' to elasticsearch you might use:
> *
> * default_route: '/dashboard/elasticsearch/WebLogs',
> */
> default_route : '/dashboard/file/default.json',
> 
> ```

> ```
> /** @scratch /configuration/config.js/5
> *
> * ==== kibana-int
> *
> * The default ES index to use for storing Kibana specific object
> * such as stored dashboards
> */
> kibana_index: "kibana-int",
> 
> ```

> ```
> /** @scratch /configuration/config.js/5
> *
> * ==== panel_name
> *
> * An array of panel modules available. Panels will only be loaded when they are defined in the
> * dashboard, but this list is used in the "add panel" interface.
> */
> panel_names: [
> 'histogram',
> 'map',
> 'goal',
> 'table',
> 'filtering',
> 'timepicker',
> 'text',
> 'hits',
> 'column',
> 'trends',
> 'bettermap',
> 'query',
> 'terms',
> 'stats',
> 'sparklines'
> ]
> 
> ```
> 
> });  
> });

Any idea of which could be the cause ? Any help will be appreciated.

Thanks in advance,

Lawinn

---

<div class="post-metadata">

**Author:** ![Lawinn](https://avatars.discourse-cdn.com/v4/letter/l/d07c76/32.png) [@Lawinn](https://discuss.elastic.co/u/Lawinn)\
**Post date:** [March 7, 2016, 12:45pm UTC](https://discuss.elastic.co/t/connection-failed-your-elasticsearch-server-is-down-or-unreachable/43636/2 "2016-03-07T12:45:54Z")

</div>

Resolved. **httpd** service was simply not started !

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:10pm UTC](https://discuss.elastic.co/t/connection-failed-your-elasticsearch-server-is-down-or-unreachable/43636/3 "2017-07-05T23:10:41Z")

</div>


