# Connection issue between app and elastic search running in different instances in aws

**URL:** <https://discuss.elastic.co/t/connection-issue-between-app-and-elastic-search-running-in-different-instances-in-aws/84287>\
**Category:** Elasticsearch\
**Created:** [May 2, 2017, 3:04pm UTC](https://discuss.elastic.co/t/connection-issue-between-app-and-elastic-search-running-in-different-instances-in-aws/84287 "2017-05-02T15:04:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![JinnaBalu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jinnabalu/32/27899_2.png) [@JinnaBalu](https://discuss.elastic.co/u/JinnaBalu)\
**Post date:** [May 2, 2017, 3:04pm UTC](https://discuss.elastic.co/t/connection-issue-between-app-and-elastic-search-running-in-different-instances-in-aws/84287/1 "2017-05-02T15:04:34Z")

</div>

Running elastic search in docker container in aws instance

docker run -d --name wsindex -p 9300:9300 -p 9200:9200 -v /var/db/elasticsearch/data:/usr/share/elasticsearch/data elasticsearch elasticsearch -Etransport.host=0.0.0.0 -Ediscovery.zen.minimum\_master\_nodes=1

Able to access this container with x.x.x.x:9200 but not with 9300 from remote

unable to connect from the application running in another instance.

getting the error

failed to load elasticsearch nodes : org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{x.x.x.x}{x.x.x.x:9300}]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 30, 2017, 3:08pm UTC](https://discuss.elastic.co/t/connection-issue-between-app-and-elastic-search-running-in-different-instances-in-aws/84287/2 "2017-05-30T15:08:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
