# Connection refuse issue in Elasticsearch cluster

**URL:** <https://discuss.elastic.co/t/connection-refuse-issue-in-elasticsearch-cluster/157234>\
**Category:** Elasticsearch\
**Created:** [November 18, 2018, 4:40pm UTC](https://discuss.elastic.co/t/connection-refuse-issue-in-elasticsearch-cluster/157234 "2018-11-18T16:40:19Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)\
**Post date:** [November 18, 2018, 4:40pm UTC](https://discuss.elastic.co/t/connection-refuse-issue-in-elasticsearch-cluster/157234/1 "2018-11-18T16:40:19Z")

</div>

Hi All

I have setup 3 mode ELK cluster and it worked well. But recently I upgrade it to latest version now Elasticsearch service and kibana service working well but when I execute curl command to verify elasticsearch I got connection refuse and when i try to access kibana dashboard I got Following error on Browser  
"Kibana server is not ready yet"  
\<Nov 18 11:24:54 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:54Z","tags":["warning","elasticsearch","data"],"pid":12759,"message":"No living connecti  
Nov 18 11:24:54 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:54Z","tags":["license","warning","xpack"],"pid":12759,"message":"License information fro  
Nov 18 11:24:56 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:56Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"Unable to revive  
Nov 18 11:24:56 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:56Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"No living connect  
Nov 18 11:24:58 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:58Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"Unable to revive  
Nov 18 11:24:58 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:58Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"No living connect  
Nov 18 11:24:58 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:58Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"Unable to revive  
Nov 18 11:24:58 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:58Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"No living connect  
Nov 18 11:24:59 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:59Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"Unable to revive  
Nov 18 11:24:59 [915423-Elastic1Prod.newfrontierdata.com](http://915423-Elastic1Prod.newfrontierdata.com) kibana[12759]: {"type":"log","@timestamp":"2018-11-18T16:24:59Z","tags":["warning","elasticsearch","admin"],"pid":12759,"message":"No living connect /b\>

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 18, 2018, 7:38pm UTC](https://discuss.elastic.co/t/connection-refuse-issue-in-elasticsearch-cluster/157234/2 "2018-11-18T19:38:06Z")

</div>

> [@nuwan](#):
>
> when I execute curl command to verify elasticsearch I got connection refuse

Please show the command and the output.

Please check your Elasticsearch logs.

---

<div class="post-metadata">

**Author:** ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)\
**Post date:** [November 19, 2018, 5:20am UTC](https://discuss.elastic.co/t/connection-refuse-issue-in-elasticsearch-cluster/157234/3 "2018-11-19T05:20:26Z")

</div>

Command is

curl [http://172.24.32.209:9200](http://172.24.32.209:9200)

Output:  
Last login: ඉ නෙවැ 18 11:33:43 EST 2018 on pts/8  
[root@915423-Elastic1Prod ~]# curl [http://172.24.32.209:9200](http://172.24.32.209:9200)  
curl: (7) Failed connect to 172.24.32.209:9200; Connection refused  
[root@915423-Elastic1Prod ~]#

2018-11-17T10:31:30,706][ERROR][o.e.b.Bootstrap] [915423-Elastic1Prod.newfrontierdata.com] Exception java.lang.IllegalStateException: index and alias names need to be unique, but the following duplicates were found [.kibana (alias of [.kibana\_2/PPiBvCj3QM2c9wyH-GPvgQ])] at org.elasticsearch.cluster.metadata.MetaData$Builder.build(MetaData.java:1111) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:72) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.gateway.GatewayMetaState.(GatewayMetaState.java:86) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.node.Node.(Node.java:499) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.node.Node.(Node.java:265) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:212) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) [elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) [elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) [elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.5.0.jar:6.5.0] at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) [elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) [elasticsearch-6.5.0.jar:6.5.0] [2018-11-17T10:31:30,708][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [915423-Elastic1Prod.newfrontierdata.com] uncaught exception in thread [main] org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: index and alias names need to be unique, but the following duplicates were found [.kibana (alias of [.kibana\_2/PPiBvCj3QM2c9wyH-GPvgQ])] at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:140) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.5.0.jar:6.5.0] at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86) ~[elasticsearch-6.5.0.jar:6.5.0] Caused by: java.lang.IllegalStateException: index and alias names need to be unique, but the following duplicates were found [.kibana (alias of [.kibana\_2/PPiBvCj3QM2c9wyH-GPvgQ])] at org.elasticsearch.cluster.metadata.MetaData$Builder.build(MetaData.java:1111) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:72) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.gateway.GatewayMetaState.(GatewayMetaState.java:86) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.node.Node.(Node.java:499) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.node.Node.(Node.java:265) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:212) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:212) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-6.5.0.jar:6.5.0] at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-6.5.0.jar:6.5.0] ... 6 more

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 17, 2018, 5:30am UTC](https://discuss.elastic.co/t/connection-refuse-issue-in-elasticsearch-cluster/157234/4 "2018-12-17T05:30:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
