# Connection Refused fun continues - is there anyone I can pay for support?

**URL:** <https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382>\
**Category:** Elasticsearch\
**Created:** [April 18, 2012, 2:20pm UTC](https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382 "2012-04-18T14:20:20Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)\
**Post date:** [April 18, 2012, 2:20pm UTC](https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382/1 "2012-04-18T14:20:20Z")

</div>

The random connection issues continue to plague my production  
systems. Now that I've brought up a second remote server, I'm getting  
the following errors:

[2012-04-18 10:13:50,398][WARN][cluster.service] [app1-uk-  
example-com] failed to reconnect to node [app2-uk-example-com]  
[HRCQGb4lTIm-hjzENY3mTQ][inet[/172.28.5.3:9300]]{zone=uk}  
org.elasticsearch.transport.ConnectTransportException: [app2-uk-  
example-com][inet[/172.28.5.3:9300]] connect\_timeout[30s]  
at  
org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:  
560)  
at  
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:  
503)  
at  
org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:  
482)  
at  
org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:  
128)  
at org.elasticsearch.cluster.service.InternalClusterService  
$ReconnectToNodes.run(InternalClusterService.java:377)  
at  
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:  
1110)  
at java.util.concurrent.ThreadPoolExecutor  
$Worker.run(ThreadPoolExecutor.java:603)  
at java.lang.Thread.run(Thread.java:679)  
Caused by: java.net.ConnectException: Connection refused  
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
at  
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)  
at  
org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink  
$Boss.connect(NioClientSocketPipelineSink.java:400)  
at  
org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink  
$Boss.processSelectedKeys(NioClientSocketPipelineSink.java:362)  
at  
org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink  
$Boss.run(NioClientSocketPipelineSink.java:284)  
at  
org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:  
102)  
at  
org.elasticsearch.common.netty.util.internal.DeadLockProofWorker  
$1.run(DeadLockProofWorker.java:42)

So the two UK servers won't talk to each other, and the status info on  
app1 show green but no shards, and the status info on app2 shows  
proper sharding and a green cluster.

I'm happy to pay someone to help me debug this problem - does anyone  
offer paid ES support?

---

<div class="post-metadata">

**Author:** ![otisg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/otisg/32/492_2.png) [@otisg](https://discuss.elastic.co/u/otisg)\
**Post date:** [April 18, 2012, 4:01pm UTC](https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382/2 "2012-04-18T16:01:31Z")

</div>

Hello,

Sematext offers Elasticsearch consulting services and support:

- [Solr, Elasticsearch & OpenSearch Production Support - Sematext](http://sematext.com/services/index.html)
- [Solr, Elasticsearch & OpenSearch Production Support - Sematext](http://sematext.com/services/tech-support.html)

Otis

On Wednesday, April 18, 2012 10:20:20 AM UTC-4, [news...@syslog.com](mailto:news...@syslog.com) wrote:

> The random connection issues continue to plague my production  
> systems. Now that I've brought up a second remote server, I'm getting  
> the following errors:
> 
> [2012-04-18 10:13:50,398][WARN][cluster.service] [app1-uk-  
> example-com] failed to reconnect to node [app2-uk-example-com]  
> [HRCQGb4lTIm-hjzENY3mTQ][inet[/172.28.5.3:9300]]{zone=uk}  
> org.elasticsearch.transport.ConnectTransportException: [app2-uk-  
> example-com][inet[/172.28.5.3:9300]] connect\_timeout[30s]  
> at  
> org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:
> 
> 1. at  
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:
> 
> 2. at  
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:
> 
> 3. at  
> org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:
> 
> 4. at org.elasticsearch.cluster.service.InternalClusterService  
> $ReconnectToNodes.run(InternalClusterService.java:377)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:
> 
> 5. at java.util.concurrent.ThreadPoolExecutor  
> $Worker.run(ThreadPoolExecutor.java:603)  
> at java.lang.Thread.run(Thread.java:679)  
> Caused by: java.net.ConnectException: Connection refused  
> at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> at  
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink
> 
> $Boss.connect(NioClientSocketPipelineSink.java:400)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink
> 
> $Boss.processSelectedKeys(NioClientSocketPipelineSink.java:362)  
> at  
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink
> 
> $Boss.run(NioClientSocketPipelineSink.java:284)  
> at  
> org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:
> 
> 1. at  
> org.elasticsearch.common.netty.util.internal.DeadLockProofWorker  
> $1.run(DeadLockProofWorker.java:42)
> 
> So the two UK servers won't talk to each other, and the status info on  
> app1 show green but no shards, and the status info on app2 shows  
> proper sharding and a green cluster.
> 
> I'm happy to pay someone to help me debug this problem - does anyone  
> offer paid ES support?

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [April 19, 2012, 2:55pm UTC](https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382/3 "2012-04-19T14:55:03Z")

</div>

Do you have any firewall or something that can block the two nodes from  
talking to one antoher?

On Wed, Apr 18, 2012 at 5:20 PM, [newsgroup@syslog.com](mailto:newsgroup@syslog.com)  
[newsgroup@syslog.com](mailto:newsgroup@syslog.com)wrote:

> The random connection issues continue to plague my production  
> systems. Now that I've brought up a second remote server, I'm getting  
> the following errors:
> 
> [2012-04-18 10:13:50,398][WARN][cluster.service] [app1-uk-  
> example-com] failed to reconnect to node [app2-uk-example-com]  
> [HRCQGb4lTIm-hjzENY3mTQ][inet[/172.28.5.3:9300]]{zone=uk}  
> org.elasticsearch.transport.ConnectTransportException: [app2-uk-  
> example-com][inet[/172.28.5.3:9300]] connect\_timeout[30s]  
> at
> 
> org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:  
> 560)  
> at
> 
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:  
> 503)  
> at
> 
> org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:  
> 482)  
> at
> 
> org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:  
> 128)  
> at org.elasticsearch.cluster.service.InternalClusterService  
> $ReconnectToNodes.run(InternalClusterService.java:377)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:  
> 1110)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.run(ThreadPoolExecutor.java:603)  
> at java.lang.Thread.run(Thread.java:679)  
> Caused by: java.net.ConnectException: Connection refused  
> at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
> at  
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)  
> at
> 
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink  
> $Boss.connect(NioClientSocketPipelineSink.java:400)  
> at
> 
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink  
> $Boss.processSelectedKeys(NioClientSocketPipelineSink.java:362)  
> at
> 
> org.elasticsearch.common.netty.channel.socket.nio.NioClientSocketPipelineSink  
> $Boss.run(NioClientSocketPipelineSink.java:284)  
> at
> 
> org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:  
> 102)  
> at  
> org.elasticsearch.common.netty.util.internal.DeadLockProofWorker  
> $1.run(DeadLockProofWorker.java:42)
> 
> So the two UK servers won't talk to each other, and the status info on  
> app1 show green but no shards, and the status info on app2 shows  
> proper sharding and a green cluster.
> 
> I'm happy to pay someone to help me debug this problem - does anyone  
> offer paid ES support?

---

<div class="post-metadata">

**Author:** ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)\
**Post date:** [April 19, 2012, 9:40pm UTC](https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382/4 "2012-04-19T21:40:18Z")

</div>

On Apr 19, 10:55 am, Shay Banon [kim...@gmail.com](mailto:kim...@gmail.com) wrote:

> Do you have any firewall or something that can block the two nodes from  
> talking to one antoher?

No, there was no firewall. The UK servers had multiple aliased IPs  
and the ES server was taking one of the aliases because I did not have  
a specific IP configured. This works on boxed with only one IP but  
not multiple. Once I put the non-alias IP in the config, they could  
talk to each other.

The aliased IP work fine otherwise for other servers.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:31am UTC](https://discuss.elastic.co/t/connection-refused-fun-continues-is-there-anyone-i-can-pay-for-support/7382/5 "2017-07-06T03:31:50Z")

</div>


