# Connection refused port 5044

**URL:** <https://discuss.elastic.co/t/connection-refused-port-5044/277149>\
**Category:** Logstash\
**Created:** [June 27, 2021, 1:26pm UTC](https://discuss.elastic.co/t/connection-refused-port-5044/277149 "2021-06-27T13:26:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![diegz](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@diegz](https://discuss.elastic.co/u/diegz)\
**Post date:** [June 27, 2021, 1:26pm UTC](https://discuss.elastic.co/t/connection-refused-port-5044/277149/1 "2021-06-27T13:26:23Z")

</div>

Hi,

When i want to validate the logstash server certificate with this command :

```auto
curl -v --cacert /etc/logstash/config/certs/logstash.crt https://logstash.ad-it.fr:5044
Rebuilt URL to: https://192.168.1.30:5044/
* Trying 192.168.1.30...
* TCP_NODELAY set
* connect to 192.168.1.30 port 5044 failed: Connection refused
* Failed to connect to 192.168.1.30 port 5044: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 192.168.1.30 port 5044: Connection refused

```

Best regards,

/etc/logstash/conf.d/example.yml

```auto
input {
  beats {
    port => 5044
    ssl => true
    ssl_certificate_authorities => ["/etc/logstash/config/certs/ca.crt"]
    ssl_key => "/etc/logstash/config/certs/logstash.pkcs8.key"
    ssl_certificate => "/etc/logstash/config/certs/logstash.crt"
    ssl_verify_mode => "peer"
  }
}
output {
  elasticsearch {
    hosts => ["https://node1.ad-it.fr:9200","https://node2.ad-it.fr:9200","https://node3.ad-it.fr:9200"]
    ssl => true
    cacert => '/etc/logstash/config/certs/ca.crt'
    user => 'logstash_writer'
    password => 'changeme'
    index => 'logstash-%{+YYYY.MM.dd}'
  }
}

```

```auto
filebeat.yml
#----------------------------- Logstash output --------------------------------
#output.logstash:
  # The Logstash hosts
  hosts: ["192.168.1.30:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  ssl.certificate_authorities: ["/etc/filebeat/config/certs/ca.crt"]

  # Certificate for SSL client authentication
  ssl.certificate: "/etc/logstash/config/certs/logstash.crt"

  # Client Certificate Key
  ssl.key: "/etc/logstash/config/certs/logstash.pkcs8.key"

```

---

<div class="post-metadata">

**Author:** ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)\
**Post date:** [July 14, 2021, 4:35pm UTC](https://discuss.elastic.co/t/connection-refused-port-5044/277149/2 "2021-07-14T16:35:43Z")

</div>

Do you have a firewall installed on that host that you need to open up?  
For example on CentOS/RHEL 7 firewalld is turned on by default and you need to open up a port to allow traffic through.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 11, 2021, 4:36pm UTC](https://discuss.elastic.co/t/connection-refused-port-5044/277149/3 "2021-08-11T16:36:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
