# Connection Refused

**URL:** https://discuss.elastic.co/t/connection-refused/7354
**Category:** Elasticsearch
**Created:** [April 16, 2012, 5:20pm UTC](https://discuss.elastic.co/t/connection-refused/7354 "2012-04-16T17:20:32Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)
#### Post date: [April 16, 2012, 5:20pm UTC](https://discuss.elastic.co/t/connection-refused/7354/1 "2012-04-16T17:20:32Z")

</div>

I'm getting the following errors:

[2012-04-16 13:17:31,897][INFO][discovery.zen] [app2-uk-  
example-com] failed to send join request to master [[app2-prod-example-  
com][T8eeWM5xTJ-cJw6FhF5Qxg][inet[/172.16.10.2:9300]]{zone=to}],  
reason [org.elasticsearch.transport.RemoteTransportException: [app2-  
prod-example-com][inet[/172.16.10.2:9300]][discovery/zen/join];  
org.elasticsearch.transport.NotSerializableTransportException:  
[org.elasticsearch.transport.ConnectTransportException] [app2-uk-  
example-com][inet[/172.28.5.3:9300]] connect\_timeout[30s]; Connection  
refused; ]

I have two zones, to and uk, with the following config:

cluster.name: prod  
node.name: ${NODENAME}  
path.logs: /var/log/elasticsearch  
network.host: 0.0.0.0  
http.port: 9200  
discovery.zen.minimum\_master\_nodes: 2  
discovery.zen.ping.unicast.hosts: ["app1.prod", "app2.prod",  
"app3.prod", "app4.prod", "app5.prod"]  
node.zone: to  
cluster.routing.allocation.awareness.attributes: zone

But the UK can't join anymore and I don't know why.

What I want is to have each zone have 2 copies of the index, and I  
have four zones total. With the zone restriction, I was getting one  
copy and I'd be happy with that again if I can get the UK server to  
connect.

---

<div class="post-metadata">

### Author: ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)
#### Post date: [April 16, 2012, 8:21pm UTC](https://discuss.elastic.co/t/connection-refused/7354/2 "2012-04-16T20:21:58Z")

</div>

Further into this, I've removed all references to the cluster routing  
and gone back to my original config, and the cluster master is still  
refusing connection to the remote server.

I can telnet to port 9300 on the master but I don't get any response.  
This is version 0.18.6.

---

<div class="post-metadata">

### Author: ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)
#### Post date: [April 17, 2012, 11:42am UTC](https://discuss.elastic.co/t/connection-refused/7354/3 "2012-04-17T11:42:05Z")

</div>

We're on to day two of this being broken in our production  
environment. I upgraded the entire cluster to 0.19.2 and it started  
working, but then last night the UK server disconnected and it hasn't  
been able to re-connect since.

Is there no one who can help me with this problem?

---

<div class="post-metadata">

### Author: ![Shairon\_Toledo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shairon_toledo/32/2490_2.png) [@Shairon\_Toledo](https://discuss.elastic.co/u/Shairon_Toledo)
#### Post date: [April 17, 2012, 6:27pm UTC](https://discuss.elastic.co/t/connection-refused/7354/4 "2012-04-17T18:27:17Z")

</div>

We have a similar issue running ES over EC2 + Ubuntu 10.04.1 LTS, the fix  
was migrating ubuntu to version 11.10.

On Tue, Apr 17, 2012 at 8:42 AM, [newsgroup@syslog.com](mailto:newsgroup@syslog.com)  
[newsgroup@syslog.com](mailto:newsgroup@syslog.com)wrote:

> We're on to day two of this being broken in our production  
> environment. I upgraded the entire cluster to 0.19.2 and it started  
> working, but then last night the UK server disconnected and it hasn't  
> been able to re-connect since.
> 
> Is there no one who can help me with this problem?

--

Shairon Toledo

> **[Microsoft Developer News | C++,C# & .NET Framework & More | CodeGuru](http://hashcode.me)**
>
> 您是否想要找关于幸运飞行艇 官方开奖历史记录 168飞艇全国统一开奖数据 还有幸运飞行艇官方开奖现场直播 幸运168飞艇全天精准稳定计划 这里都能一一提供。CodeGuru is where developers come to share ideas, articles, questions, answers, tips, tricks, comments, downloads, and more related to programming in areas including C++,...

---

<div class="post-metadata">

### Author: ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)
#### Post date: [April 17, 2012, 9:46pm UTC](https://discuss.elastic.co/t/connection-refused/7354/5 "2012-04-17T21:46:16Z")

</div>

On Apr 17, 2:27 pm, Shairon Toledo [shairon.tol...@gmail.com](mailto:shairon.tol...@gmail.com) wrote:

> We have a similar issue running ES over EC2 + Ubuntu 10.04.1 LTS, the fix  
> was migrating ubuntu to version 11.10.

I'm running CentOS 5.8.

---

<div class="post-metadata">

### Author: ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)
#### Post date: [April 19, 2012, 1:14pm UTC](https://discuss.elastic.co/t/connection-refused/7354/6 "2012-04-19T13:14:13Z")

</div>

Here's an update on this issue. It turns out that elasticsearch, when  
configured to listen on any address, would always select the aliased  
IP of the box in question. Manually setting the IP to the primary  
interface has fixed this issue.

So, for future Googlers, if you have multiple IPs on the box where  
you're running ES, manually configure the interface.

---

<div class="post-metadata">

### Author: ![newsgroup](https://avatars.discourse-cdn.com/v4/letter/n/ecccb3/32.png) [@newsgroup](https://discuss.elastic.co/u/newsgroup)
#### Post date: [April 19, 2012, 1:31pm UTC](https://discuss.elastic.co/t/connection-refused/7354/7 "2012-04-19T13:31:31Z")

</div>

Here's an update on this issue. It turns out that elasticsearch, when  
configured to listen on any address, would always select the aliased  
IP of the box in question. Manually setting the IP to the primary  
interface has fixed this issue.

So, for future Googlers, if you have multiple IPs on the box where  
you're running ES, manually configure the interface.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:32am UTC](https://discuss.elastic.co/t/connection-refused/7354/8 "2017-07-06T03:32:00Z")

</div>


