# Connectivity Issue with Curator taking on ElasticCloud in Windows 10

**URL:** <https://discuss.elastic.co/t/connectivity-issue-with-curator-taking-on-elasticcloud-in-windows-10/222378>\
**Category:** Elasticsearch\
**Tags:** curator\
**Created:** [March 5, 2020, 9:38pm UTC](https://discuss.elastic.co/t/connectivity-issue-with-curator-taking-on-elasticcloud-in-windows-10/222378 "2020-03-05T21:38:08Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bmbrit](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bmbrit/32/63571_2.png) [@bmbrit](https://discuss.elastic.co/u/bmbrit)\
**Post date:** [March 5, 2020, 9:38pm UTC](https://discuss.elastic.co/t/connectivity-issue-with-curator-taking-on-elasticcloud-in-windows-10/222378/1 "2020-03-05T21:38:08Z")

</div>

Hi,

We have the elk setup on Elastic Cloud and I have a requirement to delete the indices from a curator.  
The following code is the curator config:  
/\*---  
client:  
hosts: ["[asd321asdsa.ap-northeast-1.aws.found.io](http://asd321asdsa.ap-northeast-1.aws.found.io)" ]  
port: 9254  
use\_ssl: True  
http\_auth: elastic:elastic  
timeout: 1000  
master\_only: False

logging:  
loglevel: INFO  
logfile: C:\logs.log  
logformat: default  
blacklist: ['elasticsearch', 'urllib3']  
\*/

The following code is the action file:  
/\*  
actions:  
1:  
action: delete\_indices  
description: \>-  
Delete indices older than 30 days (based on index name), for navis-apex-ec2amaz-ul066bg-2019.10.\*  
prefixed indices. Ignore the error if the filter does not result in an  
actionable list of indices (ignore\_empty\_list) and exit cleanly.  
options:  
ignore\_empty\_list: True  
timeout\_override:  
continue\_if\_exception: False  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: ul066bg-2019.10.\*  
exclude:  
- filtertype: age  
source: name  
direction: older  
timestring: '%Y.%m.%d'  
unit: days  
unit\_count: 30  
exclude:  
\*/

The same action file, works fine with a local cluster(localhost) but not with the ElasticCloud service.

The following was the response after running the curator:  
2020-03-06 02:18:41,723 INFO Preparing Action ID: 1, "delete\_indices"  
2020-03-06 02:18:41,723 INFO Creating client object and testing connection  
2020-03-06 02:18:41,726 INFO Instantiating client object  
2020-03-06 02:18:41,726 INFO Testing client connectivity  
2020-03-06 02:24:18,077 ERROR HTTP N/A error: HTTPSConnectionPool(host='[asd321asdsa.ap-northeast-1.aws.found.io](http://asd321asdsa.ap-northeast-1.aws.found.io)', port=9254): Max retries exceeded with url: / (Caused by NewConnectionError('\<urllib3.connection.VerifiedHTTPSConnection object at 0x00000197C498D160\>: Failed to establish a new connection: [WinError 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond'))  
2020-03-06 02:24:18,077 CRITICAL Curator cannot proceed. Exiting.

Note: The host is modified for security reason.

Please assist.

Thanks, Brit

---

<div class="post-metadata">

**Author:** ![Alex\_Piggott](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_piggott/32/11053_2.png) [@Alex\_Piggott](https://discuss.elastic.co/u/Alex_Piggott)\
**Post date:** [March 5, 2020, 10:01pm UTC](https://discuss.elastic.co/t/connectivity-issue-with-curator-taking-on-elasticcloud-in-windows-10/222378/2 "2020-03-05T22:01:55Z")

</div>

Moved this to elasticsearch as I think it's a more general "how to use a client" question, but it looks like the port you've specified is wrong - it should be either 443 or equivalently 9243

---

<div class="post-metadata">

**Author:** ![bmbrit](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bmbrit/32/63571_2.png) [@bmbrit](https://discuss.elastic.co/u/bmbrit)\
**Post date:** [March 5, 2020, 10:11pm UTC](https://discuss.elastic.co/t/connectivity-issue-with-curator-taking-on-elasticcloud-in-windows-10/222378/3 "2020-03-05T22:11:38Z")

</div>

Thanks Alex. You made my day.  
I couldn't believe I made a typo on port.

The port was supposed to be 9243 instead of 9254.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 19, 2020, 10:25pm UTC](https://discuss.elastic.co/t/connectivity-issue-with-curator-taking-on-elasticcloud-in-windows-10/222378/4 "2020-03-19T22:25:15Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
