# Console.plugin tries to connect to quickstart-es-http.default.svc:9200 even though theres is explicit configuration

**URL:** <https://discuss.elastic.co/t/console-plugin-tries-to-connect-to-quickstart-es-http-default-svc-9200-even-though-theres-is-explicit-configuration/385745>\
**Category:** Kibana\
**Created:** [April 2, 2026, 3:44pm UTC](https://discuss.elastic.co/t/console-plugin-tries-to-connect-to-quickstart-es-http-default-svc-9200-even-though-theres-is-explicit-configuration/385745 "2026-04-02T15:44:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![slowdown77](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/slowdown77/32/147284_2.png) [@slowdown77](https://discuss.elastic.co/u/slowdown77)\
**Post date:** [April 2, 2026, 3:44pm UTC](https://discuss.elastic.co/t/console-plugin-tries-to-connect-to-quickstart-es-http-default-svc-9200-even-though-theres-is-explicit-configuration/385745/1 "2026-04-02T15:44:36Z")

</div>

Hi everyone,

I have a fresh installation of ECK 3.3.1 and I have deployed Kibana and pointed it to the Elasticsearch instance in the same namespace

```yaml
apiVersion: kibana.k8s.elastic.co/v1
kind: Kibana
metadata:
  name: cmp
spec:
  version: 9.3.0
  count: 1
  elasticsearchRef:
    name: cmp
  config:
    xpack.fleet.packages:
      - name: apm
        version: latest
    server.publicBaseUrl: https://kibana.cmp.cloud

```

However, when I try to run anything in the Dev Console I get the error below:

```json
{
  "statusCode": 502,
  "error": "Bad Gateway",
  "message": "An internal server error occurred. Check Kibana server logs for details."
}

```

Which corresponds to the error in Kubernetes:

```auto
[2026-04-02T15:32:07.161+00:00][INFO][plugins.security.authentication] Performing login attempt with "basic" provider.
[2026-04-02T15:32:08.409+00:00][INFO][plugins.security.authentication] Login attempt with "basic" provider succeeded (requires redirect: true).
[2026-04-02T15:32:20.409+00:00][ERROR][plugins.console] Error: getaddrinfo ENOTFOUND quickstart-es-http.default.svc
    at GetAddrInfoReqWrap.onlookupall [as oncomplete] (node:dns:122:26)
    at GetAddrInfoReqWrap.callbackTrampoline (node:internal/async_hooks:130:17)
[2026-04-02T15:32:20.410+00:00][WARN][plugins.console] Could not connect to ES node [https://quickstart-es-http.default.svc:9200]

```

Nowhere have I used `quickstart` or `default` in my configurations.

Any idea what that could be? because of this I am basically limited to only deploying it to the `default` namespace.

Update #1:

When updating Kibana and Elasticsearch from 9.3.0 to 9.3.2 I get this error in console and no error in Kubernetes:

```json
{
"statusCode": 400,
"error": "Bad Request",
"message": "Host is not configured in elasticsearch.hosts"
}

```

Update #2:  
I have rolled back to 9.3.0 and noticed one thing: If I connect via `kubectl port-forward` console works without issues.

---

<div class="post-metadata">

**Author:** ![slowdown77](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/slowdown77/32/147284_2.png) [@slowdown77](https://discuss.elastic.co/u/slowdown77)\
**Post date:** [April 7, 2026, 2:18pm UTC](https://discuss.elastic.co/t/console-plugin-tries-to-connect-to-quickstart-es-http-default-svc-9200-even-though-theres-is-explicit-configuration/385745/2 "2026-04-07T14:18:24Z")

</div>

Seems like the issue was due to the config stored in the browser. I have noticed it when I realized that when I use port-forwarding and visit it via localhost everything was working well. I have also confirmed it by opening it in a different browser.

The issue was that the `?host=https://quickstart-es-http.default.svc:9200 `was added to the get request. Resetting site data solved it.
