# Continuous failure for report generation

**URL:** <https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671>\
**Category:** Kibana\
**Tags:** elastic-stack-alerting\
**Created:** [January 20, 2020, 6:48am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671 "2020-01-20T06:48:28Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nithani25](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nithani25/32/33457_2.png) [@Nithani25](https://discuss.elastic.co/u/Nithani25)\
**Post date:** [January 20, 2020, 6:48am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/1 "2020-01-20T06:48:28Z")

</div>

Hi Team,  
I am getting continuous failure with report generation and slack alerting in kibana 6.4. I am trying to generate a dashboard report and send it as a watcher alert(daily,weekly and monthly) alerts. But i am getting continuous failure while trying to do so. Mostly the issue is with GET/POST method and error codes being 401,402 respectively.

## My watcher alert:

```
{
  "trigger": {
    "schedule": {
      "interval": "24h"
    }
  },
  "input": {
    "none": {}
  },
  "condition": {
    "always": {}
  },
  "actions": {
    "send_email": {
      "email": {
        "profile": "standard",
        "attachments": {
          "IASDE_weekly_dashboard.pdf": {
            "http": {
              "request": {
                "scheme": "http",
                "host": "rxxxxxxxxx",
                "port": 5601,
                "method": "get",
                "path": "api/reporting/jobs/download/jpv9n8j219qy69db66c562cx?_g=(time:(from:now-1d%2Fd,mode:quick,to:now))",
                "params": {},
                "headers": {},
                "auth": {
                  "basic": {
                    "username": "elastic",
                    "password": "::es_redirected::"
                  }
                }
              },
              "content_type": "application/pdf"
            }
          }
        },
        "priority": "high",
        "to": [
          "nishanth@fxxxmnhsa.com"
        ],
        "subject": "Daily Dashboard for IASDE project"
      }
    }
  }
}
```

---

<div class="post-metadata">

**Author:** ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)\
**Post date:** [January 20, 2020, 12:05pm UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/2 "2020-01-20T12:05:45Z")

</div>

Hi @Nithani25,

You'll need to enable verbose logging in Kibana and gather logs when this happens otherwise it's hard to tell what's going on. Also your `kibana.yml` will be needed (without sensitive info of course).

Best,  
Oleg

---

<div class="post-metadata">

**Author:** ![Nithani25](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nithani25/32/33457_2.png) [@Nithani25](https://discuss.elastic.co/u/Nithani25)\
**Post date:** [January 21, 2020, 7:03am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/3 "2020-01-21T07:03:57Z")

</div>

I will get you the copy of kibana.yml in short time, but this is what i get when i try to copy paste the generate url link in web browser.

```
{

* statusCode: 405,

* error: "Method Not Allowed",

* message: "GET is not allowed",

}
```

---

<div class="post-metadata">

**Author:** ![Nithani25](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nithani25/32/33457_2.png) [@Nithani25](https://discuss.elastic.co/u/Nithani25)\
**Post date:** [January 21, 2020, 11:29am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/4 "2020-01-21T11:29:11Z")

</div>

Hi,  
I finally reached a point where i get only Error[404] during the watcher simulation, any quick thoughts on what's wrong from here will be helpful..

---

<div class="post-metadata">

**Author:** ![Nithani25](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nithani25/32/33457_2.png) [@Nithani25](https://discuss.elastic.co/u/Nithani25)\
**Post date:** [January 22, 2020, 7:00am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/5 "2020-01-22T07:00:56Z")

</div>

Here is the copy of my kibana.yml...

```
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "RXXXXXXXXX"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name. This is used for display purposes.
server.name: "RXXXXXXXXXXX"

# The URL of the Elasticsearch instance to use for all your queries.
elasticsearch.url: "http://RXXXXXXXXXX:9200"

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
elasticsearch.username: "elastic"
elasticsearch.password: "XXXXXXXXXXXXX"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files validate that your Elasticsearch backend uses the same key files.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: ["/path/to/your/CA.pem"]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [authorization]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
#elasticsearch.startupTimeout: 5000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# The default locale. This locale can be used in certain circumstances to substitute any missing
# translations.
#i18n.defaultLocale: "en"
#xpack security enabled configuration
xpack.security.enabled: true
xpack.monitoring.kibana.collection.enabled: true
```

---

<div class="post-metadata">

**Author:** ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)\
**Post date:** [January 23, 2020, 8:39am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/6 "2020-01-23T08:39:58Z")

</div>

Hi @Nithani25,

We still need debug/verbose logs to understand what's going on. Also don't forget to set [`xpack.security.encryptionKey`](https://www.elastic.co/guide/en/kibana/current/using-kibana-with-security.html) and [`xpack.reporting.encryptionKey`](https://www.elastic.co/guide/en/kibana/current/reporting-settings-kb.html) to fixed values so that you can decrypt report after Kibana restart.

Best,  
Oleg

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 20, 2020, 8:39am UTC](https://discuss.elastic.co/t/continuous-failure-for-report-generation/215671/7 "2020-02-20T08:39:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
