# Copy Visualizations in Kibana 6

**URL:** <https://discuss.elastic.co/t/copy-visualizations-in-kibana-6/116662>\
**Category:** Kibana\
**Created:** [January 23, 2018, 11:59am UTC](https://discuss.elastic.co/t/copy-visualizations-in-kibana-6/116662 "2018-01-23T11:59:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cawoodm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cawoodm/32/14083_2.png) [@cawoodm](https://discuss.elastic.co/u/cawoodm)\
**Post date:** [January 23, 2018, 11:59am UTC](https://discuss.elastic.co/t/copy-visualizations-in-kibana-6/116662/1 "2018-01-23T11:59:32Z")

</div>

Copying visualizations in Kibana 6 has become difficult if not impossible. Formerly (v5) you could simply export a Viz, change the id and re-import. This no longer works. It's reproducible on any visualization of ours:

1. Export Viz

2. Change Id

3. Import Viz -\> Error:  
Saved Objects: Importing NameOfMyVizualisation (foo) failed: Could not locate that index-pattern-field (id: source.keyword)

UPDATE: As I'm unable to reply below I'll update here:  
It turns out in our PROD index many fields which were simple "keyword" fields in TEST had become "objects" with a nested "fields" structure containing a sub-field called "keyword". No idea how this came about but basically the mappings were different in TEST and PROD. In TEST the field was called "type" and in PROD it was called "type.keyword".

---

<div class="post-metadata">

**Author:** ![ppisljar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppisljar/32/11588_2.png) [@ppisljar](https://discuss.elastic.co/u/ppisljar)\
**Post date:** [January 23, 2018, 12:03pm UTC](https://discuss.elastic.co/t/copy-visualizations-in-kibana-6/116662/2 "2018-01-23T12:03:19Z")

</div>

i just did a quick test:

- i exported a visualization
- i opened the export file, i removed the id (it will get auto generated) and i changed the name
- saved the file and imported it

everything works as expected.

can you check your index pattern and see if the source.keyword field is there at all ?  
are you exporting a visualization created with current version of kibana or an old one from 5.x ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 20, 2018, 12:03pm UTC](https://discuss.elastic.co/t/copy-visualizations-in-kibana-6/116662/3 "2018-02-20T12:03:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
