# Corrupt translog entry error in index recovery

**URL:** <https://discuss.elastic.co/t/corrupt-translog-entry-error-in-index-recovery/17407>\
**Category:** Elasticsearch\
**Created:** [May 8, 2014, 11:11am UTC](https://discuss.elastic.co/t/corrupt-translog-entry-error-in-index-recovery/17407 "2014-05-08T11:11:22Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nitzan\_Dana](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nitzan_dana/32/11140_2.png) [@Nitzan\_Dana](https://discuss.elastic.co/u/Nitzan_Dana)\
**Post date:** [May 8, 2014, 11:11am UTC](https://discuss.elastic.co/t/corrupt-translog-entry-error-in-index-recovery/17407/1 "2014-05-08T11:11:22Z")

</div>

Hi,

I'm using elasticsearch in my logstash setup and having some real troubles  
for a couple of days now.  
My elasticsearch cluster state is red and I can see that there are some  
unassigned shards, and in the servers logs I can see that there is a error  
with recovering a specific index.  
Do you have any clue about fixing this unfortunate situation?

Thanks!

> [2014-05-08 11:00:43,812][INFO][index.gateway.local] [LogstashES3]  
> [logstash-2014.05.05][3] ignoring recovery of a corrupt tran  
> slog entry  
> org.elasticsearch.index.mapper.MapperParsingException: failed to parse  
> [time]  
> at  
> org.elasticsearch.index.mapper.core.AbstractFieldMapper.parse(AbstractFieldMapper.java:416)  
> at  
> org.elasticsearch.index.mapper.multifield.MultiFieldMapper.parse(MultiFieldMapper.java:204)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.serializeValue(ObjectMapper.java:613)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:466)  
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:516)  
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:460)  
> at  
> org.elasticsearch.index.shard.service.InternalIndexShard.prepareCreate(InternalIndexShard.java:353)  
> at  
> org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryOperation(InternalIndexShard.java:697)  
> at  
> org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:224)  
> at  
> org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:744)  
> Caused by: org.elasticsearch.common.jackson.core.JsonParseException:  
> Illegal unquoted character ((CTRL-CHAR, code 0)): has to be escaped using  
> backslash  
> to be included in string value  
> at [Source: [B@4960d84; line: 1, column: 402]  
> at  
> org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1524)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:557)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_throwUnquotedSpace(ParserMinimalBase.java:518)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_finishString2(UTF8StreamJsonParser.java:2220)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_finishString(UTF8StreamJsonParser.java:2150)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.getText(UTF8StreamJsonParser.java:282)  
> at  
> org.elasticsearch.common.xcontent.json.JsonXContentParser.text(JsonXContentParser.java:85)  
> at  
> org.elasticsearch.common.xcontent.support.AbstractXContentParser.textOrNull(AbstractXContentParser.java:123)  
> at  
> org.elasticsearch.index.mapper.core.StringFieldMapper.parseCreateFieldForString(StringFieldMapper.java:316)  
> at  
> org.elasticsearch.index.mapper.core.StringFieldMapper.parseCreateField(StringFieldMapper.java:261)  
> at  
> org.elasticsearch.index.mapper.core.AbstractFieldMapper.parse(AbstractFieldMapper.java:405)  
> ... 12 more  
> [2014-05-08 11:00:43,813][WARN][indices.cluster] [LogstashES3]  
> [logstash-2014.05.05][3] failed to start shard  
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException:  
> [logstash-2014.05.05][3] failed to recover shard  
> at  
> org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:238)  
> at  
> org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
> at  
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
> at java.lang.Thread.run(Thread.java:744)  
> Caused by: java.lang.IllegalArgumentException: No type mapped for [92]  
> at  
> org.elasticsearch.index.translog.Translog$Operation$Type.fromId(Translog.java:216)  
> at  
> org.elasticsearch.index.translog.TranslogStreams.readTranslogOperation(TranslogStreams.java:34)  
> at  
> org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:215)  
> ... 4 more  
> [2014-05-08 11:00:43,814][WARN][cluster.action.shard] [LogstashES3]  
> [logstash-2014.05.05][3] sending failed shard for [logstash-  
> 2014.05.05][3], node[\_v2d00AJTlWnJoNbUGhotA], [P], s[INITIALIZING],  
> indexUUID [Ui9T7dl4RSWjuodOs9tSJA], reason [Failed to start shard, message  
> [IndexShar  
> dGatewayRecoveryException[[logstash-2014.05.05][3] failed to recover  
> shard]; nested: IllegalArgumentException[No type mapped for [92]]; ]]  
> [2014-05-08 11:00:43,855][INFO][index.gateway.local] [LogstashES3]  
> [logstash-2014.05.05][1] ignoring recovery of a corrupt tran  
> slog entry

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/47864a71-3f38-4bed-8e5f-10be54d4d830%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/47864a71-3f38-4bed-8e5f-10be54d4d830%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:30am UTC](https://discuss.elastic.co/t/corrupt-translog-entry-error-in-index-recovery/17407/2 "2017-07-06T01:30:51Z")

</div>


