# Corrupted Index

**URL:** https://discuss.elastic.co/t/corrupted-index/23319
**Category:** Elasticsearch
**Created:** [April 20, 2015, 11:03am UTC](https://discuss.elastic.co/t/corrupted-index/23319 "2015-04-20T11:03:15Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![RanjithVenkat](https://avatars.discourse-cdn.com/v4/letter/r/c5a1d2/32.png) [@RanjithVenkat](https://discuss.elastic.co/u/RanjithVenkat)
#### Post date: [April 20, 2015, 11:03am UTC](https://discuss.elastic.co/t/corrupted-index/23319/1 "2015-04-20T11:03:15Z")

</div>

Dear all,

We are using ES-1.3.7 for our search Application. Sometime back we upgraded  
from 0.90.5 to 1.3.7. We have 2 master nodes and 3 data nodes. We are  
getting CorruptedIndexException when Shard initialization is happening.  
This is the second time we are facing such issue since last update. Last  
time, only one shard got corrupted, but now almost 15 to 20 shards got  
corrupted. Each shard has only ~500MB data.

log trace :

[2015-04-19 22:49:57,552][WARN][cluster.action.shard] [Node1]

> > [138][3] received shard failed for [138][3], node[EkvXNBUOTcuEfWo4SG72bA],  
> > [P], s[INITIALIZING], indexUUID [_na_], reason [Failed to start shard,  
> > message [IndexShardGatewayRecoveryException[[138][3] failed to fetch index  
> > version after copying it over]; nested: CorruptIndexException[[138][3]  
> > Corrupted index [corrupted\_gb9JvBzdRQKqkhEeaXFEIA] caused by:  
> > CorruptIndexException[checksum failed (hardware problem?) : expected=637c1x  
> > actual=gavi2b  
> > resource=(org.apache.lucene.store.FSDirectory$FSIndexOutput@54916f2a)]]; ]]
> 
> [2015-04-19 22:49:57,626][WARN][cluster.action.shard] [Node1]
> 
> > [138][3] received shard failed for [138][3], node[Q1eAQgNtSJ2BLlMevzRzcA],  
> > [P], s[INITIALIZING], indexUUID [_na_], reason [Failed to start shard,  
> > message [IndexShardGatewayRecoveryException[[138][3] failed recovery];  
> > nested: EngineCreationFailureException[[138][3] failed to open reader on  
> > writer]; nested: FileNotFoundException[No such file [\_1gy\_x.del]]; ]]

Thanks in advance

Ranjith Venkatesan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/6f1881d0-9f43-4a01-a9e3-9337a1486fed%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/6f1881d0-9f43-4a01-a9e3-9337a1486fed%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:18am UTC](https://discuss.elastic.co/t/corrupted-index/23319/2 "2017-07-06T00:18:46Z")

</div>


