# CorruptIndexException when trying to replicate one shard of a new index

**URL:** <https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387>\
**Category:** Elasticsearch\
**Created:** [October 22, 2014, 8:57pm UTC](https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387 "2014-10-22T20:57:06Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nate\_Folkert](https://avatars.discourse-cdn.com/v4/letter/n/8edcca/32.png) [@Nate\_Folkert](https://discuss.elastic.co/u/Nate_Folkert)\
**Post date:** [October 22, 2014, 8:57pm UTC](https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387/1 "2014-10-22T20:57:06Z")

</div>

Created and populated a new index on a 1.3.1 cluster. Primary shards work  
fine. Updated the index to create several replicas, and three of the four  
shards replicated, but one shard fails to replicate on any node with the  
following error (abbreviated some of the hashes for readability):

[2014-10-22 20:31:54,549][WARN][index.engine.internal] [NODENAME]

> > [INDEXNAME][2] failed engine [corrupted preexisting index]
> 
> [2014-10-22 20:31:54,549][WARN][indices.cluster] [NODENAME]
> 
> > [INDEXNAME][2] failed to start shard
> 
> org.apache.lucene.index.CorruptIndexException: [INDEXNAME][2] Corrupted
> 
> > index [CORRUPTED] caused by: CorruptIndexException[codec footer mismatch:  
> > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]
> 
> at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:343)
> 
> at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:328)
> 
> at
> 
> > org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:723)
> 
> at
> 
> > org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:576)
> 
> at
> 
> > org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:183)
> 
> at
> 
> > org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:444)
> 
> at
> 
> > org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
> 
> at
> 
> > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> 
> at
> 
> > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> 
> at java.lang.Thread.run(Thread.java:745)
> 
> [2014-10-22 20:31:54,549][WARN][cluster.action.shard] [NODENAME]
> 
> > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID], [R],  
> > s[INITIALIZING], indexUUID [INDEXID], reason [Failed to start shard,  
> > message [CorruptIndexException[[INDEXNAME][2] Corrupted index [CORRUPTED]  
> > caused by: CorruptIndexException[codec footer mismatch: actual  
> > footer=1161826848 vs expected footer=-1071082520 (resource:  
> > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> 
> [2014-10-22 20:31:54,550][WARN][cluster.action.shard] [NODENAME]
> 
> > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID], [R],  
> > s[INITIALIZING], indexUUID [INDEXID], reason [engine failure, message  
> > [corrupted preexisting index][CorruptIndexException[[INDEXNAME][2]  
> > Corrupted index [CORRUPTED] caused by: CorruptIndexException[codec footer  
> > mismatch: actual footer=1161826848 vs expected footer=-1071082520  
> > (resource: MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]

The index is stuck now in a state where the shards try to replicate on one  
set of nodes, hit this failure, and then switch to try to replicate on a  
different set of nodes. Have been looking around to see if anyone's  
encountered a similar issue but haven't found anything useful yet. Anybody  
know if this is recoverable or if I should just scrap it and try building a  
new one?

- Nate

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Robert\_Muir\_2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/robert_muir_2/32/931_2.png) [@Robert\_Muir\_2](https://discuss.elastic.co/u/Robert_Muir_2)\
**Post date:** [October 22, 2014, 9:26pm UTC](https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387/2 "2014-10-22T21:26:14Z")

</div>

Can you try the workaround mentioned here:

> **[Elasticsearch Platform — Find real-time answers at scale](https://www.elastic.co)**
>
> Power insights and outcomes with the Elasticsearch Platform and AI. See into your data and find answers that matter with enterprise solutions designed to help you build, observe, and protect. Try Elasticsearch free today.

and see if it works? If the compression issue is the problem, you can  
re-enable compression, just upgrade to at least 1.3.2 which has the  
fix.

On Wed, Oct 22, 2014 at 4:57 PM, Nate Folkert [nfolkert@foursquare.com](mailto:nfolkert@foursquare.com) wrote:

> Created and populated a new index on a 1.3.1 cluster. Primary shards work  
> fine. Updated the index to create several replicas, and three of the four  
> shards replicated, but one shard fails to replicate on any node with the  
> following error (abbreviated some of the hashes for readability):
> 
> > > [2014-10-22 20:31:54,549][WARN][index.engine.internal] [NODENAME]  
> > > [INDEXNAME][2] failed engine [corrupted preexisting index]
> > > 
> > > [2014-10-22 20:31:54,549][WARN][indices.cluster] [NODENAME]  
> > > [INDEXNAME][2] failed to start shard
> > > 
> > > org.apache.lucene.index.CorruptIndexException: [INDEXNAME][2] Corrupted  
> > > index [CORRUPTED] caused by: CorruptIndexException[codec footer mismatch:  
> > > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]
> > > 
> > > at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:343)
> > > 
> > > at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:328)
> > > 
> > > at  
> > > org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:723)
> > > 
> > > at  
> > > org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:576)
> > > 
> > > at  
> > > org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:183)
> > > 
> > > at  
> > > org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:444)
> > > 
> > > at  
> > > org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
> > > 
> > > at  
> > > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> > > 
> > > at  
> > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > 
> > > at java.lang.Thread.run(Thread.java:745)
> > > 
> > > [2014-10-22 20:31:54,549][WARN][cluster.action.shard] [NODENAME]  
> > > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID], [R],  
> > > s[INITIALIZING], indexUUID [INDEXID], reason [Failed to start shard, message  
> > > [CorruptIndexException[[INDEXNAME][2] Corrupted index [CORRUPTED] caused by:  
> > > CorruptIndexException[codec footer mismatch: actual footer=1161826848 vs  
> > > expected footer=-1071082520 (resource:  
> > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> > > 
> > > [2014-10-22 20:31:54,550][WARN][cluster.action.shard] [NODENAME]  
> > > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID], [R],  
> > > s[INITIALIZING], indexUUID [INDEXID], reason [engine failure, message  
> > > [corrupted preexisting index][CorruptIndexException[[INDEXNAME][2] Corrupted  
> > > index [CORRUPTED] caused by: CorruptIndexException[codec footer mismatch:  
> > > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> 
> The index is stuck now in a state where the shards try to replicate on one  
> set of nodes, hit this failure, and then switch to try to replicate on a  
> different set of nodes. Have been looking around to see if anyone's  
> encountered a similar issue but haven't found anything useful yet. Anybody  
> know if this is recoverable or if I should just scrap it and try building a  
> new one?
> 
> - Nate
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAMUKNZVEaeNXW%3DH6%2Bczq2M1s7Xf5g1quabGa749M8BZYMUfe%3Dg%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAMUKNZVEaeNXW%3DH6%2Bczq2M1s7Xf5g1quabGa749M8BZYMUfe%3Dg%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Nate\_Folkert](https://avatars.discourse-cdn.com/v4/letter/n/8edcca/32.png) [@Nate\_Folkert](https://discuss.elastic.co/u/Nate_Folkert)\
**Post date:** [October 22, 2014, 10:01pm UTC](https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387/3 "2014-10-22T22:01:02Z")

</div>

After disabling compression, I was able to successfully replicate that  
shard, so looks like we're hitting that bug. I guess we'll have to upgrade!

Thanks!

- Nate

On Wednesday, October 22, 2014 5:26:42 PM UTC-4, Robert Muir wrote:

> Can you try the workaround mentioned here:  
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/elasticsearch-1-3-2-released/)
> 
> and see if it works? If the compression issue is the problem, you can  
> re-enable compression, just upgrade to at least 1.3.2 which has the  
> fix.
> 
> On Wed, Oct 22, 2014 at 4:57 PM, Nate Folkert \<[nfol...@foursquare.com](mailto:nfol...@foursquare.com)  
> \<javascript:\>\> wrote:
> 
> > Created and populated a new index on a 1.3.1 cluster. Primary shards  
> > work  
> > fine. Updated the index to create several replicas, and three of the  
> > four  
> > shards replicated, but one shard fails to replicate on any node with the  
> > following error (abbreviated some of the hashes for readability):
> > 
> > > > [2014-10-22 20:31:54,549][WARN][index.engine.internal] [NODENAME]  
> > > > [INDEXNAME][2] failed engine [corrupted preexisting index]
> > > > 
> > > > [2014-10-22 20:31:54,549][WARN][indices.cluster] [NODENAME]  
> > > > [INDEXNAME][2] failed to start shard
> > > > 
> > > > org.apache.lucene.index.CorruptIndexException: [INDEXNAME][2]  
> > > > Corrupted  
> > > > index [CORRUPTED] caused by: CorruptIndexException[codec footer  
> > > > mismatch:  
> > > > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]
> > > > 
> > > > at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:343)
> > > > 
> > > > at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:328)
> > > > 
> > > > at
> 
> org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:723)
> 
> > > > at
> 
> org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:576)
> 
> > > > at
> 
> org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:183)
> 
> > > > at
> 
> org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:444)
> 
> > > > at
> 
> org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
> 
> > > > at
> 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> 
> > > > at
> 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> 
> > > > at java.lang.Thread.run(Thread.java:745)
> > > > 
> > > > [2014-10-22 20:31:54,549][WARN][cluster.action.shard] [NODENAME]  
> > > > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID],  
> > > > [R],  
> > > > s[INITIALIZING], indexUUID [INDEXID], reason [Failed to start shard,  
> > > > message  
> > > > [CorruptIndexException[[INDEXNAME][2] Corrupted index [CORRUPTED]  
> > > > caused by:  
> > > > CorruptIndexException[codec footer mismatch: actual footer=1161826848  
> > > > vs  
> > > > expected footer=-1071082520 (resource:  
> > > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> > > > 
> > > > [2014-10-22 20:31:54,550][WARN][cluster.action.shard] [NODENAME]  
> > > > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID],  
> > > > [R],  
> > > > s[INITIALIZING], indexUUID [INDEXID], reason [engine failure, message  
> > > > [corrupted preexisting index][CorruptIndexException[[INDEXNAME][2]  
> > > > Corrupted  
> > > > index [CORRUPTED] caused by: CorruptIndexException[codec footer  
> > > > mismatch:  
> > > > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> > 
> > The index is stuck now in a state where the shards try to replicate on  
> > one  
> > set of nodes, hit this failure, and then switch to try to replicate on a  
> > different set of nodes. Have been looking around to see if anyone's  
> > encountered a similar issue but haven't found anything useful yet.  
> > Anybody  
> > know if this is recoverable or if I should just scrap it and try  
> > building a  
> > new one?
> > 
> > - Nate
> > 
> > --  
> > You received this message because you are subscribed to the Google  
> > Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send  
> > an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > To view this discussion on the web visit
> 
> [https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com).
> 
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/210c5bf5-c71a-4d5a-891d-3485a86dc0b4%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/210c5bf5-c71a-4d5a-891d-3485a86dc0b4%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Robert\_Muir\_2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/robert_muir_2/32/931_2.png) [@Robert\_Muir\_2](https://discuss.elastic.co/u/Robert_Muir_2)\
**Post date:** [October 23, 2014, 2:46am UTC](https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387/4 "2014-10-23T02:46:27Z")

</div>

Thanks for closing the loop.

On Wed, Oct 22, 2014 at 6:01 PM, Nate Folkert [nfolkert@foursquare.com](mailto:nfolkert@foursquare.com) wrote:

> After disabling compression, I was able to successfully replicate that  
> shard, so looks like we're hitting that bug. I guess we'll have to upgrade!
> 
> Thanks!
> 
> - Nate
> 
> On Wednesday, October 22, 2014 5:26:42 PM UTC-4, Robert Muir wrote:
> 
> > Can you try the workaround mentioned here:  
> > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/elasticsearch-1-3-2-released/)
> > 
> > and see if it works? If the compression issue is the problem, you can  
> > re-enable compression, just upgrade to at least 1.3.2 which has the  
> > fix.
> > 
> > On Wed, Oct 22, 2014 at 4:57 PM, Nate Folkert [nfol...@foursquare.com](mailto:nfol...@foursquare.com)  
> > wrote:
> > 
> > > Created and populated a new index on a 1.3.1 cluster. Primary shards  
> > > work  
> > > fine. Updated the index to create several replicas, and three of the  
> > > four  
> > > shards replicated, but one shard fails to replicate on any node with the  
> > > following error (abbreviated some of the hashes for readability):
> > > 
> > > > > [2014-10-22 20:31:54,549][WARN][index.engine.internal] [NODENAME]  
> > > > > [INDEXNAME][2] failed engine [corrupted preexisting index]
> > > > > 
> > > > > [2014-10-22 20:31:54,549][WARN][indices.cluster] [NODENAME]  
> > > > > [INDEXNAME][2] failed to start shard
> > > > > 
> > > > > org.apache.lucene.index.CorruptIndexException: [INDEXNAME][2]  
> > > > > Corrupted  
> > > > > index [CORRUPTED] caused by: CorruptIndexException[codec footer  
> > > > > mismatch:  
> > > > > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > > > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]
> > > > > 
> > > > > at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:343)
> > > > > 
> > > > > at org.elasticsearch.index.store.Store.failIfCorrupted(Store.java:328)
> > > > > 
> > > > > at
> > > > > 
> > > > > org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:723)
> > > > > 
> > > > > at
> > > > > 
> > > > > org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:576)
> > > > > 
> > > > > at
> > > > > 
> > > > > org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:183)
> > > > > 
> > > > > at
> > > > > 
> > > > > org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:444)
> > > > > 
> > > > > at
> > > > > 
> > > > > org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
> > > > > 
> > > > > at
> > > > > 
> > > > > java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
> > > > > 
> > > > > at
> > > > > 
> > > > > java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
> > > > > 
> > > > > at java.lang.Thread.run(Thread.java:745)
> > > > > 
> > > > > [2014-10-22 20:31:54,549][WARN][cluster.action.shard] [NODENAME]  
> > > > > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID],  
> > > > > [R],  
> > > > > s[INITIALIZING], indexUUID [INDEXID], reason [Failed to start shard,  
> > > > > message  
> > > > > [CorruptIndexException[[INDEXNAME][2] Corrupted index [CORRUPTED]  
> > > > > caused by:  
> > > > > CorruptIndexException[codec footer mismatch: actual footer=1161826848  
> > > > > vs  
> > > > > expected footer=-1071082520 (resource:  
> > > > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> > > > > 
> > > > > [2014-10-22 20:31:54,550][WARN][cluster.action.shard] [NODENAME]  
> > > > > [INDEXNAME][2] sending failed shard for [INDEXNAME][2], node[NODEID],  
> > > > > [R],  
> > > > > s[INITIALIZING], indexUUID [INDEXID], reason [engine failure, message  
> > > > > [corrupted preexisting index][CorruptIndexException[[INDEXNAME][2]  
> > > > > Corrupted  
> > > > > index [CORRUPTED] caused by: CorruptIndexException[codec footer  
> > > > > mismatch:  
> > > > > actual footer=1161826848 vs expected footer=-1071082520 (resource:  
> > > > > MMapIndexInput(path="DATAPATH/INDEXNAME/2/index/\_7cp.fdt"))]]]]
> > > 
> > > The index is stuck now in a state where the shards try to replicate on  
> > > one  
> > > set of nodes, hit this failure, and then switch to try to replicate on a  
> > > different set of nodes. Have been looking around to see if anyone's  
> > > encountered a similar issue but haven't found anything useful yet.  
> > > Anybody  
> > > know if this is recoverable or if I should just scrap it and try  
> > > building a  
> > > new one?
> > > 
> > > - Nate
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google  
> > > Groups  
> > > "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send  
> > > an  
> > > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit
> > > 
> > > [https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/51f1b345-a19d-4c70-873f-a88880d47e5a%40googlegroups.com).  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/210c5bf5-c71a-4d5a-891d-3485a86dc0b4%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/210c5bf5-c71a-4d5a-891d-3485a86dc0b4%40googlegroups.com).
> 
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAMUKNZUC9me5\_t7mU%3D9ke%3DzfgcT%2Bv1Ds3dq81vFoP13CH2iV-w%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAMUKNZUC9me5_t7mU%3D9ke%3DzfgcT%2Bv1Ds3dq81vFoP13CH2iV-w%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:54am UTC](https://discuss.elastic.co/t/corruptindexexception-when-trying-to-replicate-one-shard-of-a-new-index/20387/5 "2017-07-06T00:54:20Z")

</div>


