# CouchDB Integration - ClassNotFoundException\[couchdb\];

**URL:** <https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203>\
**Category:** Elasticsearch\
**Created:** [August 19, 2011, 11:29pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203 "2011-08-19T23:29:50Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![jramirez](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@jramirez](https://discuss.elastic.co/u/jramirez)\
**Post date:** [August 19, 2011, 11:29pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/1 "2011-08-19T23:29:50Z")

</div>

Hi, I'm having trouble integrating elasticsearch with couchdb.

I followed the instructions here: [couchdb-integration](http://www.elasticsearch.org/tutorials/2010/08/01/couchb-integration.html) but when searching (curl -XGET [http://localhost:9200/doc\_es\_idx/\_search](http://localhost:9200/doc_es_idx/_search) -d '{}') I get this error message:

{"error":"IndexMissingException[[doc\_es\_idx] missing]","status":404}

I've checked other posts and documentation and found a way to get the river status: curl -XGET '[http://localhost:9200/\_river/doc\_es\_idx/\_status](http://localhost:9200/_river/doc_es_idx/_status)' and I'm getting this error:

{"\_index":"\_river","\_type":"doc\_es\_idx","\_id":"\_status","\_version":1,"exists":true, "\_source" : {"error":"NoClassSettingsException[Failed to load class with value [couchdb]]; nested: ClassNotFoundException[couchdb]; ","node":{"id":"cy4GWzNlSTqkYvLETwC6DQ","name":"Gibborim","transport\_address":"inet[/10.0.2.15:9300]"}}}

I'm not sure what could have gone wrong. I've installed elasticsearch (0.17.6) & couchdb (1.0.1), both are up and running. I've also installed the couchdb-river without problems.

I created the river like this:

curl -XPUT '[http://127.0.0.1:9200/\_river/doc\_es\_idx/\_meta](http://127.0.0.1:9200/_river/doc_es_idx/_meta)' -d '{"type":"couchdb","couchdb":{"host":"localhost","port":5984,"db":"documents\_db","filter":null},"index":{"index":"doc\_es\_idx","type":"doc\_es\_type","bulk\_size":"100","bulk\_timeout":"10ms"}}'

Any help getting this solved will be really appreciated.

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [August 24, 2011, 6:22pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/2 "2011-08-24T18:22:27Z")

</div>

Have you installed the couchdb plugin?

On Sat, Aug 20, 2011 at 2:29 AM, jramirez [jose.alb@gmail.com](mailto:jose.alb@gmail.com) wrote:

> Hi, I'm having trouble integrating elasticsearch with couchdb.
> 
> I followed the instructions here:  
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/tutorials/2010/08/01/couchb-integration.html)  
> couchdb-integration but when searching (curl -XGET  
> [http://localhost:9200/doc\_es\_idx/\_search](http://localhost:9200/doc_es_idx/_search) -d '{}') I get this error  
> message:
> 
> {"error":"IndexMissingException[[doc\_es\_idx] missing]","status":404}
> 
> I've checked other posts and documentation and found a way to get the river  
> status: curl -XGET '[http://localhost:9200/\_river/doc\_es\_idx/\_status](http://localhost:9200/_river/doc_es_idx/_status)' and  
> I'm  
> getting this error:
> 
> {"\_index":"\_river","\_type":"doc\_es\_idx","\_id":"\_status","\_version":1,"exists":true,  
> "\_source" : {"error":"NoClassSettingsException[Failed to load class with  
> value [couchdb]]; nested: ClassNotFoundException[couchdb];
> 
> ","node":{"id":"cy4GWzNlSTqkYvLETwC6DQ","name":"Gibborim","transport\_address":"inet[/  
> 10.0.2.15:9300]"}}}
> 
> I'm not sure what could have gone wrong. I've installed elasticsearch  
> (0.17.6) & couchdb (1.0.1), both are up and running. I've also installed  
> the couchdb-river without problems.
> 
> I created the river like this:
> 
> curl -XPUT '[http://127.0.0.1:9200/\_river/doc\_es\_idx/\_meta](http://127.0.0.1:9200/_river/doc_es_idx/_meta)' -d
> 
> '{"type":"couchdb","couchdb":{"host":"localhost","port":5984,"db":"documents\_db","filter":null},"index":{"index":"doc\_es\_idx","type":"doc\_es\_type","bulk\_size":"100","bulk\_timeout":"10ms"}}'
> 
> Any help getting this solved will be really appreciated.
> 
> --  
> View this message in context:  
> [http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-ClassNotFoundException-couchdb-tp3269544p3269544.html](http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-ClassNotFoundException-couchdb-tp3269544p3269544.html)  
> Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

**Author:** ![jramirez](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@jramirez](https://discuss.elastic.co/u/jramirez)\
**Post date:** [August 24, 2011, 7:36pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/3 "2011-08-24T19:36:26Z")

</div>

Hi, yes I installed the couchdb plugin. Thanks everyone but this is already solved.

I started all over again, and re-installed everything including the plugin. I restarted after that, then everything went smoothly.

---

<div class="post-metadata">

**Author:** ![Ivan](https://avatars.discourse-cdn.com/v4/letter/i/df788c/32.png) [@Ivan](https://discuss.elastic.co/u/Ivan)\
**Post date:** [August 24, 2011, 9:35pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/4 "2011-08-24T21:35:03Z")

</div>

That was my thought as well, but he did state: "I've also installed  
the couchdb-river without problems."

In your 'plugins' directory (inside the root ES home directory), is  
the couchdb plugin listed?

--  
Ivan

On Wed, Aug 24, 2011 at 2:22 PM, Shay Banon [kimchy@gmail.com](mailto:kimchy@gmail.com) wrote:

> Have you installed the couchdb plugin?
> 
> On Sat, Aug 20, 2011 at 2:29 AM, jramirez [jose.alb@gmail.com](mailto:jose.alb@gmail.com) wrote:
> 
> > Hi, I'm having trouble integrating elasticsearch with couchdb.
> > 
> > I followed the instructions here:  
> > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/tutorials/2010/08/01/couchb-integration.html)  
> > couchdb-integration but when searching (curl -XGET  
> > [http://localhost:9200/doc\_es\_idx/\_search](http://localhost:9200/doc_es_idx/_search) -d '{}') I get this error  
> > message:
> > 
> > {"error":"IndexMissingException[[doc\_es\_idx] missing]","status":404}
> > 
> > I've checked other posts and documentation and found a way to get the  
> > river  
> > status: curl -XGET '[http://localhost:9200/\_river/doc\_es\_idx/\_status](http://localhost:9200/_river/doc_es_idx/_status)' and  
> > I'm  
> > getting this error:
> > 
> > {"\_index":"\_river","\_type":"doc\_es\_idx","\_id":"\_status","\_version":1,"exists":true,  
> > "\_source" : {"error":"NoClassSettingsException[Failed to load class with  
> > value [couchdb]]; nested: ClassNotFoundException[couchdb];
> > 
> > ","node":{"id":"cy4GWzNlSTqkYvLETwC6DQ","name":"Gibborim","transport\_address":"inet[/10.0.2.15:9300]"}}}
> > 
> > I'm not sure what could have gone wrong. I've installed elasticsearch  
> > (0.17.6) & couchdb (1.0.1), both are up and running. I've also installed  
> > the couchdb-river without problems.
> > 
> > I created the river like this:
> > 
> > curl -XPUT '[http://127.0.0.1:9200/\_river/doc\_es\_idx/\_meta](http://127.0.0.1:9200/_river/doc_es_idx/_meta)' -d
> > 
> > '{"type":"couchdb","couchdb":{"host":"localhost","port":5984,"db":"documents\_db","filter":null},"index":{"index":"doc\_es\_idx","type":"doc\_es\_type","bulk\_size":"100","bulk\_timeout":"10ms"}}'
> > 
> > Any help getting this solved will be really appreciated.
> > 
> > --  
> > View this message in context:  
> > [http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-ClassNotFoundException-couchdb-tp3269544p3269544.html](http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-ClassNotFoundException-couchdb-tp3269544p3269544.html)  
> > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

**Author:** ![James\_Cook](https://avatars.discourse-cdn.com/v4/letter/j/898d66/32.png) [@James\_Cook](https://discuss.elastic.co/u/James_Cook)\
**Post date:** [August 25, 2011, 1:39pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/5 "2011-08-25T13:39:27Z")

</div>

It will also appear in the log file. Search for something that looks like:

[plugins] loaded [...list of plugins...]

---

<div class="post-metadata">

**Author:** ![pulkitsinghal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pulkitsinghal/32/802_2.png) [@pulkitsinghal](https://discuss.elastic.co/u/pulkitsinghal)\
**Post date:** [October 18, 2011, 2:52pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/6 "2011-10-18T14:52:44Z")

</div>

Hi,

I'm running into the same exact problem. I realized that when I first  
added the river, CouchDB was not actually up and running. This is what  
may have caused this issue for others on thread as well?

Now I'm curious about: Is there no other way then to delete the river  
and restart?  
Is the 1st time failure to connect with CouchDB really that fatal?  
I can accept that but just want to make sure before I do.

Thank in advance for your thoughts.

This is not hijacking is it? I think this is pertinent to the topic in  
this thread...

- Pulkit

On Aug 24, 2:36 pm, jramirez [jose....@gmail.com](mailto:jose....@gmail.com) wrote:

> Hi, yes I installed thecouchdbplugin. Thanks everyone but this is already  
> solved.
> 
> I started all over again, and re-installed everything including the plugin.  
> I restarted after that, then everything went smoothly.
> 
> --  
> View this message in context:[http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-C](http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-C)...  
> Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

**Author:** ![pulkitsinghal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pulkitsinghal/32/802_2.png) [@pulkitsinghal](https://discuss.elastic.co/u/pulkitsinghal)\
**Post date:** [October 18, 2011, 3:06pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/7 "2011-10-18T15:06:07Z")

</div>

Allow me to add on a bit more and this is not again not a problem but  
just a description of the way things are in context to what happens.

1. Initially when the CouchDB is not up & running and one adds the  
river the server spits out:  
====  
[2011-10-18 09:35:33,454][INFO][cluster.metadata]  
[Ameridroid] [\_river] creating index, cause [auto(index api)], shards  
[1]/[1], mappings   
[2011-10-18 09:35:33,591][INFO][cluster.metadata]  
[Ameridroid] [\_river] update\_mapping [bbyopen\_int] (dynamic)  
[2011-10-18 09:35:33,686][WARN][river]  
[Ameridroid] failed to create river [couchdb][bbyopen\_int]  
org.elasticsearch.common.settings.NoClassSettingsException: Failed to  
load class with value [couchdb]  
at  
org.elasticsearch.river.RiverModule.loadTypeModule(RiverModule.java:
2. at org.elasticsearch.river.RiverModule.spawnModules(RiverModule.java:
3. at  
org.elasticsearch.common.inject.ModulesBuilder.add(ModulesBuilder.java:
4. at  
org.elasticsearch.river.RiversService.createRiver(RiversService.java:
5. 

```
at org.elasticsearch.river.RiversService$ApplyRivers

```

# $1.onResponse(RiversService.java:231) at org.elasticsearch.river.RiversService$ApplyRivers $1.onResponse(RiversService.java:226) at org.elasticsearch.action.support.BaseAction$ThreadedActionListener $1.run(BaseAction.java:84) at java.util.concurrent.ThreadPoolExecutor $Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor $Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:680) Caused by: java.lang.ClassNotFoundException: couchdb at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) at org.elasticsearch.river.RiverModule.loadTypeModule(RiverModule.java: 70) ... 9 more [2011-10-18 09:35:33,764][INFO][cluster.metadata] [Ameridroid] [\_river] update\_mapping [bbyopen\_int] (dynamic)

1. The client running the command sees:  
ClassNotFoundException[couchdb]

2. Any attempt to re-run the same command again to establish the river  
while ES is still up & running yields no changes in the situation,  
even though now CouchDB may be up.

3. BUT shutting down ES and restating it causes a few exceptions in  
the ES server side and is able to now get the data from CouchDB and  
get into an operational state 🙂  
====  
[2011-10-18 09:58:50,943][DEBUG][action.admin.indices.refresh]  
[Vashti] [\_river][0], node[QQiFz3-gTAObx5IgXJlB8g], [P],  
s[INITIALIZING]: Failed to execute  
[org.elasticsearch.action.admin.indices.refresh.RefreshRequest@3fa9b4a4]  
org.elasticsearch.indices.IndexMissingException: [\_river] missing  
at  
org.elasticsearch.indices.InternalIndicesService.indexServiceSafe(InternalIndicesService.java:

4. 

```
at

```

# org.elasticsearch.action.admin.indices.refresh.TransportRefreshAction.shardOperation(TransportRefreshAction.java: 124) at org.elasticsearch.action.admin.indices.refresh.TransportRefreshAction.shardOperation(TransportRefreshAction.java: 52) at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction $AsyncBroadcastAction$2.run(TransportBroadcastOperationAction.java: 223) at java.util.concurrent.ThreadPoolExecutor $Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor $Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:680) [2011-10-18 09:58:51,289][INFO][gateway] [Vashti] recovered [2] indices into cluster\_state [2011-10-18 09:58:51,386][INFO][river.couchdb] [Vashti] [couchdb][bbyopen\_int] starting couchdb stream: host [localhost], port [5984], filter [null], db [bbyopen], indexing to [bbyopen]/[bbyopen]

1. So I retract my earlier statement: "Is there no other way then to  
delete the river and restart?" because obviously, simply restarting ES  
fixes the situation.

On Oct 18, 9:52 am, pulkitsinghal [pulkitsing...@gmail.com](mailto:pulkitsing...@gmail.com) wrote:

> Hi,
> 
> I'm running into the same exact problem. I realized that when I first  
> added the river, CouchDB was not actually up and running. This is what  
> may have caused this issue for others on thread as well?
> 
> Now I'm curious about: Is there no other way then to delete the river  
> and restart?  
> Is the 1st time failure to connect with CouchDB really that fatal?  
> I can accept that but just want to make sure before I do.
> 
> Thank in advance for your thoughts.
> 
> This is not hijacking is it? I think this is pertinent to the topic in  
> this thread...
> 
> - Pulkit
> 
> On Aug 24, 2:36 pm, jramirez [jose....@gmail.com](mailto:jose....@gmail.com) wrote:
> 
> > Hi, yes I installed thecouchdbplugin. Thanks everyone but this is already  
> > solved.
> 
> > I started all over again, and re-installed everything including the plugin.  
> > I restarted after that, then everything went smoothly.
> 
> > --  
> > View this message in context:[http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-C](http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-C)...  
> > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [October 18, 2011, 4:24pm UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/8 "2011-10-18T16:24:54Z")

</div>

If you did not install the plugin beforehand, then you have to restart the  
node so it will startup with the mentioned plugin. Assuming the plugin is  
installed, Loosing connection to couch will be handled by retrying to  
connect to it. You can definitely delete the river.

The exception that you saw, with the refresh, can be ignored, and fixed in  
laster.

On Tue, Oct 18, 2011 at 5:06 PM, pulkitsinghal [pulkitsinghal@gmail.com](mailto:pulkitsinghal@gmail.com)wrote:

> Allow me to add on a bit more and this is not again not a problem but  
> just a description of the way things are in context to what happens.
> 
> 1. Initially when the CouchDB is not up & running and one adds the  
> river the server spits out:  
> ====  
> [2011-10-18 09:35:33,454][INFO][cluster.metadata]  
> [Ameridroid] [\_river] creating index, cause [auto(index api)], shards  
> [1]/[1], mappings   
> [2011-10-18 09:35:33,591][INFO][cluster.metadata]  
> [Ameridroid] [\_river] update\_mapping [bbyopen\_int] (dynamic)  
> [2011-10-18 09:35:33,686][WARN][river]  
> [Ameridroid] failed to create river [couchdb][bbyopen\_int]  
> org.elasticsearch.common.settings.NoClassSettingsException: Failed to  
> load class with value [couchdb]  
> at  
> org.elasticsearch.river.RiverModule.loadTypeModule(RiverModule.java:
> 
> 2. at  
> org.elasticsearch.river.RiverModule.spawnModules(RiverModule.java:
> 
> 3. at  
> org.elasticsearch.common.inject.ModulesBuilder.add(ModulesBuilder.java:
> 
> 4. at  
> org.elasticsearch.river.RiversService.createRiver(RiversService.java:
> 
> 5. at org.elasticsearch.river.RiversService$ApplyRivers  
> $1.onResponse(RiversService.java:231)  
> at org.elasticsearch.river.RiversService$ApplyRivers  
> $1.onResponse(RiversService.java:226)  
> at  
> org.elasticsearch.action.support.BaseAction$ThreadedActionListener  
> $1.run(BaseAction.java:84)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.runTask(ThreadPoolExecutor.java:886)  
> at java.util.concurrent.ThreadPoolExecutor  
> $Worker.run(ThreadPoolExecutor.java:908)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: java.lang.ClassNotFoundException: couchdb  
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)  
> at java.security.AccessController.doPrivileged(Native Method)  
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)  
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)  
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)  
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)  
> at  
> org.elasticsearch.river.RiverModule.loadTypeModule(RiverModule.java:
> 
> 6. ... 9 more  
> [2011-10-18 09:35:33,764][INFO][cluster.metadata]  
> [Ameridroid] [\_river] update\_mapping [bbyopen\_int] (dynamic)  
> ====
> 
> 7. The client running the command sees:  
> ClassNotFoundException[couchdb]
> 
> 8. Any attempt to re-run the same command again to establish the river  
> while ES is still up & running yields no changes in the situation,  
> even though now CouchDB may be up.
> 
> 9. BUT shutting down ES and restating it causes a few exceptions in  
> the ES server side and is able to now get the data from CouchDB and  
> get into an operational state 🙂  
> ====  
> [2011-10-18 09:58:50,943][DEBUG][action.admin.indices.refresh]  
> [Vashti] [\_river][0], node[QQiFz3-gTAObx5IgXJlB8g], [P],  
> s[INITIALIZING]: Failed to execute  
> [org.elasticsearch.action.admin.indices.refresh.RefreshRequest@3fa9b4a4]  
> org.elasticsearch.indices.IndexMissingException: [\_river] missing  
> at
> 
> org.elasticsearch.indices.InternalIndicesService.indexServiceSafe(InternalIndicesService.java:  
> 227)  
> at
> 
> org.elasticsearch.action.admin.indices.refresh.TransportRefreshAction.shardOperation(TransportRefreshAction.java:  
> 124)  
> at
> 
> org.elasticsearch.action.admin.indices.refresh.TransportRefreshAction.shardOperation(TransportRefreshAction.java:  
> 52)  
> at
> 
> # org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction $AsyncBroadcastAction$2.run(TransportBroadcastOperationAction.java: 223) at java.util.concurrent.ThreadPoolExecutor $Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor $Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:680) [2011-10-18 09:58:51,289][INFO][gateway] [Vashti] recovered [2] indices into cluster\_state [2011-10-18 09:58:51,386][INFO][river.couchdb] [Vashti] [couchdb][bbyopen\_int] starting couchdb stream: host [localhost], port [5984], filter [null], db [bbyopen], indexing to [bbyopen]/[bbyopen]
> 
> 1. So I retract my earlier statement: "Is there no other way then to  
> delete the river and restart?" because obviously, simply restarting ES  
> fixes the situation.
> 
> On Oct 18, 9:52 am, pulkitsinghal [pulkitsing...@gmail.com](mailto:pulkitsing...@gmail.com) wrote:
> 
> > Hi,
> > 
> > I'm running into the same exact problem. I realized that when I first  
> > added the river, CouchDB was not actually up and running. This is what  
> > may have caused this issue for others on thread as well?
> > 
> > Now I'm curious about: Is there no other way then to delete the river  
> > and restart?  
> > Is the 1st time failure to connect with CouchDB really that fatal?  
> > I can accept that but just want to make sure before I do.
> > 
> > Thank in advance for your thoughts.
> > 
> > This is not hijacking is it? I think this is pertinent to the topic in  
> > this thread...
> > 
> > - Pulkit
> > 
> > On Aug 24, 2:36 pm, jramirez [jose....@gmail.com](mailto:jose....@gmail.com) wrote:
> > 
> > > Hi, yes I installed thecouchdbplugin. Thanks everyone but this is  
> > > already  
> > > solved.
> > 
> > > I started all over again, and re-installed everything including the  
> > > plugin.  
> > > I restarted after that, then everything went smoothly.
> > 
> > > --  
> > > View this message in context:  
> > > [http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-C](http://elasticsearch-users.115913.n3.nabble.com/CouchDB-Integration-C)...  
> > > Sent from the Elasticsearch Users mailing list archive at [Nabble.com](http://Nabble.com).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:51am UTC](https://discuss.elastic.co/t/couchdb-integration-classnotfoundexception-couchdb/5203/9 "2017-07-06T03:51:36Z")

</div>


