# Could not config test logstash

**URL:** <https://discuss.elastic.co/t/could-not-config-test-logstash/108153>\
**Category:** Logstash\
**Created:** [November 17, 2017, 3:16pm UTC](https://discuss.elastic.co/t/could-not-config-test-logstash/108153 "2017-11-17T15:16:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Makra](https://avatars.discourse-cdn.com/v4/letter/m/8491ac/32.png) [@Makra](https://discuss.elastic.co/u/Makra)\
**Post date:** [November 17, 2017, 3:16pm UTC](https://discuss.elastic.co/t/could-not-config-test-logstash/108153/1 "2017-11-17T15:16:17Z")

</div>

Hi  
I have an issue where i cannot config test logstash configuration file, Looks like a Java issue but could not figured out. JAVA\_HOME and java path is set correctly. I m using CentOS 7 and logstash 5

> $ /usr/share/logstash/bin/logstash --configtest -f /etc/logstash/conf.d/\*.conf

Java HotSpot(TM) 64-Bit Server VM warning: Option UseParNewGC was deprecated in version 9.0 and will likely be removed in a future release.  
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by jnr.posix.JavaLibCHelper to method sun.nio.ch.SelChImpl.getFD()  
WARNING: Please consider reporting this to the maintainers of jnr.posix.JavaLibCHelper  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
io/console on JRuby shells out to stty for most operations  
**NameError: cannot link Java class org.logstash.common.DeadLetterQueueFactory** (java.lang.NoClassDefFoundError: javax/script/ScriptEngineFactory)  
get\_proxy\_or\_package\_under\_package at org/jruby/javasupport/JavaUtilities.java:54  
method\_missing at file:/usr/share/logstash/vendor/jruby/lib/jruby.jar!/jruby/java/java\_package\_module\_template.rb:14  
DeadLetterQueueFactory at /usr/share/logstash/logstash-core/lib/logstash/util/dead\_letter\_queue\_manager.rb:46  
Util at /usr/share/logstash/logstash-core/lib/logstash/util/dead\_letter\_queue\_manager.rb:45  
LogStash at /usr/share/logstash/logstash-core/lib/logstash/util/dead\_letter\_queue\_manager.rb:3  
(root) at /usr/share/logstash/logstash-core/lib/logstash/util/dead\_letter\_queue\_manager.rb:3  
require at org/jruby/RubyKernel.java:1040  
require at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65  
(root) at /usr/share/logstash/logstash-core/lib/logstash/plugin.rb:1  
require at org/jruby/RubyKernel.java:1040  
(root) at /usr/share/logstash/logstash-core/lib/logstash/plugin.rb:6  
(root) at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:1  
require at org/jruby/RubyKernel.java:1040  
require at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65  
(root) at /usr/share/logstash/logstash-core/lib/logstash/filters/base.rb:5  
require at org/jruby/RubyKernel.java:1040  
(root) at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:1  
require at org/jruby/RubyKernel.java:1040  
require at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/polyglot-0.3.5/lib/polyglot.rb:65  
require at org/jruby/RubyKernel.java:1040  
(root) at /usr/share/logstash/lib/bootstrap/environment.rb:70

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 17, 2017, 3:54pm UTC](https://discuss.elastic.co/t/could-not-config-test-logstash/108153/2 "2017-11-17T15:54:52Z")

</div>

It looks like you're using Java 9 which isn't supported.

---

<div class="post-metadata">

**Author:** ![Makra](https://avatars.discourse-cdn.com/v4/letter/m/8491ac/32.png) [@Makra](https://discuss.elastic.co/u/Makra)\
**Post date:** [November 18, 2017, 6:59am UTC](https://discuss.elastic.co/t/could-not-config-test-logstash/108153/3 "2017-11-18T06:59:20Z")

</div>

Thanks @magnusbaeck ! JAVA 9 isn't supported.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 16, 2017, 6:59am UTC](https://discuss.elastic.co/t/could-not-config-test-logstash/108153/4 "2017-12-16T06:59:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
