# Could not connect to a compatible version of Elasticsearch (elasticsearch 7.8.0 with logstash 7.17.1)

**URL:** https://discuss.elastic.co/t/could-not-connect-to-a-compatible-version-of-elasticsearch-elasticsearch-7-8-0-with-logstash-7-17-1/300688
**Category:** Logstash
**Created:** [March 25, 2022, 11:03am UTC](https://discuss.elastic.co/t/could-not-connect-to-a-compatible-version-of-elasticsearch-elasticsearch-7-8-0-with-logstash-7-17-1/300688 "2022-03-25T11:03:49Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![splash](https://avatars.discourse-cdn.com/v4/letter/s/ac8455/32.png) [@splash](https://discuss.elastic.co/u/splash)
#### Post date: [March 25, 2022, 11:03am UTC](https://discuss.elastic.co/t/could-not-connect-to-a-compatible-version-of-elasticsearch-elasticsearch-7-8-0-with-logstash-7-17-1/300688/1 "2022-03-25T11:03:50Z")

</div>

Hi everyone,

we are running a Robotic Process Automation software called "Automation Anywhere" which uses Elasticsearch 7.8.0:

```auto
"version" : {
    "number" : "7.8.0",
    "build_flavor" : "oss",
    "build_type" : "zip",
    "build_hash" : "757314695644ea9a1dc2fecd26d1a43856725e65",
    "build_date" : "2020-06-14T19:35:50.234439Z",
    "build_snapshot" : false,
    "lucene_version" : "8.5.1",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  }

```

To ship the logs from Elasticsearch to Kibana, we are using logstash 7.10.0. Due to the log4j security issues, we tried to update it to version 7.17.1.

According to the compatibility matrix ([Unterstützungsmatrix | Elastic](https://www.elastic.co/de/support/matrix#matrix_compatibility)) Elasticsearch 7.8.0 should work with logstash 7.17.1.

But still, we are getting the following error message:

```auto
[2022-03-25T11:21:12,329][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>500, "pipeline.sources"=>["E:/Logstash/config/CR.conf"], :thread=>"#<Thread:0x7beffb32 run>"}
[2022-03-25T11:21:13,188][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=>0.86}
[2022-03-25T11:21:13,932][WARN][logstash.runner] SIGINT received. Shutting down.
[2022-03-25T11:21:14,257][ERROR][logstash.javapipeline][main] Pipeline error {:pipeline_id=>"main", :exception=>#<LogStash::ConfigurationError: Could not connect to a compatible version of Elasticsearch>, :backtrace=>["E:/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-elasticsearch-4.12.2/lib/logstash/inputs/elasticsearch.rb:481:in `test_connection!'", "E:/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-elasticsearch-4.12.2/lib/logstash/inputs/elasticsearch.rb:243:in `register'", "E:/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-mixin-ecs_compatibility_support-1.3.0-java/lib/logstash/plugin_mixins/ecs_compatibility_support/target_check.rb:48:in `register'", "E:/logstash/logstash-core/lib/logstash/java_pipeline.rb:232:in `block in register_plugins'", "org/jruby/RubyArray.java:1821:in `each'", "E:/logstash/logstash-core/lib/logstash/java_pipeline.rb:231:in `register_plugins'", "E:/logstash/logstash-core/lib/logstash/java_pipeline.rb:390:in `start_inputs'", "E:/logstash/logstash-core/lib/logstash/java_pipeline.rb:315:in `start_workers'", "E:/logstash/logstash-core/lib/logstash/java_pipeline.rb:189:in `run'", "E:/logstash/logstash-core/lib/logstash/java_pipeline.rb:141:in `block in start'"], "pipeline.sources"=>["E:/Logstash/config/CR.conf"], :thread=>"#<Thread:0x7beffb32 run>"}
[2022-03-25T11:21:14,258][INFO][logstash.javapipeline][main] Pipeline terminated {"pipeline.id"=>"main"}
[2022-03-25T11:21:14,273][ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2022-03-25T11:21:14,333][INFO][logstash.runner] Logstash shut down.
[2022-03-25T11:21:14,340][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
	at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.20.1.jar:?]
	at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.20.1.jar:?]
at E_3a_.logstash.lib.bootstrap.environment.<main>(E:\logstash\lib\bootstrap\environment.rb:94) ~[?:?]

```

Does anyone have an idea how I can make this work?

Thanks in advance!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 25, 2022, 11:03am UTC](https://discuss.elastic.co/t/could-not-connect-to-a-compatible-version-of-elasticsearch-elasticsearch-7-8-0-with-logstash-7-17-1/300688/2 "2022-03-25T11:03:50Z")

</div>

Elasticsearch 7.8 is [EOL](https://www.elastic.co/support/eol) and no longer supported. Please upgrade ASAP.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [March 25, 2022, 3:35pm UTC](https://discuss.elastic.co/t/could-not-connect-to-a-compatible-version-of-elasticsearch-elasticsearch-7-8-0-with-logstash-7-17-1/300688/3 "2022-03-25T15:35:47Z")

</div>

See [this](https://discuss.elastic.co/t/logtstash-updating-fron-7-9-to-7-16-2/298453/2) post.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 22, 2022, 3:36pm UTC](https://discuss.elastic.co/t/could-not-connect-to-a-compatible-version-of-elasticsearch-elasticsearch-7-8-0-with-logstash-7-17-1/300688/4 "2022-04-22T15:36:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
