# Could not test configuration of filebeat

**URL:** https://discuss.elastic.co/t/could-not-test-configuration-of-filebeat/93159
**Category:** Beats
**Tags:** filebeat
**Created:** [July 14, 2017, 9:58am UTC](https://discuss.elastic.co/t/could-not-test-configuration-of-filebeat/93159 "2017-07-14T09:58:03Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![marwa](https://avatars.discourse-cdn.com/v4/letter/m/67e7ee/32.png) [@marwa](https://discuss.elastic.co/u/marwa)
#### Post date: [July 14, 2017, 9:58am UTC](https://discuss.elastic.co/t/could-not-test-configuration-of-filebeat/93159/1 "2017-07-14T09:58:04Z")

</div>

after installing filebeat and configuring the file filebeat.yml to specify the host IP .I tried to test its configuration .  
after specifying the location of the installation of filebeat , i run this command to tst its configuration.  
./filebeat -configtest -e

but this error occurs  
[cmarwa@vds005 filebeat-5.5.0-linux-x86\_64]$ ./filebeat -configtest -e  
filebeat2017/07/14 09:57:13.514224 beat.go:339: CRIT Exiting: error loading config file: yaml: line 82: did not find expected key  
Exiting: error loading config file: yaml: line 82: did not find expected key

Please any help !!! i want to know if the configuration went well

---

<div class="post-metadata">

### Author: ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)
#### Post date: [July 17, 2017, 10:53pm UTC](https://discuss.elastic.co/t/could-not-test-configuration-of-filebeat/93159/2 "2017-07-17T22:53:25Z")

</div>

Looks like you have a syntax error on line 82. That is, no filebeat is not correctly configured and will refuse to start up.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 14, 2017, 10:53pm UTC](https://discuss.elastic.co/t/could-not-test-configuration-of-filebeat/93159/3 "2017-08-14T22:53:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
