# Could someone take a look at this old question

**URL:** <https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993>\
**Category:** Elasticsearch\
**Created:** [July 20, 2017, 5:35pm UTC](https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993 "2017-07-20T17:35:22Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![xwang12345](https://avatars.discourse-cdn.com/v4/letter/x/49beb7/32.png) [@xwang12345](https://discuss.elastic.co/u/xwang12345)\
**Post date:** [July 20, 2017, 5:35pm UTC](https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993/1 "2017-07-20T17:35:22Z")

</div>

> [@Painless scripting field question](https://discuss.elastic.co/t/painless-scripting-field-question/93667/3):
>
> The problem is that it failed in some shards, not all of the shards. So it works for this simple documents set does not mean it will work for large number of documents. I got the error from kibana side: Courier Fetch: 5 of 50 shards failed. The error is happening on the elasticsearch side in this file: ./core/src/main/java/org/elasticsearch/search/lookup/LeafDocLookup.java @Override public ScriptDocValues\<?\> get(Object key) { // assume its a string... String fieldNam…

It seems every day a Elasticsearch team member will go through new questions and try to answer them, but it seems to be lacking of follow up.

Could someone take a look at this old issue and hopefully help me understand a little bit more about Elasticsearch back end?

The simple example in the answer might work, but I am having issues with large number of documents, and this is an interesting problem

Thanks

---

<div class="post-metadata">

**Author:** ![rjernst](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rjernst/32/6363_2.png) [@rjernst](https://discuss.elastic.co/u/rjernst)\
**Post date:** [July 20, 2017, 7:01pm UTC](https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993/2 "2017-07-20T19:01:24Z")

</div>

@xwang12345 I responded on the other thread. Please do not create new threads in order to "bump" an existing thread. You have to give people time to respond. Your original thread had been responded to just a day earlier, and the entire thread is only 2 days old.

---

<div class="post-metadata">

**Author:** ![xwang12345](https://avatars.discourse-cdn.com/v4/letter/x/49beb7/32.png) [@xwang12345](https://discuss.elastic.co/u/xwang12345)\
**Post date:** [July 20, 2017, 9:40pm UTC](https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993/3 "2017-07-20T21:40:59Z")

</div>

Got it,  
Thanks

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 20, 2017, 10:17pm UTC](https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993/4 "2017-07-20T22:17:05Z")

</div>



---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 20, 2017, 10:17pm UTC](https://discuss.elastic.co/t/could-someone-take-a-look-at-this-old-question/93993/5 "2017-07-20T22:17:52Z")

</div>

> [@xwang12345](#):
>
> It seems every day a Elasticsearch team member will go through new questions and try to answer them, but it seems to be lacking of follow up.

If you'd like guaranteed responses from our engineers then you should have a look at [Subscriptions | Elastic Stack Products & Support | Elastic](https://www.elastic.co/subscriptions) and reach out to us for further discussions.

Otherwise please have patience.
