# Couldn't Activate Monitoring in 6.3

**URL:** <https://discuss.elastic.co/t/couldnt-activate-monitoring-in-6-3/136131>\
**Category:** Kibana\
**Created:** [June 15, 2018, 7:12pm UTC](https://discuss.elastic.co/t/couldnt-activate-monitoring-in-6-3/136131 "2018-06-15T19:12:51Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![michaelm14](https://avatars.discourse-cdn.com/v4/letter/m/13edae/32.png) [@michaelm14](https://discuss.elastic.co/u/michaelm14)\
**Post date:** [June 15, 2018, 7:12pm UTC](https://discuss.elastic.co/t/couldnt-activate-monitoring-in-6-3/136131/1 "2018-06-15T19:12:52Z")

</div>

Following a 6.1 to 6.3 upgrade, monitoring within Kibana now shows an error message:

"We couldn't activate monitoring"

I've added the following two lines to my Elasticsearch.yml:

xpack.monitoring.enabled: true  
xpack.monitoring.collection.enabled: true

The only error I'm seeing is in the kibana.stderr file and seems to indicate an index is read only?

Unhandled rejection [export\_exception] Exception when closing export bulk :: {"path":"/\_xpack/monitoring/\_bulk","query":{"system\_id":"kibana","system\_api\_version":"6","interval":"10000ms"},"body":"{"index":{"\_type":"kibana\_stats"}}\n{"concurrent\_connections":4,"os":{"load":{"1m":2.81982421875,"5m":3.24560546875,"15m":3.23291015625},"memory":{"total\_in\_bytes":16827301888,"free\_in\_bytes":309764096,"used\_in\_bytes":16517537792},"uptime\_in\_millis":221157000},"process":{"event\_loop\_delay":0.6243259906768799,"memory":{"heap":{"total\_in\_bytes":135954432,"used\_in\_bytes":121463192,"size\_limit":1501560832},"resident\_set\_size\_in\_bytes":199553024},"uptime\_in\_millis":6913806},"requests":{"disconnects":0,"total":1,"status\_codes":{"200":1}},"response\_times":{"average":59,"max":59},"timestamp":"2018-06-15T19:05:20.902Z","kibana":{"uuid":"f55b4301-cc59-4b64-b543-b766a36668c8","name":"redacted","index":".kibana","host":"redacted","transport\_address":"0.0.0.0:5601","version":"6.3.0","snapshot":false,"status":"green"},"usage":{"index":".kibana","dashboard":{"total":9},"visualization":{"total":83},"search":{"total":1},"index\_pattern":{"total":8},"graph\_workspace":{"total":0},"timelion\_sheet":{"total":0},"xpack":{"reporting":{"available":true,"enabled":true,"browser\_type":"phantom","\_all":0,"csv":{"available":true,"total":0},"printable\_pdf":{"available":true,"total":0,"app":{"visualization":0,"dashboard":0},"layout":{"print":0,"preserve\_layout":0}},"status":{},"lastDay":{"\_all":0,"csv":{"available":true,"total":0},"printable\_pdf":{"available":true,"total":0,"app":{"visualization":0,"dashboard":0},"layout":{"print":0,"preserve\_layout":0}},"status":{}},"last7Days":{"\_all":0,"csv":{"available":true,"total":0},"printable\_pdf":{"available":true,"total":0,"app":{"visualization":0,"dashboard":0},"layout":{"print":0,"preserve\_layout":0}},"status":{}}}}}}\n","statusCode":500,"response":"{"took":3,"ignored":false,"errors":true,"error":{"type":"export\_exception","reason":"Exception when closing export bulk","caused\_by":{"type":"export\_exception","reason":"failed to flush export bulks","caused\_by":{"type":"export\_exception","reason":"bulk [default\_local] reports failures when exporting documents","exceptions":[{"type":"export\_exception","reason":"ClusterBlockException[blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];]","caused\_by":{"type":"cluster\_block\_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"}}]}}}}"}

Has anyone else run into this issue?

---

<div class="post-metadata">

**Author:** ![michaelm14](https://avatars.discourse-cdn.com/v4/letter/m/13edae/32.png) [@michaelm14](https://discuss.elastic.co/u/michaelm14)\
**Post date:** [June 15, 2018, 7:27pm UTC](https://discuss.elastic.co/t/couldnt-activate-monitoring-in-6-3/136131/2 "2018-06-15T19:27:15Z")

</div>

OK, self healed it... But for anyone else searching this error, refer to this thread:

> [@FORBIDDEN/12/index read-only / allow delete (api)\]](https://discuss.elastic.co/t/forbidden-12-index-read-only-allow-delete-api/110282/4):
>
> I tried doing that with powershell WebRequest but it still gives me this error. I mean this very same command yields the error 'FORBIDDEN/12/index-read-only'

In short, due to some space issue, it appears the indices were put into read only mode. My Kibana index was set as such so this console command fixed it:

PUT your\_index\_name/\_settings  
{  
"index": {  
"blocks": {  
"read\_only\_allow\_delete": "false"  
}  
}  
}

Other indices may also be in that state so I'll check.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 13, 2018, 7:27pm UTC](https://discuss.elastic.co/t/couldnt-activate-monitoring-in-6-3/136131/3 "2018-07-13T19:27:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
