# Couldn't find any Elasticsearch data

**URL:** <https://discuss.elastic.co/t/couldnt-find-any-elasticsearch-data/296330>\
**Category:** Elasticsearch\
**Created:** [February 4, 2022, 4:42pm UTC](https://discuss.elastic.co/t/couldnt-find-any-elasticsearch-data/296330 "2022-02-04T16:42:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mikemiko](https://avatars.discourse-cdn.com/v4/letter/m/73ab20/32.png) [@mikemiko](https://discuss.elastic.co/u/mikemiko)\
**Post date:** [February 4, 2022, 4:42pm UTC](https://discuss.elastic.co/t/couldnt-find-any-elasticsearch-data/296330/1 "2022-02-04T16:42:14Z")

</div>

I deployed an EFK stack on a 3 Node Kubernetes cluster (kind cluster). The Cluster is also running a custom app that I intend to monitor through the stack. All Pods are running. I can access Kibana at: \<Any\_NodeIP\>\<Kibana\_Nodeport\> but I cannot access Elastic searach at port 9200. I am getting the following message "Couldn't find any Elasticsearch data" When I access Kibana.  
When I do: curl -X GET [http://localhost:9200](http://localhost:9200/), I get the following error:  
curl: (7) Failed to connect to localhost port 9200: Connection refused

Can anyone help me?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 6, 2022, 9:44pm UTC](https://discuss.elastic.co/t/couldnt-find-any-elasticsearch-data/296330/2 "2022-02-06T21:44:55Z")

</div>

Welcome to our community! 😃

What do the Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 6, 2022, 9:45pm UTC](https://discuss.elastic.co/t/couldnt-find-any-elasticsearch-data/296330/3 "2022-03-06T21:45:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
