# Courier Fetch : 5 of 15 shards failed. - Need Help Troubleshooting

**URL:** https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424
**Category:** Kibana
**Created:** [March 17, 2018, 11:45pm UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424 "2018-03-17T23:45:51Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![camay123](https://avatars.discourse-cdn.com/v4/letter/c/7cd45c/32.png) [@camay123](https://discuss.elastic.co/u/camay123)
#### Post date: [March 17, 2018, 11:45pm UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424/1 "2018-03-17T23:45:51Z")

</div>

Hi,

I got this warning that appears every few other times in Kibana:

Courier Fetch : 5 of 15 shards failed

In my elasticSearch log i get the following error message:

[2018-03-17T23:23:22,723][DEBUG][o.e.a.s.TransportSearchAction] [K-XtAVd] [emlheaders-fr][3], node[K-XtAVdWQIK3dacw4sh6Eg], [P], s[STARTED], a[id=9DIX0d1PRJG1\_jQtVvpAYg]: Failed to execute [SearchRequest{searchType=QUERY\_THEN\_FETCH, indices=[emlheaders-_], indicesOptions=IndicesOptions[id=39, ignore\_unavailable=true, allow\_no\_indices=true, expand\_wildcards\_open=true, expand\_wildcards\_closed=false, allow\_aliases\_to\_multiple\_indices=true, forbid\_closed\_indices=true, ignore\_aliases=false], types=[], routing='null', preference='1521328914878', requestCache=null, scroll=null, maxConcurrentShardRequests=5, batchedReduceSize=512, preFilterShardSize=64, source={"size":0,"query":{"bool":{"must":[{"match\_all":{"boost":1.0}},{"match\_all":{"boost":1.0}},{"range":{"timestamp":{"from":1518740601129,"to":1521329001130,"include\_lower":true,"include\_upper":true,"format":"epoch\_millis","boost":1.0}}}],"adjust\_pure\_negative":true,"boost":1.0}},"version":true,"\_source":{"includes":[],"excludes":[]},"stored\_fields":"_","docvalue\_fields":["timestamp"],"script\_fields":{},"aggregations":{"filter\_agg":{"filter":{"geo\_bounding\_box":{"bodyurls.geo.geo":{"top\_left":[-180.0,90.0],"bottom\_right":[180.0,-90.0]},"validation\_method":"STRICT","type":"MEMORY","ignore\_unmapped":false,"boost":1.0}},"aggregations":{"2":{"geohash\_grid":{"field":"bodyurls.geo.geo","precision":2,"size":10000},"aggregations":{"3":{"geo\_centroid":{"field":"bodyurls.geo.geo"}}}}}}},"highlight":{"pre\_tags":["@kibana-highlighted-field@"],"post\_tags":["@/kibana-highlighted-field@"],"fragment\_size":2147483647,"fields":{"\*":{}}}}}]  
org.elasticsearch.transport.RemoteTransportException: [K-XtAVd][x.x.x.x:9300][indices:data/read/search[phase/query]]  
Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [bodyurls.geo.geo] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

I just dont know where to go from here. Last suggestion seems to set fielddata=true on [bodyurls.geo.geo], but how, and does it matter that it is a geo point.

Thanks

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 18, 2018, 12:00am UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424/2 "2018-03-18T00:00:34Z")

</div>

What sort of visualisation are you building on the `bodyurls.geo.geo` field and what is the mapping of it?

---

<div class="post-metadata">

### Author: ![camay123](https://avatars.discourse-cdn.com/v4/letter/c/7cd45c/32.png) [@camay123](https://discuss.elastic.co/u/camay123)
#### Post date: [March 18, 2018, 12:13am UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424/3 "2018-03-18T00:13:28Z")

</div>

I am doing a world map and the type of the field is : geo\_point

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 18, 2018, 12:32am UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424/4 "2018-03-18T00:32:47Z")

</div>

Can you show us the `_mapping` endpoint for that index?

---

<div class="post-metadata">

### Author: ![camay123](https://avatars.discourse-cdn.com/v4/letter/c/7cd45c/32.png) [@camay123](https://discuss.elastic.co/u/camay123)
#### Post date: [March 18, 2018, 1:05am UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424/5 "2018-03-18T01:05:44Z")

</div>

While looking at the \_mapping for index-\* I noticed that:

index-au had a text field for bodyurls.geo.geo but index-fr had a geo\_point as a type, as well as index-\* had geo\_point specified. seems ok now.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 15, 2018, 1:05am UTC](https://discuss.elastic.co/t/courier-fetch-5-of-15-shards-failed-need-help-troubleshooting/124424/6 "2018-04-15T01:05:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
