# Courier fetch failed to fetch 34 shards

**URL:** https://discuss.elastic.co/t/courier-fetch-failed-to-fetch-34-shards/140324
**Category:** Elasticsearch
**Created:** [July 17, 2018, 12:01pm UTC](https://discuss.elastic.co/t/courier-fetch-failed-to-fetch-34-shards/140324 "2018-07-17T12:01:57Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![victor.nilsson](https://avatars.discourse-cdn.com/v4/letter/v/eb8c5e/32.png) [@victor.nilsson](https://discuss.elastic.co/u/victor.nilsson)
#### Post date: [July 17, 2018, 12:01pm UTC](https://discuss.elastic.co/t/courier-fetch-failed-to-fetch-34-shards/140324/1 "2018-07-17T12:01:57Z")

</div>

Hi

I was trying to create a visulization with a coordinate map using the geoip.location tag but immediately gets an error in Kibana where it says "Courier fetch: 34 of 54 shards failed." I tried to increase the "thread\_pool.search.queue\_size" to 10000 on all elastic nodes but that had no effect so that was probably not my issue.

When i look in the elasticlogs i get the following:

> org.elasticsearch.transport.RemoteTransportException: [sealikreela03-masterdata][10.229.1.13:9300][indices:data/read/search[phase/query]]  
> Caused by: org.elasticsearch.index.query.QueryShardException: failed to find geo\_point field [geoip.location]

But in my index template i have enabled support for geotagging:

GET \_template/logstash-\*

> "mappings": {  
> "doc": {  
> "properties": {  
> "geoip": {  
> "dynamic": true,  
> "properties": {  
> "ip": {  
> "type": "ip"  
> },  
> "location": {  
> "type": "geo\_point"  
> },  
> "latitude": {  
> "type": "float"  
> },  
> "longitude": {  
> "type": "float"  
> }  
> }  
> }  
> }  
> }  
> }

What could be the issue here? Did i do something wrong when implementing geotagging?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 14, 2018, 12:02pm UTC](https://discuss.elastic.co/t/courier-fetch-failed-to-fetch-34-shards/140324/2 "2018-08-14T12:02:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
