# Crashing Logstash S3 output - NotImplementedError fstat error at startup in 5.2+ on Alpine

**URL:** <https://discuss.elastic.co/t/crashing-logstash-s3-output-notimplementederror-fstat-error-at-startup-in-5-2-on-alpine/90338>\
**Category:** Logstash\
**Created:** [June 21, 2017, 5:48pm UTC](https://discuss.elastic.co/t/crashing-logstash-s3-output-notimplementederror-fstat-error-at-startup-in-5-2-on-alpine/90338 "2017-06-21T17:48:05Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![timecode](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timecode/32/19318_2.png) [@timecode](https://discuss.elastic.co/u/timecode)\
**Post date:** [June 21, 2017, 5:48pm UTC](https://discuss.elastic.co/t/crashing-logstash-s3-output-notimplementederror-fstat-error-at-startup-in-5-2-on-alpine/90338/1 "2017-06-21T17:48:05Z")

</div>

OS: Alpine 3.6  
Logstash 5.2+  
Plugin: logstash-output-s3  
Java: OpenJDK-1.8.0.131-b11

Prior to Logstash 5.2, `context.http_request.body` (as seen in `/usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_expect_100_continue.rb`) returned a STRINGIO object and .size, which is called on this object, works OK.

However, from 5.2 onwards `context.http_request.body` is a File and .size is throwing an error.

```auto
NotImplementedError: fstat unimplemented unsupported or native support failed to load
...
size at org/jruby/RubyFile.java:1148
call at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-core/plugins/s3_expect_100_continue.rb:15

```

Only seems to error in Alpine as I've tried it in Ubuntu and all seems OK.

Are additional components required for the Alpine install in order to use 5.2 onwards?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 19, 2017, 5:48pm UTC](https://discuss.elastic.co/t/crashing-logstash-s3-output-notimplementederror-fstat-error-at-startup-in-5-2-on-alpine/90338/2 "2017-07-19T17:48:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
