# Cross-cluster search fails with skip\_unavailable option

**URL:** <https://discuss.elastic.co/t/cross-cluster-search-fails-with-skip-unavailable-option/195863>\
**Category:** Elasticsearch\
**Tags:** ccs-cross-cluster-search\
**Created:** [August 20, 2019, 8:25am UTC](https://discuss.elastic.co/t/cross-cluster-search-fails-with-skip-unavailable-option/195863 "2019-08-20T08:25:51Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![prizov](https://avatars.discourse-cdn.com/v4/letter/p/958977/32.png) [@prizov](https://discuss.elastic.co/u/prizov)\
**Post date:** [August 20, 2019, 8:25am UTC](https://discuss.elastic.co/t/cross-cluster-search-fails-with-skip-unavailable-option/195863/1 "2019-08-20T08:25:51Z")

</div>

Hi everyone!

I have two remote clusters with skip\_unavailable option. Cross-cluster search works fine.  
But in case one of cluster is network unreachable I receive search timeout and don't get any response even from one cluster

Could you please explain why I faced with this problem?

Remote cluster configuration looks like this:

```auto
{
  "cluster1": {
    "seeds": [
      "cluster1-client-host1:9300",
      "cluster1-client-host2:9300"
    ],
    "http_addresses": [
      "10.200.100.2:9200",
      "10.200.100.3:9200",
      "10.200.100.4:9200"
    ],
    "connected": true,
    "num_nodes_connected": 3,
    "max_connections_per_cluster": 3,
    "initial_connect_timeout": "30s",
    "skip_unavailable": true
  },
  "cluster2": {
    "seeds": [
      "cluster2-client-host1:9300",
      "cluster2-client-host2:9300"
    ],
    "http_addresses": [
      "10.200.101.2:9200",
      "10.200.101.3:9200",
      "10.200.101.4:9200"
    ],
    "connected": true,
    "num_nodes_connected": 3,
    "max_connections_per_cluster": 3,
    "initial_connect_timeout": "30s",
    "skip_unavailable": true
  }
}

```

Thanks!

---

<div class="post-metadata">

**Author:** ![javanna](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/javanna/32/4698_2.png) [@javanna](https://discuss.elastic.co/u/javanna)\
**Post date:** [August 23, 2019, 2:35pm UTC](https://discuss.elastic.co/t/cross-cluster-search-fails-with-skip-unavailable-option/195863/2 "2019-08-23T14:35:49Z")

</div>

You seem to be setting `skip_unavailable` correctly, could you please the output of the \_remote/info API? Also, do you configure CCS via config file or via API? And could you please post the exception that you get back?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 20, 2019, 2:35pm UTC](https://discuss.elastic.co/t/cross-cluster-search-fails-with-skip-unavailable-option/195863/3 "2019-09-20T14:35:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
