# Cross cluster Search

**URL:** https://discuss.elastic.co/t/cross-cluster-search/270882
**Category:** Elasticsearch
**Tags:** ccr-cross-cluster-replication
**Created:** [April 21, 2021, 5:23pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882 "2021-04-21T17:23:58Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![kvmuralidhar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvmuralidhar/32/45160_2.png) [@kvmuralidhar](https://discuss.elastic.co/u/kvmuralidhar)
#### Post date: [April 21, 2021, 5:23pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882/1 "2021-04-21T17:23:58Z")

</div>

Hi.

Has anyone implemented CCS between Elastic running on GCP or AWS and on on-prem hardware ?

I am getting a connection refused error message when I try to add a remote cluster running on GCP or AWS.

Thanks  
Murali

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [April 21, 2021, 11:14pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882/2 "2021-04-21T23:14:57Z")

</div>

What is the error?  
What does your config look like?  
What version(s) are you running?

---

<div class="post-metadata">

### Author: ![kvmuralidhar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvmuralidhar/32/45160_2.png) [@kvmuralidhar](https://discuss.elastic.co/u/kvmuralidhar)
#### Post date: [April 22, 2021, 12:53pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882/3 "2021-04-22T12:53:11Z")

</div>

Hi Mark,

I am running version 7.12 of ElasticStack in AWS as well as on my machine. Configured both installations as follows:

- Enabled security for xpack, http.security, transport.security
- Generated keys, certs

When I try to add the remote cluster in Kibana, I do not see any activity on the remote cluster elastic logs but the local cluster on my workstation shows this error.

```auto
[2021-04-22T08:38:34,838][WARN][o.e.t.SniffConnectionStrategy] [node2] fetching nodes from external cluster [myremotecluster] failed org.elasticsearch.transport.ConnectTransportException: [][remoteip:9243] handshake_timeout[30s]

```

On AWS, I have allowed inbound communication on ports between 9200-9400 from any ip.

Thanks  
Murali

---

<div class="post-metadata">

### Author: ![kvmuralidhar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvmuralidhar/32/45160_2.png) [@kvmuralidhar](https://discuss.elastic.co/u/kvmuralidhar)
#### Post date: [April 22, 2021, 8:31pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882/4 "2021-04-22T20:31:32Z")

</div>

Hi Mark,

I am trying the same setup with Elastic Cloud running on GCP and my workstation.  
a) Created a deployment  
b) Exported the certificates of the deployment (server, intermediate and root) and added them to a cabundle.pem file  
c) Updated the local elasticsearch config to use the cabundle.pem file  
d) Tried to add the elasticsearch URL as a remote cluster and got the following error.

```auto
[2021-04-22T16:19:36,945][WARN][o.e.t.SniffConnectionStrategy] [node2] fetching nodes from external cluster [test] failed
org.elasticsearch.transport.ConnectTransportException: [][35.193.143.25:9343] general node connection failure
        at org.elasticsearch.transport.TcpTransport$ChannelsConnectedListener.lambda$onResponse$2(TcpTransport.java:958) ~[elasticsearch-7.12.0.jar:7.12.0]

Caused by: java.lang.IllegalStateException: handshake failed
        ... 40 more
Caused by: org.elasticsearch.transport.RemoteTransportException: [Failed to deserialize exception response from stream for handler [org.elasticsearch.transport.TransportHandshaker$HandshakeResponseHandler@7d334b6f]]

```

Any help would be very much appreciated.

Thanks  
Murali

---

<div class="post-metadata">

### Author: ![kvmuralidhar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvmuralidhar/32/45160_2.png) [@kvmuralidhar](https://discuss.elastic.co/u/kvmuralidhar)
#### Post date: [April 29, 2021, 4:40pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882/5 "2021-04-29T16:40:44Z")

</div>

For CCS setup between AWS and local elastic instance, we need to use the proxy mode instead of the default sniff mode.

This helped with a successful remote cluster configuration :-).

Thanks  
Murali

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 27, 2021, 4:41pm UTC](https://discuss.elastic.co/t/cross-cluster-search/270882/6 "2021-05-27T16:41:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
