# Curator 5.4 SSL module is not available

**URL:** https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009
**Category:** Elasticsearch
**Created:** [November 16, 2017, 7:53pm UTC](https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009 "2017-11-16T19:53:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![nradonicich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nradonicich/32/22843_2.png) [@nradonicich](https://discuss.elastic.co/u/nradonicich)
#### Post date: [November 16, 2017, 7:53pm UTC](https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009/1 "2017-11-16T19:53:25Z")

</div>

Hello, Installed curator 5.4 to manage a new ES6 instance (was RC1 now GA). When running curator against ES6 with X-Pack security (SSL enabled) an error is received from urllib3 seen from below debug log. This is on a RHEL73 system, curator installed from RPM which from what I understand should include all the needed modules, etc. Suggestions on correcting this?

**Debug Log**

```nohighlight
2017-11-16 14:44:30,491 DEBUG urllib3.connectionpool _new_conn:824 Starting new HTTPS connection (4): 127.0.0.1
2017-11-16 14:44:30,491 WARNING elasticsearch log_request_fail:97 GET https://127.0.0.1:9200/ [status:N/A request:0.000s]
Traceback (most recent call last):
  File "/home/buh/.local/lib/python3.6/site-packages/elasticsearch/connection/http_urllib3.py", line 114, in perform_request
  File "/home/buh/.local/lib/python3.6/site-packages/urllib3/connectionpool.py", line 639, in urlopen
  File "/home/buh/.local/lib/python3.6/site-packages/urllib3/util/retry.py", line 333, in increment
  File "/home/buh/.local/lib/python3.6/site-packages/urllib3/packages/six.py", line 686, in reraise
  File "/home/buh/.local/lib/python3.6/site-packages/urllib3/connectionpool.py", line 589, in urlopen
  File "/home/buh/.local/lib/python3.6/site-packages/urllib3/connectionpool.py", line 251, in _get_conn
  File "/home/buh/.local/lib/python3.6/site-packages/urllib3/connectionpool.py", line 827, in _new_conn
urllib3.exceptions.SSLError: Can't connect to HTTPS URL because the SSL module is not available.
2017-11-16 14:44:30,492 DEBUG elasticsearch log_request_fail:105 > None
Unable to create client connection to Elasticsearch. Error: ConnectionError(Can't connect to HTTPS URL because the SSL module is not available.) caused by: SSLError(Can't connect to HTTPS URL because the SSL module is not available.)

```

**curator.yml**

```auto
---
# Remember, leave a key empty if there is no value. None will be a string,
# not a Python "NoneType"
client:
  hosts:
    - 127.0.0.1
  port: 9200
  url_prefix:
  use_ssl: True
  certificate:
  client_cert:
  client_key:
  ssl_no_validate: True
  http_auth: curator:password
  timeout: 30
  master_only: False

logging:
  loglevel: DEBUG
  logfile:
  logformat: default
  blacklist: []
#['elasticsearch', 'urllib3']

```

**elasticsearch.yml** (truncated)

```auto
xpack:
  security:
    transport:
      ssl:
        enabled: true
    http:
      ssl:
        enabled: true

```

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [November 16, 2017, 8:30pm UTC](https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009/2 "2017-11-16T20:30:53Z")

</div>

Thanks for reporting this. I will try to duplicate it.

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [November 16, 2017, 9:22pm UTC](https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009/4 "2017-11-16T21:22:45Z")

</div>

**More research has revealed that this is limited to RHEL/CentOS 7.** The Curator packages for CentOS 6, Ubuntu 1404/1604 Debian 8, and Debian 9 all work as expected.

**Update:** This is due to an OpenSSL library version mismatch. The fix for this is `yum update openssl-libs`. The expected version should be `1.0.2k-8.el7`:

```auto
# yum list installed | grep ssl
openssl-libs.x86_64 1:1.0.2k-8.el7 @base

```

I'm not sure what changed with OpenSSL recently, but updating it on CentOS 7 seems to have fixed it.

---

<div class="post-metadata">

### Author: ![nradonicich](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nradonicich/32/22843_2.png) [@nradonicich](https://discuss.elastic.co/u/nradonicich)
#### Post date: [November 17, 2017, 4:07am UTC](https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009/5 "2017-11-17T04:07:57Z")

</div>

This worked, updating from 1.0.1e-60 to 1.0.2k-8 solved it.

Thanks!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 15, 2017, 4:07am UTC](https://discuss.elastic.co/t/curator-5-4-ssl-module-is-not-available/108009/6 "2017-12-15T04:07:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
