# Curator error - unable to delete old indices

**URL:** https://discuss.elastic.co/t/curator-error-unable-to-delete-old-indices/120529
**Category:** Elasticsearch
**Created:** [February 19, 2018, 9:46pm UTC](https://discuss.elastic.co/t/curator-error-unable-to-delete-old-indices/120529 "2018-02-19T21:46:06Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![shri](https://avatars.discourse-cdn.com/v4/letter/s/e19adc/32.png) [@shri](https://discuss.elastic.co/u/shri)
#### Post date: [February 19, 2018, 9:46pm UTC](https://discuss.elastic.co/t/curator-error-unable-to-delete-old-indices/120529/1 "2018-02-19T21:46:06Z")

</div>

Hi, I'm seeing this error Skipping action "delete\_indices" due to empty list: \<class 'curator.exceptions.NoIndices'\> when i'm trying to delete my older indices. Any help on this please?

**Error** :

2018-02-19 21:34:40,977 INFO Preparing Action ID: 1, "delete\_indices"  
2018-02-19 21:34:40,997 INFO Trying Action ID: 1, "delete\_indices": Delete indices older than 30 days (based on index name), for tomcat- prefixed indices. Ignore the error if the filter does not result in an actionable list of indices (ignore\_empty\_list) and exit cleanly.  
2018-02-19 21:34:41,138 INFO Skipping action "delete\_indices" due to empty list: \<class 'curator.exceptions.NoIndices'\>  
2018-02-19 21:34:41,138 INFO Action ID: 1, "delete\_indices" completed.  
2018-02-19 21:34:41,138 INFO Job completed.

**My action file:**  
actions:  
1:  
action: delete\_indices  
description: \>-  
Delete indices older than 30 days (based on index name), for tomcat-  
prefixed indices. Ignore the error if the filter does not result in an  
actionable list of indices (ignore\_empty\_list) and exit cleanly.  
options:  
ignore\_empty\_list: True  
timeout\_override:  
continue\_if\_exception: False  
disable\_action: False  
filters:  
- filtertype: pattern  
kind: prefix  
value: logstash-  
exclude:  
- filtertype: age  
source: name  
direction: older  
timestring: '%Y.%m.%d'  
unit: days  
unit\_count: 1  
exclude: True

**My conf.yml**

client:  
hosts:  
- ${ELK\_HOST}  
port: 9200  
url\_prefix:  
use\_ssl: False  
certificate:  
client\_cert:  
client\_key:  
ssl\_no\_validate: False  
http\_auth:  
timeout: 30  
master\_only: False  
logging:  
loglevel: INFO  
logfile:  
logformat: default  
blacklist: ['elasticsearch', 'urllib3']

**Health**

curl -XGET 'localhost:9200/\_cat/indices?v&pretty'

health status index uuid pri rep docs.count docs.deleted store.size pri.store.size  
yellow open %{[@metadata][beat]}-2018.02.18 PeSOsUCvRTa6aDBYDFst4w 5 1 84197438 0 17.1gb 17.1gb  
yellow open %{[@metadata][beat]}-2018.02.19 eXQfY8aQRfGh01vQlJO\_\_A 5 1 84085685 0 18.1gb 18.1gb  
yellow open %{[@metadata][beat]}-2018.02.15 Nndz-sf5Se-LKf1eEMeulw 5 1 3526483 0 762.5mb 762.5mb  
yellow open filebeat-2018.02.19 D9CQpuwmS5Oy-GMjPEiv0Q 5 1 29724 0 16.3mb 16.3mb  
yellow open %{[@metadata][beat]}-2018.02.17 zM-oHPOnQNStQr4COKrlTQ 5 1 83745809 0 17gb 17gb  
yellow open filebeat-2018.02.17 QYS6-c4gRn-3v0EwANJQeQ 5 1 10806 0 5.3mb 5.3mb  
yellow open .kibana pDF05V1SSZKkDDjLK4f4jA 1 1 2 1 16.2kb 16.2kb  
yellow open %{[@metadata][beat]}-2018.02.16 e6SVnfZUQ72C0ezsLkxAug 5 1 92605053 0 19.5gb 19.5gb  
yellow open filebeat-2018.02.18 dqyPEF7rSWu5mkDfKYAgzQ 5 1 6353 0 3.3mb 3.3mb  
yellow open filebeat-2018.02.16 cQ44duGCQG6KVxFi7qe05A 5 1 68558 0 24.3mb 24.3mb  
yellow open filebeat-2018.02.15 TDwA\_QBZTYOeoCD8vyojMQ 5 1 1034 0 902.1kb 902.1kb

I'm failing to delete the older index. Can i know where i'm doing mistake and any ideas please?

Thanks  
shri

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 20, 2018, 5:28pm UTC](https://discuss.elastic.co/t/curator-error-unable-to-delete-old-indices/120529/3 "2018-03-20T17:28:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
