# Curator image not working with centos 8 base image

**URL:** https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970
**Category:** Elasticsearch
**Created:** [February 19, 2020, 1:21pm UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970 "2020-02-19T13:21:12Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)
#### Post date: [February 19, 2020, 1:21pm UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/1 "2020-02-19T13:21:12Z")

</div>

Hi,  
I am trying to build curator image with centos 8 base image. Image is getting built but it is throwing below error while running:

`Traceback (most recent call last): File "/home/buh/.local/lib/python3.6/site-packages/cx_Freeze/initscripts/ __startup__.py", line 14, in run File "/home/buh/.local/lib/python3.6/site-packages/cx_Freeze/initscripts/Console.py", line 26, in run File "run_curator.py", line 23, in <module> File "/home/buh/curator/curator/ __init__.py", line 6, in <module> File "/home/buh/curator/curator/utils.py", line 1, in <module> File "/home/buh/.local/lib/python3.6/site-packages/elasticsearch/ __init__.py", line 24, in <module> File "/home/buh/.local/lib/python3.6/site-packages/elasticsearch/client/ __init__.py", line 4, in <module> File "/home/buh/.local/lib/python3.6/site-packages/elasticsearch/transport.py", line 4, in <module> File "/home/buh/.local/lib/python3.6/site-packages/elasticsearch/connection/ __init__.py", line 3, in <module> File "/home/buh/.local/lib/python3.6/site-packages/elasticsearch/connection/http_urllib3.py", line 2, in <module> File "/usr/local/lib/python3.6/ssl.py", line 101, in <module> ImportError: libssl.so.10: cannot open shared object file: No such file or directory`

Curator version: 5.7.6-1  
Base image: centos 8

Kindly help me resolve this.

Best Regards,  
Akshat Sharma

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [February 19, 2020, 1:43pm UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/2 "2020-02-19T13:43:25Z")

</div>

Try the 5.8.1 RPM instead?

---

<div class="post-metadata">

### Author: ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)
#### Post date: [February 20, 2020, 7:24am UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/3 "2020-02-20T07:24:41Z")

</div>

@theuntergeek Thank you for responding!  
As you suggested, I tried building curator image with 5.8.1 RPM. Again, I am able to build the image but while running I am getting following error:

`Fatal Python error: initfsencoding: unable to load the file system codec Traceback (most recent call last): File "/opt/python/3.7.4/lib/python3.7/encodings/ __init__.py", line 31, in <module> zipimport.ZipImportError: can't decompress data; zlib not available`

I suspected that zlib package might not be available and installed zlib while building the image, but still facing the same issue.

Any idea how we can handle this?

Best Regards,  
Akshat

---

<div class="post-metadata">

### Author: ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)
#### Post date: [February 20, 2020, 7:33am UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/4 "2020-02-20T07:33:28Z")

</div>

I found [this](https://discuss.elastic.co/t/curator-python-related-error/206446/2) link that says we should use `/usr/bin/curator` or `/usr/bin/curator_cli` as we upgrade to 5.8.1 RPM. Does this mean we need to change entrypoint or something?  
I am a bit confused here, could you please tell me what changes will we have to make in Dockerfile with respect to [this](https://discuss.elastic.co/t/curator-python-related-error/206446/2) ?

Best Regards,  
Akshat

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [February 20, 2020, 7:36am UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/5 "2020-02-20T07:36:00Z")

</div>

Yes, if you're using Docker then your entry point to execute should either be `/usr/bin/curator` or `/usr/bin/curator_cli`, as they are actually wrapper scripts that set the LD\_LIBRARY\_PATH. Without this being set, you will get library not available messages (like the one for zlib).

---

<div class="post-metadata">

### Author: ![akshatsharma](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshatsharma/32/84179_2.png) [@akshatsharma](https://discuss.elastic.co/u/akshatsharma)
#### Post date: [February 24, 2020, 5:27am UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/6 "2020-02-24T05:27:35Z")

</div>

@theuntergeek  
Got it working by changing the entrypoint, thanks a lot!

Best Regards,  
Akshat

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 23, 2020, 5:27am UTC](https://discuss.elastic.co/t/curator-image-not-working-with-centos-8-base-image/219970/7 "2020-03-23T05:27:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
