# Curator issue - No actionable item

**URL:** https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234
**Category:** Elasticsearch
**Created:** [August 16, 2017, 10:38am UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234 "2017-08-16T10:38:39Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![xon](https://avatars.discourse-cdn.com/v4/letter/x/838e76/32.png) [@xon](https://discuss.elastic.co/u/xon)
#### Post date: [August 16, 2017, 10:38am UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/1 "2017-08-16T10:38:39Z")

</div>

Hi All,

I am running ES 5.x.x and I am having the following action file

actions:  
1:  
action: snapshot  
description: \>-  
Snapshot logstash- prefixed indices older than 100 day (based on index  
creation\_date) with the default snapshot name pattern of  
'curator-%Y%m%d%H%M%S'. Wait for the snapshot to complete. Do not skip  
the repository filesystem access check. Use the other options to create  
the snapshot.  
options:  
repository: databackuptest1  
name:  
ignore\_unavailable: False  
include\_global\_state: True  
partial: False  
wait\_for\_completion: True  
skip\_repo\_fs\_check: False  
disable\_action: false  
filters:  
- filtertype: pattern  
kind: prefix  
value: logstash-test-  
- filtertype: age  
source: creation\_date  
direction: older  
timestring: '%Y-%m-%d'  
unit: days  
unit\_count: 100

When I run

./curator --config curator.yml action.yaml

I see curator going over the indices and everything looks 'okish' however at the end it quits with..

Unable to complete action "snapshot". No actionable items in list: \<class 'curator.exceptions.NoIndices'\>

Snippet from the DEBUG below:

2017-08-11 13:51:10,727 DEBUG curator.indexlist filter\_by\_regex:384 Filter by regex: Index: logstash-test-2017.04.05  
2017-08-11 13:51:10,727 DEBUG curator.indexlist \_\_actionable:35 Index logstash-test-2017.04.05 is actionable and remains in the list.  
2017-08-11 13:51:10,727 DEBUG curator.indexlist filter\_by\_regex:384 Filter by regex: Index: logstash-test-2017.01.24  
2017-08-11 13:51:10,727 DEBUG curator.indexlist \_\_actionable:35 Index logstash-test-2017.01.24 is actionable and remains in the list.  
2017-08-11 13:51:10,727 DEBUG curator.indexlist filter\_by\_regex:384 Filter by regex: Index: logstash-number1-2017.06.07  
2017-08-11 13:51:10,727 DEBUG curator.indexlist \_\_not\_actionable:39 Index logstash-number1-2017.06.07 is not actionable, removing from list.  
2017-08-11 13:51:10,727 DEBUG curator.indexlist filter\_by\_regex:384 Filter by regex: Index: logstash-number1-2017.01.07  
2017-08-11 13:51:10,727 DEBUG curator.indexlist \_\_not\_actionable:39 Index logstash-number1-2017.01.07 is not actionable, removing from list.

My goal is to backup my indices and then delete them. Any help would be much appreciated!

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [August 16, 2017, 3:31pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/2 "2017-08-16T15:31:42Z")

</div>

You're only providing the debug snippet from the pattern filter output. Clearly there are actionable indices there.

If I had to guess, though, I'd say that what's happening is that you have indices with index name dates over 100 days in the past, but they were created less than 100 days ago, so the `creation_date` condition is not being met, which results in the NoIndices exception.

Since you already have a timestring in there, change `source: creation_date` to `source: name` and see if you get the same output.

---

<div class="post-metadata">

### Author: ![xon](https://avatars.discourse-cdn.com/v4/letter/x/838e76/32.png) [@xon](https://discuss.elastic.co/u/xon)
#### Post date: [August 16, 2017, 3:40pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/3 "2017-08-16T15:40:36Z")

</div>

Thanks for your answer @theuntergeek I tried that and didnt change anything - exactly the same result.

Also to your point it shouldnt be the case - there should be indices there of more than 100 days but werent re-indexed or something like that. THese were always there...

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [August 16, 2017, 3:59pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/4 "2017-08-16T15:59:37Z")

</div>

To know any more, then, I'll need the full debug log. You probably can't attach it here, so you should put it here as a link to a zip file or something.

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [August 16, 2017, 4:10pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/5 "2017-08-16T16:10:29Z")

</div>

Even a gist of the last few hundred lines before it exits will be helpful.

---

<div class="post-metadata">

### Author: ![xon](https://avatars.discourse-cdn.com/v4/letter/x/838e76/32.png) [@xon](https://discuss.elastic.co/u/xon)
#### Post date: [August 17, 2017, 9:39am UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/6 "2017-08-17T09:39:45Z")

</div>

It turned out to be a repository issue - I had to create it. However now I am getting the following error message...

2017-08-12 12:53:34,269 ERROR curator.cli cli:193 Failed to complete action: snapshot. \<class 'curator.exceptions.ActionError'\>: Failed to verify all nodes have repository access: --- Got a 500 response from Elasticsearch. Error message: repository\_verification\_exception

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [August 17, 2017, 3:54pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/7 "2017-08-17T15:54:24Z")

</div>

That error suggests that not all of your data and master nodes can both read and write to the shared filesystem. For a repository to work, each master and data node has to be able to read and write to that shared filesystem. For an NFS mount (fs type repository), that requires that each master and data node have that filesystem mounted in the exact same path, with read/write permissions, and also that `path.repo` has been added to the elasticsearch.yml file with that path.

---

<div class="post-metadata">

### Author: ![xon](https://avatars.discourse-cdn.com/v4/letter/x/838e76/32.png) [@xon](https://discuss.elastic.co/u/xon)
#### Post date: [August 17, 2017, 4:10pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/8 "2017-08-17T16:10:08Z")

</div>

> [@xon](#):
>
> Got a 500 response from Elasticsearch. Error message: repository\_verification\_exception

Thanks that was indeed the case 🙂 All sorted now!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 14, 2017, 4:10pm UTC](https://discuss.elastic.co/t/curator-issue-no-actionable-item/97234/9 "2017-09-14T16:10:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
