# Curator no longer working. I think it's related to a failed ILM setup

**URL:** <https://discuss.elastic.co/t/curator-no-longer-working-i-think-its-related-to-a-failed-ilm-setup/194489>\
**Category:** Elasticsearch\
**Created:** [August 8, 2019, 6:20pm UTC](https://discuss.elastic.co/t/curator-no-longer-working-i-think-its-related-to-a-failed-ilm-setup/194489 "2019-08-08T18:20:24Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dfinn](https://avatars.discourse-cdn.com/v4/letter/d/8c91f0/32.png) [@dfinn](https://discuss.elastic.co/u/dfinn)\
**Post date:** [August 8, 2019, 6:20pm UTC](https://discuss.elastic.co/t/curator-no-longer-working-i-think-its-related-to-a-failed-ilm-setup/194489/1 "2019-08-08T18:20:25Z")

</div>

A little while back I tried to setup ILM. It didn't go so well, I asked for help here but was unable to get it working:

> [@Getting errors related to ILM](https://discuss.elastic.co/t/getting-errors-related-to-ilm/182256):
>
> currently running ES 6.7.1 and we use the logstash-\* indexes I recently setup ILM through the UI, using these settings: { "policy": { "phases": { "hot": { "min\_age": "0ms", "actions": { "rollover": { "max\_age": "15d", "max\_size": "50gb" }, "set\_priority": { "priority": 100 } } }, "delete": { "min\_age": "1d", "actions": { "delete": {} } } } } } And I noticed in our elasticsearch logs we got the following error: [2019-05-22T00:16:46,994][ERROR][o.e.x.i.IndexLifecycleR…

So it's kind of half setup but still giving errors about rolling indexes over.

I've kind of left it as it is for now but I noticed today that curator does not seem to be working any more. Now when I run curator it reports an empty list of indexes, no matter what I set unit\_count to. Here's my simple curator config:

> actions:  
> 1:  
> action: delete\_indices  
> description: \>-  
> Delete indices older than 15 days (based on index name), for logstash-  
> prefixed indices. Ignore the error if the filter does not result in an  
> actionable list of indices (ignore\_empty\_list) and exit cleanly.  
> options:  
> ignore\_empty\_list: True  
> timeout\_override:  
> continue\_if\_exception: False  
> disable\_action: False  
> filters:  
> - filtertype: pattern  
> kind: prefix  
> value: logstash-  
> exclude:  
> - filtertype: age  
> source: name  
> direction: older  
> timestring: '%Y.%m.%d'  
> unit: days  
> unit\_count: 5  
> exclude:

And the output that I'm getting from curator:

> 2019-08-08 18:18:04,202 INFO Preparing Action ID: 1, "delete\_indices"  
> 2019-08-08 18:18:04,212 INFO Trying Action ID: 1, "delete\_indices": Delete indices older than 15 days (based on index name), for logstash- prefixed indices. Ignore the error if the filter does not result in an actionable list of indices (ignore\_empty\_list) and exit cleanly.  
> 2019-08-08 18:18:04,301 INFO Skipping action "delete\_indices" due to empty list: \<class 'curator.exceptions.NoIndices'\>  
> 2019-08-08 18:18:04,301 INFO Action ID: 1, "delete\_indices" completed.  
> 2019-08-08 18:18:04,301 INFO Job completed.

Here's my list of indexes currently:

> root@ps-dev-elk:~# curl -X GET "localhost:9200/_cat/indices?v&pretty"  
> health status index uuid pri rep docs.count docs.deleted store.size pri.store.size  
> yellow open logstash-000002 KmIUUStBTkSe3NXcUy-vhQ 5 1 0 0 1.2kb 1.2kb  
> yellow open logstash-2019.07.03 lhehP\_liSbGO5mNd8iQ6ug 5 1 34648 0 24.1mb 24.1mb  
> yellow open logstash-2019.06.29 9AczdsFTQk65CGyXdU6a2g 5 1 11873 0 11.9mb 11.9mb  
> yellow open logstash-2019.07.12 mSnVXCjLRIySS\_9cG6qpXA 5 1 1218159 0 328.4mb 328.4mb  
> yellow open logstash-2019.07.31 LNfFP57BTd28bzW57C1f4w 5 1 11312682 0 4.6gb 4.6gb  
> yellow open logstash-2019.07.27 ZvZcNrT6Tq2DDjGw1I5n1w 5 1 9846601 0 3.3gb 3.3gb  
> yellow open logstash-2019.06.28 U430uIccRpmQEeldgTEopg 5 1 13671 0 14.1mb 14.1mb  
> yellow open logstash-2019.08.04 8K70cBewQ9m2kyunFR0Fnw 5 1 9712827 0 3.2gb 3.2gb  
> yellow open logstash-2019.08.02 fc4YutRjS\_S2s8TGlXwtBQ 5 1 10279012 0 3.7gb 3.7gb  
> green open .kibana\_task\_manager xnKBV\_MmSRabaCajI\_9esA 1 0 2 0 12.9kb 12.9kb  
> yellow open logstash-2019.06.26 2zgDKUUBSPeS5YSpWqL4SQ 5 1 6013 0 6mb 6mb  
> yellow open logstash-2019.07.18 KwVV5VQgQgaaDup-UA5Kxg 5 1 10294809 0 3.9gb 3.9gb  
> yellow open logstash-2019.08.06 SL7Zka4cRtiqNDy020eqSA 5 1 1698488 0 596.2mb 596.2mb  
> yellow open logstash-2019.07.25 6AYLP8CzQF6-CP7ywwunog 5 1 10452281 0 3.6gb 3.6gb  
> yellow open logstash-2019.07.21 xm31mDXvSpu\_Su7xsEp6PQ 5 1 10012414 0 3.4gb 3.4gb  
> yellow open logstash-2019.07.29 UaAQ1zcYRBm1PPtgyfKjYg 5 1 10975367 0 4.3gb 4.3gb  
> yellow open logstash-2019.07.28 1ugwhMfpSq6U22BwJ3MmfQ 5 1 9827911 0 3.3gb 3.3gb  
> yellow open logstash-2019.06.25 7hiw79RgROCSkk5sXdtS7Q 5 1 2870 0 4.7mb 4.7mb  
> yellow open logstash-2019.07.07 WicWZwu7RC2ZVdtcOEesBg 5 1 9720334 0 3.5gb 3.5gb  
> green open .kibana\_8 8M6UJL8YRf2p4Uv3qnQftg 1 0 87 1 85kb 85kb  
> yellow open logstash-2019.07.30 -TpSM\_BrQXKmVTghFSN5JQ 5 1 11823449 0 5gb 5gb  
> yellow open logstash-2019.07.26 3wcSdQLFSK2359m2ZOpCeA 5 1 10211976 0 3.6gb 3.6gb  
> yellow open .kibana-6 tzxLdJi8RTioz3Av0qIYVA 1 1 75 1 78.3kb 78.3kb  
> yellow open logstash-2019.07.24 H8Vp8ICiSDqhluGZpoILyw 5 1 10335395 0 3.7gb 3.7gb  
> yellow open logstash-2019.07.15 Aa4ptB3fQhmiAwupCJUnng 5 1 2412431 0 653.5mb 653.5mb  
> yellow open logstash-2019.07.06 knFlSPPPSj6z_-0ILMF4EQ 5 1 9525251 0 3.3gb 3.3gb  
> green open .kibana\_7 iF0d8s65Q6-CPU4KrrG4Sw 1 0 86 1 87.2kb 87.2kb  
> yellow open logstash-2019.08.05 OwgaYR7oQiulhssyzaU-qg 5 1 9996109 0 3.5gb 3.5gb  
> yellow open logstash-2019.07.10 YgwZRYdyTtif\_HOUm0zDLQ 5 1 1178881 0 307.1mb 307.1mb

I'm pretty sure that this is related to ILM because we have 2 ELK servers that are nearly identical, 1 for dev and 1 for prod. I've only tried to implement ILM on the dev server. curator is still functioning correctly on the prod server. I don't think anything else has changed, no changes to index names or anything like that.

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [August 8, 2019, 6:59pm UTC](https://discuss.elastic.co/t/curator-no-longer-working-i-think-its-related-to-a-failed-ilm-setup/194489/2 "2019-08-08T18:59:54Z")

</div>

Because it can collide with ILM, Curator will not touch indices associated with an ILM policy by default. This can be overridden by setting the option [`allow_ilm_indices: true`](https://www.elastic.co/guide/en/elasticsearch/client/curator/5.7/ilm-and-curator.html)

---

<div class="post-metadata">

**Author:** ![dfinn](https://avatars.discourse-cdn.com/v4/letter/d/8c91f0/32.png) [@dfinn](https://discuss.elastic.co/u/dfinn)\
**Post date:** [August 8, 2019, 9:35pm UTC](https://discuss.elastic.co/t/curator-no-longer-working-i-think-its-related-to-a-failed-ilm-setup/194489/3 "2019-08-08T21:35:00Z")

</div>

> [@theuntergeek](#):
>
> allow\_ilm\_indices: true

That did it, thanks @theuntergeek!

If anyone sees this and knows what's wrong with my ILM setup I'd love some tips on that as well.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 5, 2019, 9:35pm UTC](https://discuss.elastic.co/t/curator-no-longer-working-i-think-its-related-to-a-failed-ilm-setup/194489/4 "2019-09-05T21:35:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
