# Curator Repo Issue?

**URL:** https://discuss.elastic.co/t/curator-repo-issue/64541
**Category:** Elasticsearch
**Created:** [November 1, 2016, 10:42am UTC](https://discuss.elastic.co/t/curator-repo-issue/64541 "2016-11-01T10:42:26Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![jinal.shah](https://avatars.discourse-cdn.com/v4/letter/j/3da27b/32.png) [@jinal.shah](https://discuss.elastic.co/u/jinal.shah)
#### Post date: [November 1, 2016, 10:42am UTC](https://discuss.elastic.co/t/curator-repo-issue/64541/1 "2016-11-01T10:42:26Z")

</div>

Hello

I've been trying to install curator via yum (on CentOS 6) for a few days now but I keep getting the following error:

```
> Loaded plugins: fastestmirror
> Determining fastest mirrors
> epel/metalink | 24 kB 00:00
> * base: centos.hyve.com
> * elrepo: nl.mirror.babylon.network
> * epel: mirror.karneval.cz
> * extras: mirrors.coreix.net
> * rpmforge: mirror.lstn.net
> * updates: centos.hyve.com
> * webtatic: us-east.repo.webtatic.com
> curator-4/primary | 1.1 kB 00:00
> http://packages.elastic.co/curator/4/centos/6/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
> Trying other mirror.
> Error: failure: repodata/primary.xml.gz from curator-4: [Errno 256] No more mirrors to try.

```

And when you access the URL via web browser, you see the following message:

`<Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message><Key>kibana/4.6/centos</Key><RequestId>CEBC1BA87328E017</RequestId><HostId>U+kqyUwGZvAyv7IMGbp7Jrpfx5xqHG5MCbBxqfwMFFK6L9OTuxloJhodB8SLnX0v</HostId></Error>`

Is this an issue on the elastic side?

PS: This is the repo file:

[curator-4]  
name=CentOS/RHEL 6 repository for Elasticsearch Curator 4.x packages  
baseurl=http://packages.elastic.co/curator/4/centos/6  
gpgcheck=1  
gpgkey=http://packages.elastic.co/GPG-KEY-elasticsearch  
enabled=1

All followed from the guide here: [https://www.elastic.co/guide/en/elasticsearch/client/curator/current/yum-repository.html](https://www.elastic.co/guide/en/elasticsearch/client/curator/current/yum-repository.html)

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [November 1, 2016, 12:36pm UTC](https://discuss.elastic.co/t/curator-repo-issue/64541/2 "2016-11-01T12:36:52Z")

</div>

Thanks for reporting this. I will look into it.

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [November 1, 2016, 12:39pm UTC](https://discuss.elastic.co/t/curator-repo-issue/64541/3 "2016-11-01T12:39:38Z")

</div>

I re-published the repodata. Will you please try again and report?

---

<div class="post-metadata">

### Author: ![jinal.shah](https://avatars.discourse-cdn.com/v4/letter/j/3da27b/32.png) [@jinal.shah](https://discuss.elastic.co/u/jinal.shah)
#### Post date: [November 1, 2016, 1:46pm UTC](https://discuss.elastic.co/t/curator-repo-issue/64541/4 "2016-11-01T13:46:09Z")

</div>

Hello

I am still facing the issue:

```
sudo yum install elasticsearch-curator
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.econdc.com
 * elrepo: elrepo.mirrors.arminco.com
 * epel: mirror.slu.cz
 * extras: mirror.econdc.com
 * rpmforge: mirror.zetup.net
 * updates: centos.mirroring.pulsant.co.uk
 * webtatic: uk.repo.webtatic.com
curator-4 | 951 B 00:00
curator-4/primary | 1.1 kB 00:00
http://packages.elastic.co/curator/4/centos/6/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
curator-4/primary | 1.1 kB 00:00
http://packages.elastic.co/curator/4/centos/6/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from curator-4: [Errno 256] No more mirrors to try.

```

I cleared the yum cache and metadata but have had no luck.

Other repositories and apps are working OK. Such as Kibana, Logstash etc.

Regards  
Jinal

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [November 1, 2016, 2:46pm UTC](https://discuss.elastic.co/t/curator-repo-issue/64541/5 "2016-11-01T14:46:25Z")

</div>

Sounds like something on your end there:

```auto
[vagrant@localhost ~]$ sudo vim /etc/yum.repos.d/curator4.repo
[vagrant@localhost ~]$ sudo yum install elasticsearch-curator
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
epel/metalink | 13 kB 00:00
 * base: mirrors.unifiedlayer.com
 * epel: mirrors.xmission.com
 * extras: centos.mirrors.hoobly.com
 * updates: mirrors.kernel.org
base | 3.7 kB 00:00
curator-4 | 951 B 00:00
curator-4/primary | 5.4 kB 00:00
curator-4 28/28
epel | 4.3 kB 00:00
epel/primary_db | 5.9 MB 00:01
extras | 3.4 kB 00:00
logstash-5.x | 1.3 kB 00:00
puppetlabs-pc1 | 2.5 kB 00:00
puppetlabs-pc1/primary_db | 86 kB 00:00
updates | 3.4 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package elasticsearch-curator.x86_64 0:4.1.2-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package Arch Version Repository Size
================================================================================
Installing:
 elasticsearch-curator x86_64 4.1.2-1 curator-4 3.6 M

Transaction Summary
================================================================================
Install 1 Package(s)

Total download size: 3.6 M
Installed size: 7.5 M
Is this ok [y/N]: y
Downloading Packages:
elasticsearch-curator-4.1.2-1.x86_64.rpm | 3.6 MB 00:02
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : elasticsearch-curator-4.1.2-1.x86_64 1/1
  Verifying : elasticsearch-curator-4.1.2-1.x86_64 1/1

Installed:
  elasticsearch-curator.x86_64 0:4.1.2-1

Complete!

```

I just installed on a clean CentOS 6 machine. I'm not exactly sure what you're running into, but it installs just fine for me.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:07pm UTC](https://discuss.elastic.co/t/curator-repo-issue/64541/6 "2017-07-05T22:07:51Z")

</div>


