# Curator rpm offline installation

**URL:** https://discuss.elastic.co/t/curator-rpm-offline-installation/166816
**Category:** Elasticsearch
**Created:** [February 2, 2019, 9:27am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816 "2019-02-02T09:27:28Z")
**Posts on this page:** 13
**Page:** 1

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 2, 2019, 9:27am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/1 "2019-02-02T09:27:28Z")

</div>

hi all,  
I want to install rpm version of curator as offline, could you please advice me about this?  
Many thanks.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 2, 2019, 9:39am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/2 "2019-02-02T09:39:44Z")

</div>

[https://www.elastic.co/guide/en/elasticsearch/client/curator/current/yum-repository.html](https://www.elastic.co/guide/en/elasticsearch/client/curator/current/yum-repository.html) has links to the RPMs, are you having problems downloading them?

---

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 3, 2019, 5:28am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/3 "2019-02-03T05:28:00Z")

</div>

hi, many thanks for your replying,  
I downloaded "elasticsearch-curator-5.6.0-1.x86\_64.rpm" from following link and copy it in the VM where has no internet access  
[https://packages.elastic.co/curator/5/centos/6/Packages/elasticsearch-curator-5.6.0-1.x86\_64.rpm](https://packages.elastic.co/curator/5/centos/6/Packages/elasticsearch-curator-5.6.0-1.x86_64.rpm)

according to document, we should add following in /etc/yum.repos.d directory for CentOS 6:

```
[curator-5]
name=CentOS/RHEL 6 repository for Elasticsearch Curator 5.x packages
baseurl=https://packages.elastic.co/curator/5/centos/6
gpgcheck=1
gpgkey=https://packages.elastic.co/GPG-KEY-elasticsearch
enabled=1

```

but, it contains two addresses and my VM cannot access to internet. how can i handle this issue?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 3, 2019, 6:14am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/4 "2019-02-03T06:14:11Z")

</div>

You may want to look at the documentation for RPM, and how to refer to local install files.

---

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 13, 2019, 6:52am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/5 "2019-02-13T06:52:56Z")

</div>

many thanks.  
in order to download GPG-KEY-elasticsearch using windows cmd, i used following command:

`wget https://packages.elastic.co/GPG-KEY-elasticsearch`

which result following message. could you please advise me about this issue? many thanks.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/d/ad34e36acbebe1d7670ccd884075d2547f2e4393.png)

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 13, 2019, 7:03am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/6 "2019-02-13T07:03:38Z")

</div>

Are you running Windows or a RedHat distro?

---

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 13, 2019, 7:31am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/7 "2019-02-13T07:31:31Z")

</div>

dear warkolm  
i solved that issue, now i am using yum installation as following  
`yum install elasticsearch-curator`  
where a curator.repo has been created in /etc/yum.repos.d as following

```
[curator-5]
name=CentOS/RHEL 6 repository for Elasticsearch Curator 5.x packages
baseurl=file:///home/srahimi/files
gpgcheck=1
gpgkey=file:///home/srahimi/files/GPG-KEY-elasticsearch
enabled=1

```

where elasticsearch-curator-5.6.0-1.x86\_64.rpm and GPG-KEY-elasticsearch located in /home/files  
when i run (yum install elasticsearch-curator), following message can be found:

```
[root@localhost files]# yum install elasticsearch-curator -y
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
file:///home/srahimi/files/repodata/repomd.xml: [Errno 14] Could not open/read file:///home/srahimi/files/repodata/repomd.xml
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: curator-5. Please verify its path and try again

```

how can i handle this issue?

---

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 13, 2019, 9:46am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/8 "2019-02-13T09:46:26Z")

</div>

i get the repomd.xml from following link  
`http://packages.elastic.co/curator/5/centos/6/repodata/repomd.xml`  
and then save it as repomd.xml and copy to my VM in /home/srahimi/files/repodata folder.  
after that, i run (yum install elasticsearch-curator) which leads to following error:

```
[root@localhost sync_gateway]# yum install elasticsearch-curator
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
curator-5 | 1.2 kB 00:00 ... 
file:///home/srahimi/files/repodata/primary.xml.gz: [Errno 14] Could not open/read file:///home/srahimi/files/repodata/primary.xml.gz
Trying other mirror.
file:///home/srahimi/files/repodata/primary.xml.gz: [Errno 14] Could not open/read file:///home/srahimi/files/repodata/primary.xml.gz
Trying other mirror.
Error: failure: repodata/primary.xml.gz from curator-5: [Errno 256] No more mirrors to try.

```

any advice will be so appreciated

---

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 16, 2019, 2:18pm UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/9 "2019-02-16T14:18:36Z")

</div>

I will be so appreciated if anyone advises me?

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [February 16, 2019, 4:22pm UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/10 "2019-02-16T16:22:28Z")

</div>

You _can_ use yum to install locally, but it requires an additional flag:

```auto
yum localinstall /path/to/elasticsearch-curator-5.6.0-1.x86_64.rpm

```

Where `/path/to` is the path to the RPM file on your filesystem.

---

<div class="post-metadata">

### Author: ![sahere37](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@sahere37](https://discuss.elastic.co/u/sahere37)
#### Post date: [February 17, 2019, 3:55am UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/11 "2019-02-17T03:55:56Z")

</div>

dear Aaron,

I used (yum localinstall /.../elasticsearch-curator-5.6.0-1.x86\_64.rpm), but still give me the same error:

```auto
file:///home/srahimi/files/repodata/primary.xml.gz: [Errno 14] Could not open/read file:///home/srahimi/files/repodata/primary.xml.gz
Trying other mirror.
file:///home/srahimi/files/repodata/primary.xml.gz: [Errno 14] Could not open/read file:///home/srahimi/files/repodata/primary.xml.gz
Trying other mirror.
Error: failure: repodata/primary.xml.gz from curator-5: [Errno 256] No more mirrors to try.

```

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [February 17, 2019, 2:36pm UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/13 "2019-02-17T14:36:59Z")

</div>

Option c is to just use the RPM command:

```auto
rpm -ivh elasticsearch-curator-5.6.0-1.x86_64.rpm

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 17, 2019, 2:42pm UTC](https://discuss.elastic.co/t/curator-rpm-offline-installation/166816/14 "2019-03-17T14:42:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
