# Curator snapshot fails

**URL:** <https://discuss.elastic.co/t/curator-snapshot-fails/35198>\
**Category:** Elasticsearch\
**Created:** [November 21, 2015, 3:23am UTC](https://discuss.elastic.co/t/curator-snapshot-fails/35198 "2015-11-21T03:23:07Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bluethundr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bluethundr/32/409_2.png) [@bluethundr](https://discuss.elastic.co/u/bluethundr)\
**Post date:** [November 21, 2015, 3:23am UTC](https://discuss.elastic.co/t/curator-snapshot-fails/35198/1 "2015-11-21T03:23:07Z")

</div>

Hey all,

Trying to backup my ES indexes using curator.

I tried this approach, and failed:

```
[root@logs:~] #curator --http_auth "admin:$ES_PASS" snapshot --repository jf_backup --prefix jokefire- --ignore_unavailable --partial indices --all-indices
2015-11-20 22:21:07,530 INFO Job starting: snapshot indices
2015-11-20 22:21:07,530 WARNING Overriding default connection timeout. New timeout: 21600
2015-11-20 22:21:07,546 INFO Matching all indices. Ignoring flags other than --exclude.
2015-11-20 22:21:07,546 INFO Action snapshot will be performed on the following indices: [u'.kibana', u'logstash-2015.11.19', u'logstash-2015.11.21']
2015-11-20 22:21:07,748 ERROR Failed to verify all nodes have repository access.
2015-11-20 22:21:07,749 WARNING Job did not complete successfully.

```

Just wondering how I can alter that command so that it'll work. Any suggestions?

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [November 21, 2015, 3:40am UTC](https://discuss.elastic.co/t/curator-snapshot-fails/35198/2 "2015-11-21T03:40:24Z")

</div>

> [@bluethundr](#):
>
> Failed to verify all nodes have repository access.

This means that Curator was unable to verify that each node had write access to the shared file system. What kind of shared filesystem is your repository?

---

<div class="post-metadata">

**Author:** ![bluethundr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bluethundr/32/409_2.png) [@bluethundr](https://discuss.elastic.co/u/bluethundr)\
**Post date:** [November 21, 2015, 5:33pm UTC](https://discuss.elastic.co/t/curator-snapshot-fails/35198/3 "2015-11-21T17:33:51Z")

</div>

Hey Aaron,

Yeah, I was using the same NFS share on each volume to store the snapshots. Turns out that volume was maxed out, so that's why I was getting that error. So I cleared out some space and ran the snapshot again. Glad I was able to resolve the problem and thanks for your input!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:36pm UTC](https://discuss.elastic.co/t/curator-snapshot-fails/35198/4 "2017-07-05T23:36:46Z")

</div>


