# Curator version for Elastic 5.2.0

**URL:** <https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832>\
**Category:** Elasticsearch\
**Created:** [March 16, 2017, 10:07am UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832 "2017-03-16T10:07:32Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ankit\_Pradhan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ankit_pradhan/32/44412_2.png) [@Ankit\_Pradhan](https://discuss.elastic.co/u/Ankit_Pradhan)\
**Post date:** [March 16, 2017, 10:07am UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832/1 "2017-03-16T10:07:32Z")

</div>

I have installed Curator 4.2.6 and trying to connect to Elastic 5.2.0

But it refuses to connect, see error below:

Unable to create client connection to Elasticsearch. Error: TransportError(503, '{\n "name" : "lrv160gk",\n "cluster\_name" : "gmtt-dev",\n "cluster \_uuid" : "eGMk7xLlTxyTkyxe40mebw",\n "version" : {\n "number" : "5.2.0",\n "build\_hash" : "24e05b9",\n "build\_date" : "2017-01-24T19:52:35.80 0Z",\n "build\_snapshot" : false,\n "lucene\_version" : "6.4.0"\n },\n "tagline" : "You Know, for Search"\n}\n')

It seems like curator 4.2.6 can only connect to ES 5 and not ES 5.2.0

Which version of Curator can support ES 5.2.0?  
I see that on Elastic website, Curator 5 is mentioned but all links for download the same are broken it seems.

Help !! Help !!

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [March 16, 2017, 1:46pm UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832/2 "2017-03-16T13:46:24Z")

</div>

Curator 5.0 has not yet been released, and there is a message indicating that at the top of the page, if you're browsing through the 5.0 documentation.

That said, Curator version 4.2.6 will work with Elasticsearch 5.2.0 just fine:

```auto
$ curl esclient:9200
{
  "name" : "esclient",
  "cluster_name" : "untergeek",
  "cluster_uuid" : "7OfiDNTsTJqiHTK4_ghIsA",
  "version" : {
    "number" : "5.2.0",
    "build_hash" : "24e05b9",
    "build_date" : "2017-01-24T19:52:35.800Z",
    "build_snapshot" : false,
    "lucene_version" : "6.4.0"
  },
  "tagline" : "You Know, for Search"
}

```

And the `curator_cli` output:

```auto
$ curator_cli --version
curator_cli, version 4.2.6
$ curator_cli --host esclient show_indices
.kibana
.monitoring-data-2
.monitoring-es-2-2017.03.10
.monitoring-es-2-2017.03.11
.monitoring-es-2-2017.03.12
... (many more indices)

```

A 503 transport error is not very informative without more context. A 503 error suggests "Service Unavailable" in some way. What does your configuration look like?

---

<div class="post-metadata">

**Author:** ![Ankit\_Pradhan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ankit_pradhan/32/44412_2.png) [@Ankit\_Pradhan](https://discuss.elastic.co/u/Ankit_Pradhan)\
**Post date:** [March 16, 2017, 2:09pm UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832/3 "2017-03-16T14:09:32Z")

</div>

Thanks ...  
The issue is resolved because the Elastic server was in itself not available at the moment of test. ☹

I missed though the ''to be released'' message 😉

Actually the line which says curator-4.2.6 is not compatible with all commands of ES-5 confused me and i thought it is that reason why it is not connecting with 5.2.0

---

<div class="post-metadata">

**Author:** ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)\
**Post date:** [March 16, 2017, 2:13pm UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832/4 "2017-03-16T14:13:01Z")

</div>

> [@Ankit\_Pradhan](#):
>
> the line which says curator-4.2.6 is not compatible with all commands of ES-5 confused me

Apologies for that. It will become clear when Curator 5 is released. The rollover API and the reindex API are just two examples of things which will be in Curator 5 but not supported in Curator 4, even though Curator 4 works with Elasticsearch v5. Hope that clarifies that statement a bit.

---

<div class="post-metadata">

**Author:** ![mrkschan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrkschan/32/5386_2.png) [@mrkschan](https://discuss.elastic.co/u/mrkschan)\
**Post date:** [March 23, 2017, 1:37am UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832/5 "2017-03-23T01:37:11Z")

</div>

@theuntergeek any idea when will this PR be released [https://github.com/elastic/curator/pull/896](https://github.com/elastic/curator/pull/896)? That's blocking the setup of hot/warm elasticsearch cluster setup.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 20, 2017, 1:37am UTC](https://discuss.elastic.co/t/curator-version-for-elastic-5-2-0/78832/6 "2017-04-20T01:37:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
