# Curl: (77) error setting certificate verify locations:

**URL:** https://discuss.elastic.co/t/curl-77-error-setting-certificate-verify-locations/308945
**Category:** Elasticsearch
**Created:** [July 5, 2022, 4:44pm UTC](https://discuss.elastic.co/t/curl-77-error-setting-certificate-verify-locations/308945 "2022-07-05T16:44:06Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![CBrad](https://avatars.discourse-cdn.com/v4/letter/c/96bed5/32.png) [@CBrad](https://discuss.elastic.co/u/CBrad)
#### Post date: [July 5, 2022, 4:44pm UTC](https://discuss.elastic.co/t/curl-77-error-setting-certificate-verify-locations/308945/1 "2022-07-05T16:44:06Z")

</div>

I am installing Elasticsearch on Amazon Linux 2 EC2 instances, and using the latest version of ES 8.2.3. When I run:

```auto
sudo systemctl status elasticsearch.service

```

ES shows as running on all three, but when I check:

```auto
$ curl --cacert /etc/elasticsearch/certs/http_ca.crt -u elastic https://localhost:9200

```

I get

```auto
curl: (77) error setting certificate verify locations: CAfile: /etc/elasticsearch/certs/http_ca.crt CApath: none

```

I am very new to ES, any guidance on this issue?

---

<div class="post-metadata">

### Author: ![CBrad](https://avatars.discourse-cdn.com/v4/letter/c/96bed5/32.png) [@CBrad](https://discuss.elastic.co/u/CBrad)
#### Post date: [July 5, 2022, 5:38pm UTC](https://discuss.elastic.co/t/curl-77-error-setting-certificate-verify-locations/308945/2 "2022-07-05T17:38:05Z")

</div>

Sort of resolved, had to run the sudo the curl command. Now I am getting a different issue that I have yet to research.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 2, 2022, 5:38pm UTC](https://discuss.elastic.co/t/curl-77-error-setting-certificate-verify-locations/308945/3 "2022-08-02T17:38:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
